summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2016-08-24 10:56:36 -0400
committerMike Gilbert <floppym@gentoo.org>2016-08-24 12:27:55 -0400
commit8678d7ac2872fc1345a99f3c649d1c3a9b797a5a (patch)
tree7d1826eb83795c9a8b62dd205aad63b5de953d58 /net-fs/s3fs/s3fs-1.78.ebuild
parentdev-util/bcc: revbump to 0.1.8-r2 for changed RDEPEND (diff)
downloadgentoo-8678d7ac2872fc1345a99f3c649d1c3a9b797a5a.tar.gz
gentoo-8678d7ac2872fc1345a99f3c649d1c3a9b797a5a.tar.bz2
gentoo-8678d7ac2872fc1345a99f3c649d1c3a9b797a5a.zip
net-fs/s3fs: move from sys-fs/s3fs
Diffstat (limited to 'net-fs/s3fs/s3fs-1.78.ebuild')
-rw-r--r--net-fs/s3fs/s3fs-1.78.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-fs/s3fs/s3fs-1.78.ebuild b/net-fs/s3fs/s3fs-1.78.ebuild
new file mode 100644
index 000000000000..34cc4f8a7480
--- /dev/null
+++ b/net-fs/s3fs/s3fs-1.78.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+MY_PN=${PN}-fuse
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Amazon mounting S3 via fuse"
+HOMEPAGE="https://github.com/s3fs-fuse/s3fs-fuse/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND=">=dev-libs/libxml2-2.6:2
+ dev-libs/openssl
+ >=net-misc/curl-7.0
+ >=sys-fs/fuse-2.8.4"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ eautoreconf
+}