summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDongsu Park <dongsu@kinvolk.io>2021-02-18 17:10:07 +0100
committerLars Wendler <polynomial-c@gentoo.org>2021-02-26 12:38:42 +0100
commit7401f52198730785b3548c3d82b61046cdb60375 (patch)
treed69cd91e50166db75ad2d6fa5ea17f5b0b8b24ec /net-fs/samba
parentarch/arm64/package.use.mask: remove obsolete mask for dev-libs/xmlrpc-c[tools] (diff)
downloadgentoo-7401f52198730785b3548c3d82b61046cdb60375.tar.gz
gentoo-7401f52198730785b3548c3d82b61046cdb60375.tar.bz2
gentoo-7401f52198730785b3548c3d82b61046cdb60375.zip
net-fs/samba: new USE flags spotlight, regedit, glusterfs, ntvfs
Introduce a USE flag spotlight, to be able to disable the spotlight backend by default, as it is not needed by Linux. Introduce a USE flag rededit, to be able to disable the rededit tool if needed. Introduce a USE flag glusterfs, to be able to disable the glusterfs by default. Introduce a USE flag ntvfs, to be able to disable the ntvfs-fileserver by default. Since the docbook-xsl-stylesheets and libxslt are needed only at build time, we should move those deps to BDEPEND. Signed-off-by: Dongsu Park <dongsu@kinvolk.io> Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-fs/samba')
-rw-r--r--net-fs/samba/metadata.xml4
-rw-r--r--net-fs/samba/samba-4.12.11.ebuild21
-rw-r--r--net-fs/samba/samba-4.12.9-r1.ebuild21
-rw-r--r--net-fs/samba/samba-4.13.3-r1.ebuild14
-rw-r--r--net-fs/samba/samba-4.13.4.ebuild14
-rw-r--r--net-fs/samba/samba-4.14.0_rc3.ebuild14
6 files changed, 69 insertions, 19 deletions
diff --git a/net-fs/samba/metadata.xml b/net-fs/samba/metadata.xml
index d1bb8bfdd510..e871aa5724b6 100644
--- a/net-fs/samba/metadata.xml
+++ b/net-fs/samba/metadata.xml
@@ -16,12 +16,16 @@
<flag name="client">Enables the client part</flag>
<flag name="cluster">Enable support for clustering</flag>
<flag name="dmapi">Enable support for DMAPI. This currently works only in combination with XFS.</flag>
+ <flag name="glusterfs">Enable support for Glusterfs filesystem via <pkg>sys-cluster/glusterfs</pkg></flag>
<flag name="gpg">Use <pkg>app-crypt/gpgme</pkg> for AD DC</flag>
<flag name="json">Enable json audit support through <pkg>dev-libs/jansson</pkg></flag>
<flag name="iprint">Enabling iPrint technology by Novell</flag>
+ <flag name="ntvfs">Enable support for NTVFS fileserver</flag>
<flag name="profiling-data">Enables support for collecting profiling data</flag>
<flag name="quota">Enables support for user quotas</flag>
+ <flag name="regedit">Enable support for regedit command-line tool</flag>
<flag name="snapper">Enable vfs_snapper module (requires <pkg>sys-apps/dbus</pkg>)</flag>
+ <flag name="spotlight">Enable support for spotlight backend</flag>
<flag name="system-heimdal">Use <pkg>app-crypt/heimdal</pkg> instead of
bundled heimdal.</flag>
<flag name="system-mitkrb5">Use <pkg>app-crypt/mit-krb5</pkg> instead of
diff --git a/net-fs/samba/samba-4.12.11.ebuild b/net-fs/samba/samba-4.12.11.ebuild
index 4945e097198f..4c218a5d0893 100644
--- a/net-fs/samba/samba-4.12.11.ebuild
+++ b/net-fs/samba/samba-4.12.11.ebuild
@@ -23,9 +23,10 @@ LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam gpg iprint
-json ldap pam profiling-data python quota selinux snapper syslog
-system-heimdal +system-mitkrb5 systemd test winbind zeroconf"
+IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam glusterfs
+gpg iprint json ldap ntvfs pam profiling-data python quota +regedit selinux
+snapper spotlight syslog system-heimdal +system-mitkrb5 systemd test winbind
+zeroconf"
MULTILIB_WRAPPED_HEADERS=(
/usr/include/samba-4.0/policy.h
@@ -89,8 +90,6 @@ CDEPEND="
"
DEPEND="${CDEPEND}
${PYTHON_DEPS}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
>=dev-util/cmocka-1.1.3[${MULTILIB_USEDEP}]
net-libs/libtirpc[${MULTILIB_USEDEP}]
virtual/pkgconfig
@@ -98,6 +97,7 @@ DEPEND="${CDEPEND}
net-libs/rpcsvc-proto
<sys-libs/glibc-2.26[rpc(+)]
)
+ spotlight? ( dev-libs/glib )
test? (
!system-mitkrb5? (
>=sys-libs/nss_wrapper-1.1.3
@@ -112,12 +112,19 @@ RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-samba )
"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+"
+
REQUIRED_USE="
addc? ( python json winbind )
addns? ( python )
ads? ( acl ldap winbind )
cluster? ( ads )
gpg? ( addc )
+ ntvfs? ( addc )
+ spotlight? ( json )
test? ( python )
?? ( system-heimdal system-mitkrb5 )
${PYTHON_REQUIRED_USE}
@@ -208,13 +215,17 @@ multilib_src_configure() {
$(multilib_native_use_enable cups)
$(multilib_native_use_with dmapi)
$(multilib_native_use_with fam)
+ $(multilib_native_use_enable glusterfs)
$(multilib_native_use_with gpg gpgme)
$(multilib_native_use_with json)
$(multilib_native_use_enable iprint)
+ $(multilib_native_use_with ntvfs ntvfs-fileserver)
$(multilib_native_use_with pam)
$(multilib_native_usex pam "--with-pammodulesdir=${EPREFIX}/$(get_libdir)/security" '')
$(multilib_native_use_with quota quotas)
+ $(multilib_native_use_with regedit)
$(multilib_native_use_enable snapper)
+ $(multilib_native_use_enable spotlight)
$(multilib_native_use_with syslog)
$(multilib_native_use_with systemd)
--systemd-install-services
diff --git a/net-fs/samba/samba-4.12.9-r1.ebuild b/net-fs/samba/samba-4.12.9-r1.ebuild
index c63729651021..84df21f0f498 100644
--- a/net-fs/samba/samba-4.12.9-r1.ebuild
+++ b/net-fs/samba/samba-4.12.9-r1.ebuild
@@ -23,9 +23,10 @@ LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam gpg iprint
-json ldap pam profiling-data python quota selinux snapper syslog
-system-heimdal +system-mitkrb5 systemd test winbind zeroconf"
+IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam glusterfs
+gpg iprint json ldap ntvfs pam profiling-data python quota +regedit selinux
+snapper spotlight syslog system-heimdal +system-mitkrb5 systemd test winbind
+zeroconf"
MULTILIB_WRAPPED_HEADERS=(
/usr/include/samba-4.0/policy.h
@@ -89,8 +90,6 @@ CDEPEND="
"
DEPEND="${CDEPEND}
${PYTHON_DEPS}
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
>=dev-util/cmocka-1.1.3[${MULTILIB_USEDEP}]
net-libs/libtirpc[${MULTILIB_USEDEP}]
virtual/pkgconfig
@@ -98,6 +97,7 @@ DEPEND="${CDEPEND}
net-libs/rpcsvc-proto
<sys-libs/glibc-2.26[rpc(+)]
)
+ spotlight? ( dev-libs/glib )
test? (
!system-mitkrb5? (
>=sys-libs/nss_wrapper-1.1.3
@@ -112,12 +112,19 @@ RDEPEND="${CDEPEND}
selinux? ( sec-policy/selinux-samba )
"
+BDEPEND="
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+"
+
REQUIRED_USE="
addc? ( python json winbind )
addns? ( python )
ads? ( acl ldap winbind )
cluster? ( ads )
gpg? ( addc )
+ ntvfs? ( addc )
+ spotlight? ( json )
test? ( python )
?? ( system-heimdal system-mitkrb5 )
${PYTHON_REQUIRED_USE}
@@ -209,13 +216,17 @@ multilib_src_configure() {
$(multilib_native_use_enable cups)
$(multilib_native_use_with dmapi)
$(multilib_native_use_with fam)
+ $(multilib_native_use_enable glusterfs)
$(multilib_native_use_with gpg gpgme)
$(multilib_native_use_with json)
$(multilib_native_use_enable iprint)
+ $(multilib_native_use_with ntvfs ntvfs-fileserver)
$(multilib_native_use_with pam)
$(multilib_native_usex pam "--with-pammodulesdir=${EPREFIX}/$(get_libdir)/security" '')
$(multilib_native_use_with quota quotas)
+ $(multilib_native_use_with regedit)
$(multilib_native_use_enable snapper)
+ $(multilib_native_use_enable spotlight)
$(multilib_native_use_with syslog)
$(multilib_native_use_with systemd)
--systemd-install-services
diff --git a/net-fs/samba/samba-4.13.3-r1.ebuild b/net-fs/samba/samba-4.13.3-r1.ebuild
index f5512a97a1a3..315792bf5681 100644
--- a/net-fs/samba/samba-4.13.3-r1.ebuild
+++ b/net-fs/samba/samba-4.13.3-r1.ebuild
@@ -22,9 +22,10 @@ S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam gpg iprint
-json ldap pam profiling-data python quota selinux snapper syslog
-system-heimdal +system-mitkrb5 systemd test winbind zeroconf"
+IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam glusterfs
+gpg iprint json ldap ntvfs pam profiling-data python quota +regedit selinux
+snapper spotlight syslog system-heimdal +system-mitkrb5 systemd test winbind
+zeroconf"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
addc? ( python json winbind )
@@ -32,6 +33,8 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
ads? ( acl ldap winbind )
cluster? ( ads )
gpg? ( addc )
+ ntvfs? ( addc )
+ spotlight? ( json )
test? ( python )
!ads? ( !addc )
?? ( system-heimdal system-mitkrb5 )
@@ -113,6 +116,7 @@ DEPEND="${COMMON_DEPEND}
net-libs/rpcsvc-proto
<sys-libs/glibc-2.26[rpc(+)]
)
+ spotlight? ( dev-libs/glib )
test? (
!system-mitkrb5? (
>=net-dns/resolv_wrapper-1.1.4
@@ -209,12 +213,16 @@ multilib_src_configure() {
$(multilib_native_use_enable cups)
$(multilib_native_use_with dmapi)
$(multilib_native_use_with fam)
+ $(multilib_native_use_enable glusterfs)
$(multilib_native_use_with gpg gpgme)
$(multilib_native_use_with json)
$(multilib_native_use_enable iprint)
+ $(multilib_native_use_with ntvfs ntvfs-fileserver)
$(multilib_native_use_with pam)
$(multilib_native_usex pam "--with-pammodulesdir=${EPREFIX}/$(get_libdir)/security" '')
$(multilib_native_use_with quota quotas)
+ $(multilib_native_use_with regedit)
+ $(multilib_native_use_enable spotlight)
$(multilib_native_use_with syslog)
$(multilib_native_use_with systemd)
--systemd-install-services
diff --git a/net-fs/samba/samba-4.13.4.ebuild b/net-fs/samba/samba-4.13.4.ebuild
index f5512a97a1a3..315792bf5681 100644
--- a/net-fs/samba/samba-4.13.4.ebuild
+++ b/net-fs/samba/samba-4.13.4.ebuild
@@ -22,9 +22,10 @@ S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam gpg iprint
-json ldap pam profiling-data python quota selinux snapper syslog
-system-heimdal +system-mitkrb5 systemd test winbind zeroconf"
+IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam glusterfs
+gpg iprint json ldap ntvfs pam profiling-data python quota +regedit selinux
+snapper spotlight syslog system-heimdal +system-mitkrb5 systemd test winbind
+zeroconf"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
addc? ( python json winbind )
@@ -32,6 +33,8 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
ads? ( acl ldap winbind )
cluster? ( ads )
gpg? ( addc )
+ ntvfs? ( addc )
+ spotlight? ( json )
test? ( python )
!ads? ( !addc )
?? ( system-heimdal system-mitkrb5 )
@@ -113,6 +116,7 @@ DEPEND="${COMMON_DEPEND}
net-libs/rpcsvc-proto
<sys-libs/glibc-2.26[rpc(+)]
)
+ spotlight? ( dev-libs/glib )
test? (
!system-mitkrb5? (
>=net-dns/resolv_wrapper-1.1.4
@@ -209,12 +213,16 @@ multilib_src_configure() {
$(multilib_native_use_enable cups)
$(multilib_native_use_with dmapi)
$(multilib_native_use_with fam)
+ $(multilib_native_use_enable glusterfs)
$(multilib_native_use_with gpg gpgme)
$(multilib_native_use_with json)
$(multilib_native_use_enable iprint)
+ $(multilib_native_use_with ntvfs ntvfs-fileserver)
$(multilib_native_use_with pam)
$(multilib_native_usex pam "--with-pammodulesdir=${EPREFIX}/$(get_libdir)/security" '')
$(multilib_native_use_with quota quotas)
+ $(multilib_native_use_with regedit)
+ $(multilib_native_use_enable spotlight)
$(multilib_native_use_with syslog)
$(multilib_native_use_with systemd)
--systemd-install-services
diff --git a/net-fs/samba/samba-4.14.0_rc3.ebuild b/net-fs/samba/samba-4.14.0_rc3.ebuild
index 08b7f93199df..197b80e67973 100644
--- a/net-fs/samba/samba-4.14.0_rc3.ebuild
+++ b/net-fs/samba/samba-4.14.0_rc3.ebuild
@@ -22,9 +22,10 @@ S="${WORKDIR}/${MY_P}"
LICENSE="GPL-3"
SLOT="0"
-IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam gpg iprint
-json ldap pam profiling-data python quota selinux snapper syslog
-system-heimdal +system-mitkrb5 systemd test winbind zeroconf"
+IUSE="acl addc addns ads ceph client cluster cups debug dmapi fam glusterfs
+gpg iprint json ldap ntvfs pam profiling-data python quota +regedit selinux
+snapper spotlight syslog system-heimdal +system-mitkrb5 systemd test winbind
+zeroconf"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
addc? ( python json winbind )
@@ -32,6 +33,8 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
ads? ( acl ldap winbind )
cluster? ( ads )
gpg? ( addc )
+ ntvfs? ( addc )
+ spotlight? ( json )
test? ( python )
!ads? ( !addc )
?? ( system-heimdal system-mitkrb5 )
@@ -113,6 +116,7 @@ DEPEND="${COMMON_DEPEND}
net-libs/rpcsvc-proto
<sys-libs/glibc-2.26[rpc(+)]
)
+ spotlight? ( dev-libs/glib )
test? (
!system-mitkrb5? (
>=net-dns/resolv_wrapper-1.1.4
@@ -209,12 +213,16 @@ multilib_src_configure() {
$(multilib_native_use_enable cups)
$(multilib_native_use_with dmapi)
$(multilib_native_use_with fam)
+ $(multilib_native_use_enable glusterfs)
$(multilib_native_use_with gpg gpgme)
$(multilib_native_use_with json)
$(multilib_native_use_enable iprint)
+ $(multilib_native_use_with ntvfs ntvfs-fileserver)
$(multilib_native_use_with pam)
$(multilib_native_usex pam "--with-pammodulesdir=${EPREFIX}/$(get_libdir)/security" '')
$(multilib_native_use_with quota quotas)
+ $(multilib_native_use_with regedit)
+ $(multilib_native_use_enable spotlight)
$(multilib_native_use_with syslog)
$(multilib_native_use_with systemd)
--systemd-install-services