summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-fs/wdfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-fs/wdfs')
-rw-r--r--net-fs/wdfs/Manifest1
-rw-r--r--net-fs/wdfs/files/wdfs-1.4.2-fix-Waddress.patch40
-rw-r--r--net-fs/wdfs/metadata.xml13
-rw-r--r--net-fs/wdfs/wdfs-1.4.2-r1.ebuild25
-rw-r--r--net-fs/wdfs/wdfs-1.4.2.ebuild21
5 files changed, 100 insertions, 0 deletions
diff --git a/net-fs/wdfs/Manifest b/net-fs/wdfs/Manifest
new file mode 100644
index 000000000000..d71114c141b4
--- /dev/null
+++ b/net-fs/wdfs/Manifest
@@ -0,0 +1 @@
+DIST wdfs-1.4.2.tar.gz 109315 SHA256 fcf2e1584568b07c7f3683a983a9be26fae6534b8109e09167e5dff9114ba2e5 SHA512 da7e16ed86cbe4746fabe5fce44c83b1d0cd0fbc19994eefe0ce2a75f3d8c77c3c341a76409150a3509be08f8c0d28b8a9650037edcbbf2aa60f4c8ea5407004 WHIRLPOOL 0306bc45e174a627bf9b728a631e3e34135ccd2773b22ff0f9fde1342a03b724bdcc97b5c60ff55ed47337df0099ff62083d90828583e27519af96ebbd2efc1a
diff --git a/net-fs/wdfs/files/wdfs-1.4.2-fix-Waddress.patch b/net-fs/wdfs/files/wdfs-1.4.2-fix-Waddress.patch
new file mode 100644
index 000000000000..0f35776bdebc
--- /dev/null
+++ b/net-fs/wdfs/files/wdfs-1.4.2-fix-Waddress.patch
@@ -0,0 +1,40 @@
+diff --git a/src/wdfs-main.c b/src/wdfs-main.c
+index 9bd5244..a9917b7 100644
+--- a/src/wdfs-main.c
++++ b/src/wdfs-main.c
+@@ -697,7 +697,7 @@ static int wdfs_open(const char *localpath, struct fuse_file_info *fi)
+ ">> %s() by PID %d\n", __func__, fuse_get_context()->pid);
+ }
+
+- assert(localpath && &fi);
++ assert(localpath && fi);
+
+ struct open_file *file = g_new0(struct open_file, 1);
+ file->modified = false;
+@@ -763,7 +763,7 @@ static int wdfs_read(
+ if (wdfs.debug == true)
+ print_debug_infos(__func__, localpath);
+
+- assert(localpath && buf && &fi);
++ assert(localpath && buf && fi);
+
+ struct open_file *file = (struct open_file*)(uintptr_t)fi->fh;
+
+@@ -785,7 +785,7 @@ static int wdfs_write(
+ if (wdfs.debug == true)
+ print_debug_infos(__func__, localpath);
+
+- assert(localpath && buf && &fi);
++ assert(localpath && buf && fi);
+
+ /* data below svn_basedir is read-only */
+ if (wdfs.svn_mode == true && g_str_has_prefix(localpath, svn_basedir))
+@@ -961,7 +961,7 @@ static int wdfs_ftruncate(
+ if (wdfs.debug == true)
+ print_debug_infos(__func__, localpath);
+
+- assert(localpath && &fi);
++ assert(localpath && fi);
+
+ /* data below svn_basedir is read-only */
+ if (wdfs.svn_mode == true && g_str_has_prefix(localpath, svn_basedir))
diff --git a/net-fs/wdfs/metadata.xml b/net-fs/wdfs/metadata.xml
new file mode 100644
index 000000000000..19a60cdb2753
--- /dev/null
+++ b/net-fs/wdfs/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ wdfs is a webdav filesystem that makes it possible to mount a webdav
+ share under linux, freebsd and apple mac os x. wdfs has some special
+ features for accessing subversion repositories via webdav. it's based on
+ fuse and neon.
+ </longdescription>
+</pkgmetadata>
diff --git a/net-fs/wdfs/wdfs-1.4.2-r1.ebuild b/net-fs/wdfs/wdfs-1.4.2-r1.ebuild
new file mode 100644
index 000000000000..336ba5dcc695
--- /dev/null
+++ b/net-fs/wdfs/wdfs-1.4.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="WebDAV filesystem with special features for accessing subversion repositories"
+HOMEPAGE="http://noedler.de/projekte/wdfs/"
+SRC_URI="http://noedler.de/projekte/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=net-libs/neon-0.24.7
+ >=sys-fs/fuse-2.5
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-Waddress.patch"
+}
diff --git a/net-fs/wdfs/wdfs-1.4.2.ebuild b/net-fs/wdfs/wdfs-1.4.2.ebuild
new file mode 100644
index 000000000000..2d8a766b6d4d
--- /dev/null
+++ b/net-fs/wdfs/wdfs-1.4.2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="WebDAV filesystem with special features for accessing subversion repositories"
+HOMEPAGE="http://noedler.de/projekte/wdfs/"
+SRC_URI="http://noedler.de/projekte/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=net-libs/neon-0.24.7
+ >=sys-fs/fuse-2.5"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog AUTHORS NEWS README
+}