summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-01-12 10:16:20 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-01-12 10:16:36 +0100
commit3e77c54440c06967eeae9283c87a5702b0010f41 (patch)
tree4d91328a34cb8230583f1629f2fcdf17140c1ccc /net-fs
parentapp-text/djview: bump to 4.10.5 (diff)
downloadgentoo-3e77c54440c06967eeae9283c87a5702b0010f41.tar.gz
gentoo-3e77c54440c06967eeae9283c87a5702b0010f41.tar.bz2
gentoo-3e77c54440c06967eeae9283c87a5702b0010f41.zip
net-fs/samba: Minor formatting fixes.
Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/samba-4.2.7-r1.ebuild116
-rw-r--r--net-fs/samba/samba-4.3.3-r1.ebuild116
2 files changed, 120 insertions, 112 deletions
diff --git a/net-fs/samba/samba-4.2.7-r1.ebuild b/net-fs/samba/samba-4.2.7-r1.ebuild
index b7ff879b95d4..6686a68e6c86 100644
--- a/net-fs/samba/samba-4.2.7-r1.ebuild
+++ b/net-fs/samba/samba-4.2.7-r1.ebuild
@@ -93,14 +93,14 @@ pkg_setup() {
python-single-r1_pkg_setup
if use aio ; then
if ! linux_config_exists || ! linux_chkconfig_present AIO; then
- ewarn "You must enable AIO support in your kernel config, "
- ewarn "to be able to support asynchronous I/O. "
- ewarn "You can find it at"
- ewarn
- ewarn "General Support"
- ewarn " Enable AIO support "
- ewarn
- ewarn "and recompile your kernel..."
+ ewarn "You must enable AIO support in your kernel config, "
+ ewarn "to be able to support asynchronous I/O. "
+ ewarn "You can find it at"
+ ewarn
+ ewarn "General Support"
+ ewarn " Enable AIO support "
+ ewarn
+ ewarn "and recompile your kernel..."
fi
fi
}
@@ -127,54 +127,58 @@ multilib_src_configure() {
--nopyc
--nopyo
)
- if multilib_is_native_abi ; then myconf+=(
- $(use_with acl acl-support)
- $(usex addc '' '--without-ad-dc')
- $(use_with addns dnsupdate)
- $(use_with ads)
- $(usex ads '--with-shared-modules=idmap_ad' '')
- $(use_with aio aio-support)
- $(usex cluster '--with-ctdb-dir=/usr' '')
- $(use_enable avahi)
- $(use_with cluster cluster-support)
- $(use_enable cups)
- $(use_with dmapi)
- $(use_with fam)
- $(use_enable gnutls)
- $(use_enable iprint)
- $(use_with ldap)
- $(use_with pam)
- $(use_with pam pam_smbpass)
- $(usex pam "--with-pammodulesdir=/$(get_libdir)/security" '')
- $(use_with quota quotas)
- $(use_with syslog)
- $(use_with systemd)
- $(usex system-mitkrb5 '--with-system-mitkrb5' '')
- $(use_with winbind)
- $(usex test '--enable-selftest' '')
- ); else myconf+=(
- --without-acl-support
- --without-ad-dc
- --without-dnsupdate
- --without-ads
- --without-aio-support
- --disable-avahi
- --without-cluster-support
- --disable-cups
- --without-dmapi
- --without-fam
- --disable-gnutls
- --disable-iprint
- --without-ldap
- --without-pam
- --without-pam_smbpass
- --without-quotas
- --without-syslog
- --without-systemd
- $(usex system-mitkrb5 '--with-system-mitkrb5' '')
- --without-winbind
- --disable-python
- ); fi
+ if multilib_is_native_abi ; then
+ myconf+=(
+ $(use_with acl acl-support)
+ $(usex addc '' '--without-ad-dc')
+ $(use_with addns dnsupdate)
+ $(use_with ads)
+ $(usex ads '--with-shared-modules=idmap_ad' '')
+ $(use_with aio aio-support)
+ $(usex cluster '--with-ctdb-dir=/usr' '')
+ $(use_enable avahi)
+ $(use_with cluster cluster-support)
+ $(use_enable cups)
+ $(use_with dmapi)
+ $(use_with fam)
+ $(use_enable gnutls)
+ $(use_enable iprint)
+ $(use_with ldap)
+ $(use_with pam)
+ $(use_with pam pam_smbpass)
+ $(usex pam "--with-pammodulesdir=/$(get_libdir)/security" '')
+ $(use_with quota quotas)
+ $(use_with syslog)
+ $(use_with systemd)
+ $(usex system-mitkrb5 '--with-system-mitkrb5' '')
+ $(use_with winbind)
+ $(usex test '--enable-selftest' '')
+ )
+ else
+ myconf+=(
+ --without-acl-support
+ --without-ad-dc
+ --without-dnsupdate
+ --without-ads
+ --without-aio-support
+ --disable-avahi
+ --without-cluster-support
+ --disable-cups
+ --without-dmapi
+ --without-fam
+ --disable-gnutls
+ --disable-iprint
+ --without-ldap
+ --without-pam
+ --without-pam_smbpass
+ --without-quotas
+ --without-syslog
+ --without-systemd
+ $(usex system-mitkrb5 '--with-system-mitkrb5' '')
+ --without-winbind
+ --disable-python
+ )
+ fi
CPPFLAGS="-I${SYSROOT}/usr/include/et ${CPPFLAGS}" \
waf-utils_src_configure ${myconf[@]}
diff --git a/net-fs/samba/samba-4.3.3-r1.ebuild b/net-fs/samba/samba-4.3.3-r1.ebuild
index 0b93ae7878fc..d7769ae0435e 100644
--- a/net-fs/samba/samba-4.3.3-r1.ebuild
+++ b/net-fs/samba/samba-4.3.3-r1.ebuild
@@ -92,14 +92,14 @@ pkg_setup() {
python-single-r1_pkg_setup
if use aio ; then
if ! linux_config_exists || ! linux_chkconfig_present AIO; then
- ewarn "You must enable AIO support in your kernel config, "
- ewarn "to be able to support asynchronous I/O. "
- ewarn "You can find it at"
- ewarn
- ewarn "General Support"
- ewarn " Enable AIO support "
- ewarn
- ewarn "and recompile your kernel..."
+ ewarn "You must enable AIO support in your kernel config, "
+ ewarn "to be able to support asynchronous I/O. "
+ ewarn "You can find it at"
+ ewarn
+ ewarn "General Support"
+ ewarn " Enable AIO support "
+ ewarn
+ ewarn "and recompile your kernel..."
fi
fi
}
@@ -126,54 +126,58 @@ multilib_src_configure() {
--nopyc
--nopyo
)
- if multilib_is_native_abi ; then myconf+=(
- $(use_with acl acl-support)
- $(usex addc '' '--without-ad-dc')
- $(use_with addns dnsupdate)
- $(use_with ads)
- $(usex ads '--with-shared-modules=idmap_ad' '')
- $(use_with aio aio-support)
- $(usex cluster '--with-ctdb-dir=/usr' '')
- $(use_enable avahi)
- $(use_with cluster cluster-support)
- $(use_enable cups)
- $(use_with dmapi)
- $(use_with fam)
- $(use_enable gnutls)
- $(use_enable iprint)
- $(use_with ldap)
- $(use_with pam)
- $(use_with pam pam_smbpass)
- $(usex pam "--with-pammodulesdir=/$(get_libdir)/security" '')
- $(use_with quota quotas)
- $(use_with syslog)
- $(use_with systemd)
- $(usex system-mitkrb5 '--with-system-mitkrb5' '')
- $(use_with winbind)
- $(usex test '--enable-selftest' '')
- ); else myconf+=(
- --without-acl-support
- --without-ad-dc
- --without-dnsupdate
- --without-ads
- --without-aio-support
- --disable-avahi
- --without-cluster-support
- --disable-cups
- --without-dmapi
- --without-fam
- --disable-gnutls
- --disable-iprint
- --without-ldap
- --without-pam
- --without-pam_smbpass
- --without-quotas
- --without-syslog
- --without-systemd
- $(usex system-mitkrb5 '--with-system-mitkrb5' '')
- --without-winbind
- --disable-python
- ); fi
+ if multilib_is_native_abi ; then
+ myconf+=(
+ $(use_with acl acl-support)
+ $(usex addc '' '--without-ad-dc')
+ $(use_with addns dnsupdate)
+ $(use_with ads)
+ $(usex ads '--with-shared-modules=idmap_ad' '')
+ $(use_with aio aio-support)
+ $(usex cluster '--with-ctdb-dir=/usr' '')
+ $(use_enable avahi)
+ $(use_with cluster cluster-support)
+ $(use_enable cups)
+ $(use_with dmapi)
+ $(use_with fam)
+ $(use_enable gnutls)
+ $(use_enable iprint)
+ $(use_with ldap)
+ $(use_with pam)
+ $(use_with pam pam_smbpass)
+ $(usex pam "--with-pammodulesdir=/$(get_libdir)/security" '')
+ $(use_with quota quotas)
+ $(use_with syslog)
+ $(use_with systemd)
+ $(usex system-mitkrb5 '--with-system-mitkrb5' '')
+ $(use_with winbind)
+ $(usex test '--enable-selftest' '')
+ )
+ else
+ myconf+=(
+ --without-acl-support
+ --without-ad-dc
+ --without-dnsupdate
+ --without-ads
+ --without-aio-support
+ --disable-avahi
+ --without-cluster-support
+ --disable-cups
+ --without-dmapi
+ --without-fam
+ --disable-gnutls
+ --disable-iprint
+ --without-ldap
+ --without-pam
+ --without-pam_smbpass
+ --without-quotas
+ --without-syslog
+ --without-systemd
+ $(usex system-mitkrb5 '--with-system-mitkrb5' '')
+ --without-winbind
+ --disable-python
+ )
+ fi
CPPFLAGS="-I${SYSROOT}/usr/include/et ${CPPFLAGS}" \
waf-utils_src_configure ${myconf[@]}