summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-12-23 21:22:51 -0700
committerTim Harder <radhermit@gentoo.org>2020-12-23 21:27:28 -0700
commita1e7a920cdd53a51bd419040738f3f64c5295110 (patch)
treeed83ee0c6556d3cdd3b3c5e9a16f7028b7da7af9 /net-fs
parentdev-python/python-libevdev: Version bump to 0.9 (diff)
downloadgentoo-a1e7a920cdd53a51bd419040738f3f64c5295110.tar.gz
gentoo-a1e7a920cdd53a51bd419040738f3f64c5295110.tar.bz2
gentoo-a1e7a920cdd53a51bd419040738f3f64c5295110.zip
net-fs/sshfs: version bump to 3.7.1
Closes: https://bugs.gentoo.org/758965 Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/sshfs/Manifest1
-rw-r--r--net-fs/sshfs/sshfs-3.7.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/net-fs/sshfs/Manifest b/net-fs/sshfs/Manifest
index bdb6947f93e8..b92f5ff678f7 100644
--- a/net-fs/sshfs/Manifest
+++ b/net-fs/sshfs/Manifest
@@ -1 +1,2 @@
DIST sshfs-3.7.0.tar.xz 52724 BLAKE2B be974475692e8f9a4d0653776b7b7dc62c6beb1a300caf62c55cbc6bb72fedcf08cdd2c65f051415df57e6e2b21e5a3cb00e8525585c40ab92b0bd0b3474ac77 SHA512 bd8bcd45dd9a5e9686c6fb442e877ffdb592ba0d3424d5dab84a955bfafb17e8666abefba6857467833f5b285842bdadd5a9b6c9e8128ac2e564c36df79aa570
+DIST sshfs-3.7.1.tar.xz 52988 BLAKE2B 48fd9b1483a8f4d48e3d9d25dc13c6e265ca3cb623762b2721b955db52fc05a6138cd0fef684e8893c3b380041ac30ecb3df4c5716b067f621790730fa07be08 SHA512 ee91b2eacbad5891006dbac14188ddd591e242b6092c7b7d8234503d79acb52f4b7ea9a15d5eaad83597ff4b4e700580ee2271671edfa6db762d9a8c756d45fd
diff --git a/net-fs/sshfs/sshfs-3.7.1.ebuild b/net-fs/sshfs/sshfs-3.7.1.ebuild
new file mode 100644
index 000000000000..8fbd75eb7eae
--- /dev/null
+++ b/net-fs/sshfs/sshfs-3.7.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service"
+HOMEPAGE="https://github.com/libfuse/sshfs"
+SRC_URI="https://github.com/libfuse/${PN}/releases/download/${P}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+
+DEPEND=">=sys-fs/fuse-3.1.0:3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${DEPEND}
+ >=net-misc/openssh-4.4"
+BDEPEND="dev-python/docutils
+ virtual/pkgconfig"
+
+# requires root privs and specific localhost sshd setup
+RESTRICT="test"
+
+DOCS=( AUTHORS ChangeLog.rst README.rst )