summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-18 00:40:19 +0100
committerSam James <sam@gentoo.org>2022-06-18 00:44:54 +0100
commitdab861a0e0f33ba400fa937b2b1f368081a589da (patch)
treea5affacb88ca3d06a17d5f297872cb41c63b3e76 /net-fs
parentdev-libs/libmaa: Fix the build with rlibtool (diff)
downloadgentoo-dab861a0e0f33ba400fa937b2b1f368081a589da.tar.gz
gentoo-dab861a0e0f33ba400fa937b2b1f368081a589da.tar.bz2
gentoo-dab861a0e0f33ba400fa937b2b1f368081a589da.zip
net-fs/nfs4-acl-tools: strip patch; add new revision
(Was mangling it to do the changes in a revbump and didn't actually add the new version!) Bug: https://bugs.gentoo.org/731162 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/nfs4-acl-tools/files/nfs4-acl-tools-0.3.7-libtool.patch16
-rw-r--r--net-fs/nfs4-acl-tools/nfs4-acl-tools-0.3.7-r1.ebuild27
2 files changed, 29 insertions, 14 deletions
diff --git a/net-fs/nfs4-acl-tools/files/nfs4-acl-tools-0.3.7-libtool.patch b/net-fs/nfs4-acl-tools/files/nfs4-acl-tools-0.3.7-libtool.patch
index 60ce83af59a9..7eb4d67e552d 100644
--- a/net-fs/nfs4-acl-tools/files/nfs4-acl-tools-0.3.7-libtool.patch
+++ b/net-fs/nfs4-acl-tools/files/nfs4-acl-tools-0.3.7-libtool.patch
@@ -1,3 +1,5 @@
+https://bugs.gentoo.org/731162
+
From 2abd5015bf6bac1697ac4422d76fa121a49f2b24 Mon Sep 17 00:00:00 2001
From: orbea <orbea@riseup.net>
Date: Fri, 17 Jun 2022 12:36:01 -0700
@@ -10,14 +12,6 @@ determine if it should build static or shared libraries.
The existing make and libtool tests were removed as unnecessary and
problematic.
----
- configure.ac | 3 +++
- include/builddefs.in | 3 ++-
- m4/package_utilies.m4 | 20 --------------------
- 3 files changed, 5 insertions(+), 21 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index c624295..bc3dac8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,6 +9,9 @@ AC_ARG_ENABLE(shared,
@@ -30,8 +24,6 @@ index c624295..bc3dac8 100644
AC_PROG_INSTALL
AC_PROG_CC
-diff --git a/include/builddefs.in b/include/builddefs.in
-index fe49b08..3cc85ec 100644
--- a/include/builddefs.in
+++ b/include/builddefs.in
@@ -39,6 +39,8 @@ DEBUG = @debug_build@
@@ -51,8 +43,6 @@ index fe49b08..3cc85ec 100644
ECHO = @echo@
SORT = @sort@
LN_S = @LN_S@
-diff --git a/m4/package_utilies.m4 b/m4/package_utilies.m4
-index fe54e21..431c9bc 100644
--- a/m4/package_utilies.m4
+++ b/m4/package_utilies.m4
@@ -22,26 +22,6 @@ AC_DEFUN([AC_PACKAGE_UTILITIES],
@@ -82,5 +72,3 @@ index fe54e21..431c9bc 100644
if test -z "$TAR"; then
AC_PATH_PROG(TAR, tar,, /usr/freeware/bin:/bin:/usr/local/bin:/usr/bin)
fi
---
-2.35.1
diff --git a/net-fs/nfs4-acl-tools/nfs4-acl-tools-0.3.7-r1.ebuild b/net-fs/nfs4-acl-tools/nfs4-acl-tools-0.3.7-r1.ebuild
new file mode 100644
index 000000000000..e6d5317ee8cc
--- /dev/null
+++ b/net-fs/nfs4-acl-tools/nfs4-acl-tools-0.3.7-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Commandline and GUI tools that deal directly with NFSv4 ACLs"
+HOMEPAGE="https://git.linux-nfs.org/?p=bfields/nfs4-acl-tools.git;a=summary"
+SRC_URI="https://linux-nfs.org/~bfields/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-apps/attr"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-libtool.patch # bug #731162
+ "${FILESDIR}"/${PN}-0.3.5-jobserver-unavailable.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}