summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-03-20 22:55:06 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2017-03-20 22:55:06 +0100
commitf835b4ae0f845df06633802314b7d9ac6a83da4c (patch)
tree8298210523750cd3b648a4075e9fff31dd1e0c16 /net-ftp/filezilla
parentdev-perl/LWP-Protocol-https: Bump to version 6.70.0 (diff)
downloadgentoo-f835b4ae0f845df06633802314b7d9ac6a83da4c.tar.gz
gentoo-f835b4ae0f845df06633802314b7d9ac6a83da4c.tar.bz2
gentoo-f835b4ae0f845df06633802314b7d9ac6a83da4c.zip
net-ftp/filezilla: 3.25.1 bump
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'net-ftp/filezilla')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.25.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index e38a21538d27..5eab33825f51 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -3,3 +3,4 @@ DIST FileZilla_3.14.1_src.tar.bz2 4411187 SHA256 b10871b6ced5f52062b44deda037edb
DIST FileZilla_3.24.0_src.tar.bz2 4635977 SHA256 3d5dd4899cdeca038afd330f24098a61a223f15b172611e0c210244911cd4cad SHA512 e5e7fcf1d1c33053775d09ee9a3c0bac1286b4ed5aee1af47498ec2d860bd0571b8e2a35443119d3ebe61a8eea4fb236edb0e7d9dc6a1b37b823902828620ea0 WHIRLPOOL 41abe64523852b45c7ca7e8bf54ed92d749fb4af289b4cdfd0bfa7399dbcd4f135bdc5329b26306b2a04e98c9790b38945c82566db200de8d741603044ba61a1
DIST FileZilla_3.24.1_src.tar.bz2 4645630 SHA256 e6dd748c7ec067c1165683ebe81325ce6c561f4725963a9515494af346a30c2a SHA512 7a3f871278ad35a9237e7a8e16c4b7becadd29bb3385dd528a645c96a36c9451d7e798da43bfe57de4064206605750a9184494ff8ff233511a4be09b6265bffd WHIRLPOOL 344fff6628ef3f281784b729aa913b33dcff0cc275d389886fb0913aa2d36407362fbe69b36071ded1923a8ccc14fe6304a418b3d69f37649d5401abefdd5d69
DIST FileZilla_3.25.0_src.tar.bz2 4707698 SHA256 104e5f302dfef72cf9d235a880da159c93c9378ebfc48487ef07a1ba7f5834ac SHA512 efaf92b3705394a310dd2026095b0b44e54182e508e3fa6838944f7d2bca8f053f4242c8138385b1e4fd33837476c34173a33e234be0faaaec9fdc9a7b0fbb79 WHIRLPOOL edd44203e72603072e82f47eb1b78397f707b7d22ecd18706bfdb8a37cdc882a09e808b19c0c742bec2d7979067d532425fcbeafdf952310eef4b8d3cb103eb4
+DIST FileZilla_3.25.1_src.tar.bz2 4707839 SHA256 8873be716059cf7425b72dba5d130ea2a1ec62a769b4ada41f6c7313a2112fc1 SHA512 fbaa5184c21a06884db68befec8a30971a620744114ba0d12f701999210e2448ae88267c0631bbed0abeef302c6f2d80033a8f70ed548a5dd05f74cd5567a64b WHIRLPOOL 6ab1b5a6a3177fbb74bc5db588ee9dd053bbe66a0ddaa90a5e602b37acfb9444275033e3bfbbdc5cc2d169b8218cdf797a9cd693c29c0b070f0110c2eab66869
diff --git a/net-ftp/filezilla/filezilla-3.25.1.ebuild b/net-ftp/filezilla/filezilla-3.25.1.ebuild
new file mode 100644
index 000000000000..17003f08647e
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.25.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0"
+
+inherit autotools eutils flag-o-matic multilib wxwidgets
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="http://filezilla-project.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.9.1
+ >=dev-libs/pugixml-1.7
+ net-dns/libidn
+ >=net-libs/gnutls-3.4.0
+ >=x11-libs/wxGTK-3.0.2.0-r1:3.0[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( dev-util/cppunit )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with dbus) $(use_enable nls locales) \
+ --with-pugixml=system \
+ --disable-autoupdatecheck
+}