summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-03-03 13:26:11 +0100
committerJeroen Roovers <jer@gentoo.org>2019-03-03 14:11:05 +0100
commit97e3267240185760244506ad14b13d6f9e3ccc2f (patch)
treead0356d52e15b04b7fdb8136ba8fd4bdb91f3851 /net-ftp/lftp/lftp-9999.ebuild
parentnet-libs/srt: Version Bump (diff)
downloadgentoo-97e3267240185760244506ad14b13d6f9e3ccc2f.tar.gz
gentoo-97e3267240185760244506ad14b13d6f9e3ccc2f.tar.bz2
gentoo-97e3267240185760244506ad14b13d6f9e3ccc2f.zip
net-ftp/lftp: EAPI bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-ftp/lftp/lftp-9999.ebuild')
-rw-r--r--net-ftp/lftp/lftp-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/net-ftp/lftp/lftp-9999.ebuild b/net-ftp/lftp/lftp-9999.ebuild
index 4f73a82a139b..ae490e6c7f39 100644
--- a/net-ftp/lftp/lftp-9999.ebuild
+++ b/net-ftp/lftp/lftp-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit autotools eutils git-r3 libtool
+EAPI=7
+inherit autotools git-r3 libtool xdg-utils
DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
HOMEPAGE="https://lftp.tech/"
@@ -95,3 +95,11 @@ src_install() {
use ${script} || { rm "${ED}"/usr/share/${PN}/${script} || die ;}
done
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}