summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-02-05 15:59:59 +0100
committerJeroen Roovers <jer@gentoo.org>2018-02-05 16:01:19 +0100
commitcee0bfb56f78270a1a4deaf8de03c8afb428d6a9 (patch)
treed8e5338245ccc6a78f2266a0f93a64fbfca04947 /net-ftp/lftp/lftp-9999.ebuild
parentwww-client/opera-developer: Old. (diff)
downloadgentoo-cee0bfb56f78270a1a4deaf8de03c8afb428d6a9.tar.gz
gentoo-cee0bfb56f78270a1a4deaf8de03c8afb428d6a9.tar.bz2
gentoo-cee0bfb56f78270a1a4deaf8de03c8afb428d6a9.zip
net-ftp/lftp: Remove all LDFLAGS=.*-L.*\/lib (bug #646284).
Diffstat (limited to 'net-ftp/lftp/lftp-9999.ebuild')
-rw-r--r--net-ftp/lftp/lftp-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/net-ftp/lftp/lftp-9999.ebuild b/net-ftp/lftp/lftp-9999.ebuild
index 75206b992406..d8dca66a3ca7 100644
--- a/net-ftp/lftp/lftp-9999.ebuild
+++ b/net-ftp/lftp/lftp-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit autotools eutils git-r3 libtool multilib
+inherit autotools eutils git-r3 libtool
DESCRIPTION="A sophisticated ftp/sftp/http/https/torrent client and file transfer program"
HOMEPAGE="https://lftp.tech/"
@@ -19,7 +19,7 @@ RDEPEND="
dev-libs/expat
sys-libs/zlib
convert-mozilla-cookies? ( dev-perl/DBI )
- idn? ( net-dns/libidn )
+ idn? ( net-dns/libidn2 )
socks5? (
>=net-proxy/dante-1.1.12
virtual/pam
@@ -52,6 +52,12 @@ DOCS=(
)
PATCHES=(
"${FILESDIR}"/${PN}-4.5.5-am_config_header.patch
+ "${FILESDIR}"/${PN}-4.7.5-libdir-expat.patch
+ "${FILESDIR}"/${PN}-4.7.5-libdir-readline.patch
+ "${FILESDIR}"/${PN}-4.8.2-libdir-configure.patch
+ "${FILESDIR}"/${PN}-4.8.2-libdir-libidn2.patch
+ "${FILESDIR}"/${PN}-4.8.2-libdir-openssl.patch
+ "${FILESDIR}"/${PN}-4.8.2-libdir-zlib.patch
)
src_prepare() {
@@ -69,12 +75,11 @@ src_configure() {
econf \
$(use_enable ipv6) \
$(use_enable nls) \
- $(use_with idn libidn) \
+ $(use_with idn libidn2) \
$(use_with socks5 socksdante "${EPREFIX}"/usr) \
$(usex ssl "$(use_with !gnutls openssl ${EPREFIX}/usr)" '--without-openssl') \
$(usex ssl "$(use_with gnutls)" '--without-gnutls') \
--enable-packager-mode \
- --libdir="${EPREFIX}/usr/$(get_libdir)" \
--sysconfdir="${EPREFIX}"/etc/${PN} \
--with-modules \
--with-readline="${EPREFIX}"/usr \