summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-07-15 10:42:57 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2017-07-15 10:43:24 +0100
commit941ea3724bb21d7c1d56e000876627343a6d0157 (patch)
tree9394e219066cacd3c8f761d4c24648f895f8fa4b /net-ftp/proftpd
parentdev-python/pythondialog: ia64 stable, bug #625064 (diff)
downloadgentoo-941ea3724bb21d7c1d56e000876627343a6d0157.tar.gz
gentoo-941ea3724bb21d7c1d56e000876627343a6d0157.tar.bz2
gentoo-941ea3724bb21d7c1d56e000876627343a6d0157.zip
net-ftp/proftpd: unconditionally enable USE=trace, disable broken tests, bug #624570
Reported-by: Toralf Förster Bug: https://bugs.gentoo.org/624570 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-ftp/proftpd')
-rw-r--r--net-ftp/proftpd/files/proftpd-1.3.6-use-trace.patch18
-rw-r--r--net-ftp/proftpd/proftpd-1.3.6.ebuild8
2 files changed, 24 insertions, 2 deletions
diff --git a/net-ftp/proftpd/files/proftpd-1.3.6-use-trace.patch b/net-ftp/proftpd/files/proftpd-1.3.6-use-trace.patch
new file mode 100644
index 000000000000..c7d918425636
--- /dev/null
+++ b/net-ftp/proftpd/files/proftpd-1.3.6-use-trace.patch
@@ -0,0 +1,18 @@
+Make --disable-trace a build-time failure instead of link-time one.
+
+Reported-by: Toralf Förster
+Bug: https://bugs.gentoo.org/624570
+diff --git a/include/trace.h b/include/trace.h
+index f05dd0e..398e939 100644
+--- a/include/trace.h
++++ b/include/trace.h
+@@ -29,2 +29,4 @@
+
++#ifdef PR_USE_TRACE
++
+ #define PR_TRACE_DEFAULT_CHANNEL "DEFAULT"
+@@ -64,2 +66,4 @@ int pr_trace_vmsg(const char *, int, const char *, va_list);
+
++#endif /* PR_USE_TRACE */
++
+ #endif /* PR_TRACE_H */
diff --git a/net-ftp/proftpd/proftpd-1.3.6.ebuild b/net-ftp/proftpd/proftpd-1.3.6.ebuild
index 2c767eb641b5..fffba1c6c266 100644
--- a/net-ftp/proftpd/proftpd-1.3.6.ebuild
+++ b/net-ftp/proftpd/proftpd-1.3.6.ebuild
@@ -30,7 +30,7 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd
IUSE="acl authfile ban +caps case clamav copy ctrls deflate diskuse doc dso dynmasq exec ifsession ifversion ident ipv6
kerberos ldap libressl linguas_bg_BG linguas_en_US linguas_fr_FR linguas_it_IT linguas_ja_JP linguas_ko_KR
linguas_ru_RU linguas_zh_CN linguas_zh_TW log_forensic memcache msg mysql ncurses nls pam +pcre postgres qos radius
- ratio readme rewrite selinux sftp shaper sitemisc snmp softquota sqlite ssl tcpd test trace unique_id vroot xinetd"
+ ratio readme rewrite selinux sftp shaper sitemisc snmp softquota sqlite ssl tcpd test unique_id vroot xinetd"
# TODO: geoip
REQUIRED_USE="ban? ( ctrls )
msg? ( ctrls )
@@ -63,6 +63,10 @@ RDEPEND="${CDEPEND}
S="${WORKDIR}/${P/_/}"
+PATCHES=("${FILESDIR}"/${PN}-1.3.6-use-trace.patch)
+
+RESTRICT=test # tests corrupt memory. need to be fixed upstream first
+
in_dir() {
pushd "${WORKDIR}/${1}" || die
shift
@@ -218,7 +222,7 @@ src_configure() {
$(use_enable pam auth-pam) \
$(use_enable pcre) \
$(use_enable test tests) \
- $(use_enable trace) \
+ --enable-trace \
$(use_enable userland_GNU shadow) \
$(use_enable userland_GNU autoshadow) \
${c:1}