summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-01-11 13:38:07 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-01-11 13:38:40 +0100
commitb1a2de0657453482c3965e157e29bffdada55dda (patch)
treecbc41a5b5c321f7f24a2494dba798d881e158dd7 /net-ftp/pure-ftpd
parentnet-ftp/pure-ftpd: Fixed segfault on login with newer glibc. (diff)
downloadgentoo-b1a2de0657453482c3965e157e29bffdada55dda.tar.gz
gentoo-b1a2de0657453482c3965e157e29bffdada55dda.tar.bz2
gentoo-b1a2de0657453482c3965e157e29bffdada55dda.zip
net-ftp/pure-ftpd: Removed old.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-ftp/pure-ftpd')
-rw-r--r--net-ftp/pure-ftpd/Manifest1
-rw-r--r--net-ftp/pure-ftpd/pure-ftpd-1.0.46.ebuild136
2 files changed, 0 insertions, 137 deletions
diff --git a/net-ftp/pure-ftpd/Manifest b/net-ftp/pure-ftpd/Manifest
index d75bb5a74c66..469d95112c38 100644
--- a/net-ftp/pure-ftpd/Manifest
+++ b/net-ftp/pure-ftpd/Manifest
@@ -1,3 +1,2 @@
DIST pure-ftpd-1.0.45.tar.bz2 497695 BLAKE2B c905675253d992757e44baf1fae42d8363789ce3eb4d71d6f0e5c994a63efd307af69fb81aadb1875f0f2da952c0b3c8fbbc79c9c5c0b22c2d2f82029b417f11 SHA512 bb22b6b88778e2586411318905aa165e590185f7a87ac30761d6250f4de22a1deec6be5441926eae28011d3a5a923bad2ac366e237cc96a4d7932e3dbc9a1f2a
-DIST pure-ftpd-1.0.46.tar.bz2 490337 BLAKE2B c0b1fcbf46343dd49fcc9ecec44807c9474ecaf29869f67bfebfd722e0fd9947e8c2e84d5123afcdf6d219d527700f317affd44f3610a6dec46a1cea7ab0a433 SHA512 e44c1842e6f101f4d7dd42617392f3d54ff58d68608f6a3bc5e612fc89bfd1da6935215a7e87c0d2bbd9fc9f0fa31a40ceb764fd67428dfdd8c5454e0d64e0ab
DIST pure-ftpd-1.0.47.tar.bz2 489177 BLAKE2B 06e71ead47b87dedf47a84e488b2de127fcd297c2e9ca7a617c2ee2760cf55b816884763721826c512558d016cbd38a87a11ca0e8c2334d93145edc6f88d9287 SHA512 c1920a3f67f04635fde600fe226a7730b801e7e64658b25f1d9f9c0b35a704664be4adfb0b291594f7e0f10beade25eae9a5e6cc3b6777a3b413f3c2d9574e63
diff --git a/net-ftp/pure-ftpd/pure-ftpd-1.0.46.ebuild b/net-ftp/pure-ftpd/pure-ftpd-1.0.46.ebuild
deleted file mode 100644
index 0666f54ec764..000000000000
--- a/net-ftp/pure-ftpd/pure-ftpd-1.0.46.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils flag-o-matic
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-
-DESCRIPTION="Fast, production-quality, standard-conformant FTP server"
-HOMEPAGE="http://www.pureftpd.org/"
-SRC_URI="ftp://ftp.pureftpd.org/pub/${PN}/releases/${P}.tar.bz2
- http://download.pureftpd.org/pub/${PN}/releases/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-
-IUSE="anondel anonperm anonren anonres caps charconv implicittls ldap libressl mysql noiplog pam paranoidmsg postgres resolveids selinux ssl sysquota vchroot xinetd"
-
-REQUIRED_USE="implicittls? ( ssl )"
-
-DEPEND="caps? ( sys-libs/libcap )
- charconv? ( virtual/libiconv )
- ldap? ( >=net-nds/openldap-2.0.25 )
- mysql? ( virtual/mysql )
- pam? ( virtual/pam )
- postgres? ( dev-db/postgresql:= )
- ssl? (
- !libressl? ( >=dev-libs/openssl-0.9.6g:0=[-bindist] )
- libressl? ( dev-libs/libressl:= )
- )
- sysquota? ( sys-fs/quota[-rpc] )
- xinetd? ( virtual/inetd )"
-
-RDEPEND="${DEPEND}
- dev-libs/libsodium:=
- net-ftp/ftpbase
- selinux? ( sec-policy/selinux-ftp )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0.28-pam.patch
-)
-
-src_configure() {
- # adjust max user length to something more appropriate
- # for virtual hosts. See bug #62472 for details.
- sed -e "s:# define MAX_USER_LENGTH 32U:# define MAX_USER_LENGTH 127U:" \
- -i "${S}/src/ftpd.h" || die "sed failed"
-
- # Those features are only configurable like this, see bug #179375.
- use anondel && append-cppflags -DANON_CAN_DELETE
- use anonperm && append-cppflags -DANON_CAN_CHANGE_PERMS
- use anonren && append-cppflags -DANON_CAN_RENAME
- use anonres && append-cppflags -DANON_CAN_RESUME
- use resolveids && append-cppflags -DALWAYS_RESOLVE_IDS
-
- # Do not auto-use SSP -- let the user select this.
- export ax_cv_check_cflags___fstack_protector_all=no
-
- local myeconfargs=(
- --enable-largefile
- --with-altlog
- --with-cookie
- --with-diraliases
- --with-extauth
- --with-ftpwho
- --with-language=${PUREFTPD_LANG:=english}
- --with-peruserlimits
- --with-privsep
- --with-puredb
- --with-quotas
- --with-ratios
- --with-throttling
- --with-uploadscript
- --with-virtualhosts
- $(use_with charconv rfc2640)
- $(use_with ldap)
- $(use_with mysql)
- $(use_with pam)
- $(use_with paranoidmsg)
- $(use_with postgres pgsql)
- $(use_with ssl tls)
- $(use_with implicittls)
- $(use_with vchroot virtualchroot)
- $(use_with sysquota sysquotas)
- $(usex caps '' '--without-capabilities')
- $(usex noiplog '--without-iplogging' '')
- $(usex xinetd '' '--without-inetd')
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- local DOCS=( AUTHORS CONTACT ChangeLog FAQ HISTORY INSTALL README* NEWS )
-
- default
-
- newinitd "${FILESDIR}/pure-ftpd.rc11" ${PN}
- newconfd "${FILESDIR}/pure-ftpd.conf_d-3" ${PN}
-
- if use implicittls ; then
- sed -i '/^SERVER/s@21@990@' "${ED}"/etc/conf.d/${PN} \
- || die "Adjusting default server port for implicittls usage failed!"
- fi
-
- keepdir /var/lib/run/${PN}
-
- if use xinetd ; then
- insinto /etc/xinetd.d
- newins "${FILESDIR}/pure-ftpd.xinetd" ${PN}
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema
- doins pureftpd.schema
- insinto /etc/openldap
- insopts -m 0600
- doins pureftpd-ldap.conf
- fi
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- # This is a new installation
- elog
- elog "Before starting Pure-FTPd, you have to edit the /etc/conf.d/pure-ftpd file!"
- elog
- ewarn "It's *really* important to read the README provided with Pure-FTPd!"
- ewarn "Check out http://download.pureftpd.org/pub/pure-ftpd/doc/README for general info"
- ewarn "and http://download.pureftpd.org/pub/pure-ftpd/doc/README.TLS for SSL/TLS info."
- ewarn
- if use charconv ; then
- ewarn "Charset conversion is an *experimental* feature!"
- ewarn "Remember to set a valid charset for your filesystem in the configuration!"
- fi
- fi
-}