summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-ftp/tlswrap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-ftp/tlswrap')
-rw-r--r--net-ftp/tlswrap/Manifest1
-rw-r--r--net-ftp/tlswrap/files/tlswrap.init20
-rw-r--r--net-ftp/tlswrap/metadata.xml9
-rw-r--r--net-ftp/tlswrap/tlswrap-1.04.ebuild30
4 files changed, 60 insertions, 0 deletions
diff --git a/net-ftp/tlswrap/Manifest b/net-ftp/tlswrap/Manifest
new file mode 100644
index 000000000000..87905cfdc3d5
--- /dev/null
+++ b/net-ftp/tlswrap/Manifest
@@ -0,0 +1 @@
+DIST tlswrap-1.04.tar.gz 129507 SHA256 d10b8b45276695f5357d3e46212b8708a6baf42c83c5e4f4a263801890ac34b4
diff --git a/net-ftp/tlswrap/files/tlswrap.init b/net-ftp/tlswrap/files/tlswrap.init
new file mode 100644
index 000000000000..fd4eea954af5
--- /dev/null
+++ b/net-ftp/tlswrap/files/tlswrap.init
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting tlswrap"
+ start-stop-daemon --start --exec /usr/bin/tlswrap >/dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping tlswrap"
+ start-stop-daemon --stop --exec /usr/sbin/tlswrap
+ eend $?
+}
diff --git a/net-ftp/tlswrap/metadata.xml b/net-ftp/tlswrap/metadata.xml
new file mode 100644
index 000000000000..7a92e30a3922
--- /dev/null
+++ b/net-ftp/tlswrap/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-ftp</herd>
+ <longdescription lang="en">
+ TLSWRAP is a TLS/SSL FTP wrapper/proxy which allows to use TLS with
+ every FTP client
+ </longdescription>
+</pkgmetadata>
diff --git a/net-ftp/tlswrap/tlswrap-1.04.ebuild b/net-ftp/tlswrap/tlswrap-1.04.ebuild
new file mode 100644
index 000000000000..f5105e2eb7a8
--- /dev/null
+++ b/net-ftp/tlswrap/tlswrap-1.04.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="TLSWRAP is a TLS/SSL FTP wrapper/proxy which allows to use TLS with every FTP client"
+HOMEPAGE="http://tlswrap.sunsite.dk"
+SRC_URI="http://tlswrap.sunsite.dk/${P}.tar.gz"
+
+# GPL-2 for Gentoo init script
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/openssl-0.9.7"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodoc ChangeLog README
+ # einstall for sandbox issues
+ einstall || die "einstall failed"
+ newinitd "${FILESDIR}/tlswrap.init" tlswrap
+}