summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Dummer <martin.dummer@gmx.net>2022-09-07 11:09:03 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-10-02 20:10:51 +0200
commit13c3bbe3792578491392bc1d00e3e5eec582bf1f (patch)
tree1666987b0b58b752899dbc105cee2e0235de6ce2 /net-ftp
parentdev-util/drone: add 2.13.0 (diff)
downloadgentoo-13c3bbe3792578491392bc1d00e3e5eec582bf1f.tar.gz
gentoo-13c3bbe3792578491392bc1d00e3e5eec582bf1f.tar.bz2
gentoo-13c3bbe3792578491392bc1d00e3e5eec582bf1f.zip
net-ftp/atftp: add 0.8.0
Signed-off-by: Martin Dummer <martin.dummer@gmx.net> Closes: https://github.com/gentoo/gentoo/pull/27177 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/atftp/Manifest1
-rw-r--r--net-ftp/atftp/atftp-0.8.0.ebuild62
-rw-r--r--net-ftp/atftp/files/atftp-fix-test.patch11
3 files changed, 74 insertions, 0 deletions
diff --git a/net-ftp/atftp/Manifest b/net-ftp/atftp/Manifest
index 45877ec53841..050b3b5349f9 100644
--- a/net-ftp/atftp/Manifest
+++ b/net-ftp/atftp/Manifest
@@ -1 +1,2 @@
DIST atftp-0.7.5.tar.gz 253626 BLAKE2B aa0a0311d29fd52b77f8ae021407221f815a39fe85cabac36ee18dce8918a5b0accda455e2df5fecf34f09e93e583bfbc86162b60a7237bd6d34b0c658ec2970 SHA512 457101136e59f7a1657ce591e9ea678ab9091a59219d41b6c522fad4a3555c5cbcb8c9e0c3267fd871940d99b5f8673ab4ce5ec9737dee52f017e5c80a4e59d7
+DIST atftp-0.8.0.tar.gz 133417 BLAKE2B 6c0ec29c78f345f24adb65fd162e4572bd5b91e067c8db1ff6600ed2ea9a8461693bb6635c2edf09c77693dc6227689406a97b1d6e86a742ffbe3849ab9d3ee3 SHA512 b700b3e4182970fb494ffabd49e39d3622b1aff5f69882549eff0b52a01c8c47babe51b451c4829f9b833ea2ea7c590a2f3819f8e3508176fa7d1b5c0e152b68
diff --git a/net-ftp/atftp/atftp-0.8.0.ebuild b/net-ftp/atftp/atftp-0.8.0.ebuild
new file mode 100644
index 000000000000..7f0f4082403c
--- /dev/null
+++ b/net-ftp/atftp/atftp-0.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic systemd
+
+DESCRIPTION="Advanced TFTP implementation client/server"
+HOMEPAGE="https://sourceforge.net/projects/atftp/"
+SRC_URI="mirror://sourceforge/atftp/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="selinux tcpd readline pcre"
+
+DEPEND="tcpd? ( sys-apps/tcp-wrappers )
+ readline? ( sys-libs/readline:0= )
+ pcre? ( dev-libs/libpcre2:= )"
+RDEPEND="${DEPEND}
+ !net-ftp/tftp-hpa
+ !net-ftp/uftpd
+ selinux? ( sec-policy/selinux-tftp )"
+BDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.7.5-CFLAGS.patch"
+ "${FILESDIR}/atftp-fix-test.patch"
+)
+
+src_prepare() {
+ append-cppflags -D_REENTRANT -DRATE_CONTROL
+ # fix #561720 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable tcpd libwrap) \
+ $(use_enable readline libreadline) \
+ $(use_enable pcre libpcre) \
+ --enable-mtftp
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/atftp.init atftp
+ newconfd "${FILESDIR}"/atftp.confd atftp
+
+ systemd_dounit "${FILESDIR}"/atftp.service
+ systemd_install_serviced "${FILESDIR}"/atftp.service.conf
+
+ dodoc README* BUGS FAQ Changelog INSTALL TODO
+ dodoc "${S}"/docs/*
+
+ docinto test
+ cd "${S}"/test || die
+ dodoc load.sh mtftp.conf pcre_pattern.txt test.sh test_suite.txt
+}
diff --git a/net-ftp/atftp/files/atftp-fix-test.patch b/net-ftp/atftp/files/atftp-fix-test.patch
new file mode 100644
index 000000000000..67845c244a2e
--- /dev/null
+++ b/net-ftp/atftp/files/atftp-fix-test.patch
@@ -0,0 +1,11 @@
+--- a/test/test.sh
++++ b/test/test.sh
+@@ -575,7 +575,7 @@
+ echo
+ ## +3 is for "Test tsize option ..." and "Test PCRE mapped download ... "
+ ## +2 for diskspace tests:
+- local M=$(grep "/tmp/" "$TDIR"/multicast*.log | wc -l)
++ local M=$(grep "/tmp/" "$TDIR"/multicast*.log 2>/dev/null | wc -l)
+ $INTERACTIVE && D=2
+ cat <<EOF
+ Expected: