summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-13 13:36:41 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-13 13:38:14 +0200
commit554f0abb75a5956f370ee94a0c72884233c91e6b (patch)
treec7016417c88c44c209d14a2ffa5e8a1ac9270325 /net-ftp
parentdev-libs/libfilezilla: Bump to version 0.18.0 (diff)
downloadgentoo-554f0abb75a5956f370ee94a0c72884233c91e6b.tar.gz
gentoo-554f0abb75a5956f370ee94a0c72884233c91e6b.tar.bz2
gentoo-554f0abb75a5956f370ee94a0c72884233c91e6b.zip
net-ftp/filezilla: Bump to version 3.44.1
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/filezilla/Manifest1
-rw-r--r--net-ftp/filezilla/filezilla-3.44.1.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-ftp/filezilla/Manifest b/net-ftp/filezilla/Manifest
index 30b4337e1b26..4803ff368a2e 100644
--- a/net-ftp/filezilla/Manifest
+++ b/net-ftp/filezilla/Manifest
@@ -3,3 +3,4 @@ DIST FileZilla_3.40.0_src.tar.bz2 4997647 BLAKE2B 88ff2461d33369c435645f1dd5afa9
DIST FileZilla_3.41.2_src.tar.bz2 4994803 BLAKE2B 34f8331d3dfe3bdf483d234a0473074e17954b7d16abb7276ee6276221091f085c802d8cb0d397e00159b408d2737f5e23f2e50ad19d344c82472c09eea4dcd1 SHA512 c4b8284896942ba46f8f88fc5d60c6893c719e28ab94463848060850b6f9b2f4d3d13f580551dc3b21ab25ffc0cb1f43a2750500b5be2117952e14512a7ee40c
DIST FileZilla_3.42.1_src.tar.bz2 4987250 BLAKE2B 8cc6fd0a0cec336f34793520fe4be52a36a91ba5a4a3d41092d78c00a25899f73abd03f8d6339da40bc98a618dbae98063de2844a83cacb1431fc53f3b962383 SHA512 0dc9b3a6347803f60a71c56bb759700fb2b1b019dc29794aa639ce892ccd1ae53041112987f9d5e8e75ec7e07702a5aac8e1c131796bbc5f210d75d286276deb
DIST FileZilla_3.43.0_src.tar.bz2 4544635 BLAKE2B 13c99918dd7674fe3f2f0217b39ebe7aa89effe411e3cf90e08c9177278ce143ac84a021e49be0bc0772af29a5c34c33b03ce93d54f0b9918e4ea1001875ea48 SHA512 12c518616508e1cbd7ab60f1b94f8c876c885bc4399674c4b2df34235141fde1297a1edc686078c0f93b040ea6e42984c22ace00c4da201c7f99b4c9b71f5bc1
+DIST FileZilla_3.44.1_src.tar.bz2 4606669 BLAKE2B 407697467d7f9511b1b4e2e11505cf8815dd950609eabf242e283918e577d70f9b732fef930bbe97ba60fdffa484d77e0f7d74bb3ade8d1fcd0296ce91384301 SHA512 fa2e8c65621c7c6003e45f99f5153177e507ca34dde49d86d6f59e8b985abdeb80b779d71e554fc6acb891a695a0ef4c275bf0950af1b4cb67ff5ddb4c51e3b7
diff --git a/net-ftp/filezilla/filezilla-3.44.1.ebuild b/net-ftp/filezilla/filezilla-3.44.1.ebuild
new file mode 100644
index 000000000000..564462ccd07d
--- /dev/null
+++ b/net-ftp/filezilla/filezilla-3.44.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+MY_PV=${PV/_/-}
+MY_P="FileZilla_${MY_PV}"
+
+DESCRIPTION="FTP client with lots of useful features and an intuitive interface"
+HOMEPAGE="https://filezilla-project.org/"
+SRC_URI="https://download.filezilla-project.org/client/${MY_P}_src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="dbus nls test"
+
+# pugixml 1.7 minimal dependency is for c++11 proper configuration
+RDEPEND=">=app-eselect/eselect-wxwidgets-0.7-r1
+ >=dev-libs/nettle-3.1:=
+ >=dev-db/sqlite-3.7
+ >=dev-libs/libfilezilla-0.18.0
+ <dev-libs/libfilezilla-0.19.0
+ >=dev-libs/pugixml-1.7
+ >=net-libs/gnutls-3.5.7
+ >=x11-libs/wxGTK-3.0.4:${WX_GTK_VER}[X]
+ x11-misc/xdg-utils
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-1.4
+ nls? ( >=sys-devel/gettext-0.11 )
+ test? ( >=dev-util/cppunit-1.13.0 )"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+DOCS=(AUTHORS ChangeLog NEWS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.22.1-debug.patch
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ if ! test-flag-CXX -std=c++14; then
+ eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
+ eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
+ eerror "to gcc-4.9 or an equivalent version supporting C++14."
+ die "Currently active compiler does not support -std=c++14"
+ fi
+ fi
+}
+
+src_prepare() {
+ setup-wxwidgets
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-autoupdatecheck
+ --with-pugixml=system
+ $(use_enable nls locales)
+ $(use_with dbus)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}