summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 19:55:52 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:12:19 +0100
commitfe717395745b2d02b81f2eaaf170415e5f29d8a2 (patch)
tree12044c00e0445f7db6663bf2eba5538a9a3370c2 /net-ftp
parentnet-im/cpop: port to EAPI 7 (diff)
downloadgentoo-fe717395745b2d02b81f2eaaf170415e5f29d8a2.tar.gz
gentoo-fe717395745b2d02b81f2eaaf170415e5f29d8a2.tar.bz2
gentoo-fe717395745b2d02b81f2eaaf170415e5f29d8a2.zip
net-ftp/yafc: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-ftp')
-rw-r--r--net-ftp/yafc/yafc-1.3.7.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/net-ftp/yafc/yafc-1.3.7.ebuild b/net-ftp/yafc/yafc-1.3.7.ebuild
index 450630a16546..b5da3d97096b 100644
--- a/net-ftp/yafc/yafc-1.3.7.ebuild
+++ b/net-ftp/yafc/yafc-1.3.7.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit bash-completion-r1 epatch
+inherit bash-completion-r1
DESCRIPTION="Console ftp client with a lot of nifty features"
HOMEPAGE="http://www.yafc-ftp.com/"
@@ -12,13 +12,12 @@ SRC_URI="http://www.yafc-ftp.com/downloads/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
-IUSE="ipv6 libressl kerberos readline socks5 ssh"
+IUSE="ipv6 kerberos readline socks5 ssh"
RDEPEND="
sys-libs/ncurses:*
dev-libs/libbsd
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
+ dev-libs/openssl:0=
kerberos? ( virtual/krb5 )
readline? ( >=sys-libs/readline-6:0= )
socks5? ( net-proxy/dante )
@@ -28,10 +27,6 @@ DEPEND="${RDEPEND}"
DOCS=( BUGS NEWS README.md THANKS TODO )
-src_prepare() {
- epatch_user
-}
-
src_configure() {
export ac_cv_ipv6=$(usex ipv6)
econf \