summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-26 21:22:04 -0400
committerTim Harder <radhermit@gentoo.org>2016-03-26 21:26:38 -0400
commit51a2d7a258a4943331177760f591e941e03d37d0 (patch)
tree4f1cc3780fd87ecf706fd56dc0988e6ec4f98d0a /net-im/bitlbee/bitlbee-9999.ebuild
parentmedia-plugins/audacious-plugins: Non-GUI builds do not install the libaudgui ... (diff)
downloadgentoo-51a2d7a258a4943331177760f591e941e03d37d0.tar.gz
gentoo-51a2d7a258a4943331177760f591e941e03d37d0.tar.bz2
gentoo-51a2d7a258a4943331177760f591e941e03d37d0.zip
net-im/bitlbee: version bump to 3.4.2
Diffstat (limited to 'net-im/bitlbee/bitlbee-9999.ebuild')
-rw-r--r--net-im/bitlbee/bitlbee-9999.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/net-im/bitlbee/bitlbee-9999.ebuild b/net-im/bitlbee/bitlbee-9999.ebuild
index 181f31968bcf..dceb0c289806 100644
--- a/net-im/bitlbee/bitlbee-9999.ebuild
+++ b/net-im/bitlbee/bitlbee-9999.ebuild
@@ -26,12 +26,12 @@ IUSE="debug gnutls ipv6 +xmpp libevent msn nss +oscar otr +plugins purple selinu
COMMON_DEPEND="
>=dev-libs/glib-2.16
purple? ( net-im/pidgin )
- libevent? ( dev-libs/libevent )
+ libevent? ( dev-libs/libevent:= )
otr? ( >=net-libs/libotr-4 )
- gnutls? ( net-libs/gnutls )
+ gnutls? ( net-libs/gnutls:= )
!gnutls? (
nss? ( dev-libs/nss )
- !nss? ( ssl? ( !libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:= ) ) )
+ !nss? ( ssl? ( !libressl? ( dev-libs/openssl:0= ) libressl? ( dev-libs/libressl:= ) ) )
)
"
DEPEND="${COMMON_DEPEND}
@@ -173,4 +173,15 @@ pkg_postinst() {
chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
[[ -d "${ROOT}"/var/run/bitlbee ]] &&
chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ einfo
+ elog "The bitlbee init script will now attempt to stop all processes owned by the"
+ elog "bitlbee user, including per-client forks."
+ elog
+ elog "Tell the init script not to touch anything besides the main bitlbee process"
+ elog "by changing the BITLBEE_STOP_ALL variable in"
+ elog " /etc/conf.d/bitlbee"
+ einfo
+ fi
}