summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-10-13 05:41:05 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-10-13 05:41:17 +1100
commit61deea9a6ae0573a34afd646ebc49ec801961135 (patch)
tree1b859e3bd4ac934381d5f5adbbfa30404259ee57 /net-im/choqok
parentnet-im/choqok: remove obsolete upstream metadata (diff)
downloadgentoo-61deea9a6ae0573a34afd646ebc49ec801961135.tar.gz
gentoo-61deea9a6ae0573a34afd646ebc49ec801961135.tar.bz2
gentoo-61deea9a6ae0573a34afd646ebc49ec801961135.zip
net-im/choqok: version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'net-im/choqok')
-rw-r--r--net-im/choqok/Manifest1
-rw-r--r--net-im/choqok/choqok-1.6.0.ebuild66
-rw-r--r--net-im/choqok/metadata.xml2
3 files changed, 69 insertions, 0 deletions
diff --git a/net-im/choqok/Manifest b/net-im/choqok/Manifest
index de6e26fd8e2a..e4cf72685729 100644
--- a/net-im/choqok/Manifest
+++ b/net-im/choqok/Manifest
@@ -1 +1,2 @@
DIST choqok-1.5.tar.xz 1068516 SHA256 5cb97ac4cdf9db4699bb7445a9411393073d213fea649ab0713f659f1308efe4 SHA512 fbb31abedd07ea1c674a7d59b4a18808ca03812ac37c60ea67d2d641668be4a9137e9f4573eda1e19425123601e9536971170e3948c1e5098b220991571a2cf3 WHIRLPOOL c4f869bab6a23a2ffa2e8e071414a6c7170816269e6e9f77df4269b94b627248fd259eb3c24217a2a838f74162ba6c198ff5549371b61f516fb142b8690cdce0
+DIST choqok-1.6.0.tar.xz 1170748 SHA256 8a7527067b3694ad16faafac754cfd5f1e5f5fd1547f066d8f14fbcf8327310f SHA512 78c03689e40978213f2f9462780fe47507a2778985d4d5b940cab004f0ac52becfa76d7dbaa886df958134c65b27255e49ac68ddbb2a434131fffe9ca9280cbc WHIRLPOOL 57155eea1f9f54113bfad9d883d77c332b97c0ef4512d15db9764056704d9709b6c4e81ec630cb5b60c0b310953deabdf9cb5b2521b41ea016a421562e2d06fd
diff --git a/net-im/choqok/choqok-1.6.0.ebuild b/net-im/choqok/choqok-1.6.0.ebuild
new file mode 100644
index 000000000000..aa49343a0fe7
--- /dev/null
+++ b/net-im/choqok/choqok-1.6.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Free/Open Source micro-blogging client by KDE"
+HOMEPAGE="http://choqok.gnufolks.org/"
+[[ ${KDE_BUILD_TYPE} != live ]] && SRC_URI="mirror://kde/stable/${PN}/${PV%.0}/src/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~x86"
+IUSE="attica konqueror telepathy"
+#qtnetwork
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kemoticons)
+ $(add_frameworks_dep kglobalaccel)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep knotifyconfig)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwallet)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep sonnet)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ app-crypt/qca[qt5]
+ dev-libs/qoauth:5
+ attica? ( $(add_frameworks_dep attica) )
+ konqueror? (
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kdewebkit)
+ $(add_qt_dep qtwebkit)
+ )
+ telepathy? ( net-libs/telepathy-qt[qt5] )
+"
+RDEPEND="${DEPEND}
+ !net-im/choqok:4
+"
+
+DOCS=( AUTHORS README TODO changelog )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package attica KF5Attica)
+ $(cmake-utils_use_find_package konqueror KF5Parts)
+ $(cmake-utils_use_find_package konqueror KF5WebKit)
+ $(cmake-utils_use_find_package telepathy TelepathyQt5)
+ )
+
+ kde5_src_configure
+}
diff --git a/net-im/choqok/metadata.xml b/net-im/choqok/metadata.xml
index 602a023a5bef..468d03a98f06 100644
--- a/net-im/choqok/metadata.xml
+++ b/net-im/choqok/metadata.xml
@@ -6,6 +6,8 @@
<name>Gentoo KDE Project</name>
</maintainer>
<use>
+ <flag name="attica">Build Open Collaboration Services plugin using <pkg>dev-libs/libattica</pkg></flag>
+ <flag name="konqueror">Build Konqueror Choqok plugin</flag>
<flag name="telepathy">Enable support for the real-time communication framework telepathy</flag>
</use>
</pkgmetadata>