summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-06-01 09:46:31 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-06-01 09:58:46 +0200
commit218bbbb6e36d07ff61b3848001bfba84cfef309a (patch)
treedb6e9904ed415322f7d05bd0751e8f91af208b21 /net-im/dino
parentmedia-libs/fontconfig: Stabilize 2.14.2-r2 ppc, #907581 (diff)
downloadgentoo-218bbbb6e36d07ff61b3848001bfba84cfef309a.tar.gz
gentoo-218bbbb6e36d07ff61b3848001bfba84cfef309a.tar.bz2
gentoo-218bbbb6e36d07ff61b3848001bfba84cfef309a.zip
net-im/dino: add USE=rtp
This required dropping the arm64 keyword for now. Thanks to Сергей for providing the initial patch. Closes: https://github.com/gentoo/gentoo/pull/30365 Closes: https://bugs.gentoo.org/903179 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-im/dino')
-rw-r--r--net-im/dino/dino-0.4.2.ebuild12
-rw-r--r--net-im/dino/metadata.xml1
2 files changed, 9 insertions, 4 deletions
diff --git a/net-im/dino/dino-0.4.2.ebuild b/net-im/dino/dino-0.4.2.ebuild
index b2932f67878a..1a58bab58470 100644
--- a/net-im/dino/dino-0.4.2.ebuild
+++ b/net-im/dino/dino-0.4.2.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://dino.im"
LICENSE="GPL-3"
SLOT="0"
-IUSE="+gpg +http +omemo +notification-sound test"
+IUSE="+gpg +http +omemo +notification-sound +rtp test"
RESTRICT="!test? ( test )"
MY_REPO_URI="https://github.com/dino/dino"
@@ -18,7 +18,7 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="${MY_REPO_URI}.git"
inherit git-r3
else
- KEYWORDS="~amd64 ~arm64"
+ KEYWORDS="~amd64"
SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
fi
@@ -43,6 +43,11 @@ RDEPEND="
dev-libs/libgcrypt:=
media-gfx/qrencode:=
)
+ rtp? (
+ media-libs/gst-plugins-base:1.0
+ media-libs/gstreamer:1.0
+ media-libs/webrtc-audio-processing
+ )
"
DEPEND="
${RDEPEND}
@@ -57,12 +62,11 @@ BDEPEND="
src_configure() {
vala_setup
- # TODO: Make videocalls (rtp) optional and not completely disable it
local disabled_plugins=(
$(usex gpg "" "openpgp")
$(usex omemo "" "omemo")
$(usex http "" "http-files")
- "rtp"
+ $(usex rtp "" rtp)
)
local enabled_plugins=(
$(usex notification-sound "notification-sound" "")
diff --git a/net-im/dino/metadata.xml b/net-im/dino/metadata.xml
index 9f5aee117e5c..8798c1dab8d4 100644
--- a/net-im/dino/metadata.xml
+++ b/net-im/dino/metadata.xml
@@ -11,5 +11,6 @@
<flag name="http">Enable HTTP file upload plugin</flag>
<flag name="omemo">Enable OMEMO encryption plugin</flag>
<flag name="notification-sound">notification sounds plugin</flag>
+ <flag name="rtp">Enable Audio/Video calls over XMPP using RTP</flag>
</use>
</pkgmetadata>