summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-03-07 23:35:54 +0000
committerSam James <sam@gentoo.org>2023-03-11 16:24:03 +0000
commita563d3f7bef380261641d5a3ced40700f0abf9aa (patch)
treed7375a086f7a3abd3567a224972017cad517da6e /net-im/dino
parentnet-im/dino: add 0.4.0 (diff)
downloadgentoo-a563d3f7bef380261641d5a3ced40700f0abf9aa.tar.gz
gentoo-a563d3f7bef380261641d5a3ced40700f0abf9aa.tar.bz2
gentoo-a563d3f7bef380261641d5a3ced40700f0abf9aa.zip
net-im/dino: add 0.4.1
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/29762 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-im/dino')
-rw-r--r--net-im/dino/Manifest1
-rw-r--r--net-im/dino/dino-0.4.1.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/net-im/dino/Manifest b/net-im/dino/Manifest
index ed37f9d9df06..93ca8314ad79 100644
--- a/net-im/dino/Manifest
+++ b/net-im/dino/Manifest
@@ -1,2 +1,3 @@
DIST dino-0.3.0.tar.gz 804810 BLAKE2B cb6365f6fad051d0308909c6d5d2c59d7f57cb94f9f691516e27b7bb3aba214fdffa95066d8203d8ac5bd770bec1580e81baad313beef7fe5c058e1e94a37556 SHA512 e3d885208451b00b0416a1401780a94a169fb1179b2f609f7965e3445873d6b72ded84cb471d534616892ec89b5edcd6701fc97c36f19d690f4b894399000515
DIST dino-0.4.0.tar.gz 882288 BLAKE2B 7d05f358746c09d5c129db1366fdb609f796cdc11c889bc22f9d0d71daa1b9b622b83512e15cbfe8d1e6f3fcf2870f20d7e0c5ecbf66257e7a155d2e020f7652 SHA512 09abfda34625a680dd7bc4cfa842c6bcbc4097fa613bf91bb7c6a4a10d2075f5050d3be705379fd7ecf9c686024000cd6791757eb8b0958ff8e533774267085a
+DIST dino-0.4.1.tar.gz 882374 BLAKE2B 79d057721f5fc62d89b6afcdcad6851a63604c80135aa3971a7185c29fb393bbe40c28e01a7dfe49058d6d74a9b9a75d0df641bf9e9486db8d04c63dbb35015b SHA512 cdc3e5e066cbd9351c084a7ab41d82bf4b5b4d937e81b955924667c35b59dcbe7472be1caa1dfea1903667ba7f625d118251f3425b3cefc89ab8cb358e6f79be
diff --git a/net-im/dino/dino-0.4.1.ebuild b/net-im/dino/dino-0.4.1.ebuild
new file mode 100644
index 000000000000..25abd0156494
--- /dev/null
+++ b/net-im/dino/dino-0.4.1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake vala xdg readme.gentoo-r1
+
+DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
+HOMEPAGE="https://dino.im"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+gpg +http +omemo +notification-sound test"
+RESTRICT="!test? ( test )"
+
+MY_REPO_URI="https://github.com/dino/dino"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="${MY_REPO_URI}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm64"
+ SRC_URI="${MY_REPO_URI}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+RDEPEND="
+ app-text/gspell[vala]
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/icu:=
+ dev-libs/libgee:0.8=
+ gui-libs/gtk:4
+ >=gui-libs/libadwaita-1.2.0:1
+ net-libs/glib-networking
+ >=net-libs/libnice-0.1.15
+ net-libs/libsignal-protocol-c
+ net-libs/libsrtp:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+ gpg? ( app-crypt/gpgme:= )
+ http? ( net-libs/libsoup:2.4 )
+ notification-sound? ( media-libs/libcanberra:0[sound] )
+ omemo? (
+ dev-libs/libgcrypt:=
+ media-gfx/qrencode:=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ media-libs/gst-plugins-base
+ media-libs/gstreamer
+"
+BDEPEND="
+ sys-devel/gettext
+ $(vala_depend)
+"
+
+src_configure() {
+ vala_setup
+
+ # TODO: Make videocalls (rtp) optional and not completely disable it
+ local disabled_plugins=(
+ $(usex gpg "" "openpgp")
+ $(usex omemo "" "omemo")
+ $(usex http "" "http-files")
+ "rtp"
+ )
+ local enabled_plugins=(
+ $(usex notification-sound "notification-sound" "")
+ )
+ local mycmakeargs=(
+ "-DENABLED_PLUGINS=$(local IFS=";"; echo "${enabled_plugins[*]}")"
+ "-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
+ "-DVALA_EXECUTABLE=${VALAC}"
+ "-DBUILD_TESTS=$(usex test)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/xmpp-vala-test || die
+}
+
+src_install() {
+ cmake_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}