summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-im/licq
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-im/licq')
-rw-r--r--net-im/licq/Manifest1
-rw-r--r--net-im/licq/files/licq-1.3.8-hebrew.patch95
-rw-r--r--net-im/licq/files/licq-1.3.8-memory_leak.patch9
-rw-r--r--net-im/licq/licq-1.8.2.ebuild76
-rw-r--r--net-im/licq/metadata.xml16
5 files changed, 197 insertions, 0 deletions
diff --git a/net-im/licq/Manifest b/net-im/licq/Manifest
new file mode 100644
index 000000000000..1338c964cfc3
--- /dev/null
+++ b/net-im/licq/Manifest
@@ -0,0 +1 @@
+DIST licq-1.8.2.tar.bz2 2260717 SHA256 16aa514888379a12f538becbaeb81f77017d05c94c15f3b2a5e0ffb60315180f SHA512 2535d1ec3abf91825041ce17ccbe525291b10d9df9af16f5c4bbfab27b5dcef2fc39444f6de839d126cb36014330fc75a3143cbc50b7926123782988105bdf1f WHIRLPOOL 25f4881b8e8abe1187f1bda374d3513dfb52b77742611c41c080d151e4c3d1e369dce11c9f7dc43b6e199c5117ca65e2273fab6355548ed57ceefc4bf74d53ed
diff --git a/net-im/licq/files/licq-1.3.8-hebrew.patch b/net-im/licq/files/licq-1.3.8-hebrew.patch
new file mode 100644
index 000000000000..a0fdb936bdb2
--- /dev/null
+++ b/net-im/licq/files/licq-1.3.8-hebrew.patch
@@ -0,0 +1,95 @@
+--- configure
++++ configure
+@@ -3283,7 +3283,7 @@
+
+ # Check whether --enable-hebrew was given.
+ if test "${enable_hebrew+set}" = set; then :
+- enableval=$enable_hebrew; USE_HEBREW=yes
++ enableval=$enable_hebrew; USE_HEBREW=$enableval
+ else
+ USE_HEBREW=no
+ fi
+--- src/hebrev.c
++++ src/hebrev.c
+@@ -48,6 +48,7 @@
+ short int mode = 0, imode;
+ const char *hmark = NULL, *lmark, *nmark, *nlmark;
+ char ch;
++ const char* srcstart = src;
+
+ if (src == NULL)
+ return NULL;
+@@ -69,7 +70,7 @@
+ if (*src == 0 || iseng(*src))
+ {
+ lmark = src-1;
+- while ((!isheb(*lmark)) && (!ispunct(*lmark))) lmark--;
++ while (lmark > srcstart && !isheb(*lmark) && !ispunct(*lmark)) lmark--;
+ src = lmark;
+ imode = 0;
+ nmark = NULL;
+@@ -114,6 +115,7 @@
+ hmark = NULL;
+ mode = 0;
+ }
++ if (*src == '\0') *dest = '\0';
+ }
+ if (!*src++)
+ break;
+@@ -141,15 +143,16 @@
+ char *temp=NULL, *tmp=NULL;
+ char *arg=NULL, *arg2=NULL;
+ int i=0;
++ char* saveptr = NULL;
+
+ temp = (char*) malloc(strlen(input)+1);
+ tmp = temp;
+
+ strcpy(temp, input);
+
+- arg = strtok(temp, "\n");
++ arg = strtok_r(temp, "\n", &saveptr);
+ for(i = 0; (i < index) && (arg!=NULL); i++)
+- arg = strtok(NULL, "\n");
++ arg = strtok_r(NULL, "\n", &saveptr);
+
+ if(arg != NULL)
+ {
+@@ -164,6 +167,7 @@
+ {
+ char* temp_str = NULL;
+ char* temp = NULL;
++ char* arg = NULL;
+ int i=0;
+ int size = 0;
+ if(src == NULL)
+@@ -172,21 +176,23 @@
+ if((temp_str = (char*)malloc(strlen(src)+1))== NULL)
+ return NULL;
+
+- temp = GetArg(src, i);
+- while(temp != NULL)
++ arg = GetArg(src, i);
++ while(arg != NULL)
+ {
+ i++;
+- temp = hebrew(temp);
++ temp = hebrew(arg);
++ free(arg);
+ memcpy(temp_str + size , temp, strlen(temp));
+ size += strlen(temp) ;
+ temp_str[size++] = '\n';
+
+ free(temp);
+ temp = NULL;
+- temp = GetArg(src, i);
++ arg = GetArg(src, i);
+ }
+- free(temp);
+- temp_str[size]= '\0';
++ // Above loop adds a line break after last line that wasn't there in src
++ // replace it with the null terminator
++ temp_str[--size]= '\0';
+ return temp_str;
+ }
+
diff --git a/net-im/licq/files/licq-1.3.8-memory_leak.patch b/net-im/licq/files/licq-1.3.8-memory_leak.patch
new file mode 100644
index 000000000000..38ea9e0da5bb
--- /dev/null
+++ b/net-im/licq/files/licq-1.3.8-memory_leak.patch
@@ -0,0 +1,9 @@
+--- src/user.cpp
++++ src/user.cpp
+@@ -3631,6 +3631,7 @@
+ {
+ gLog.Error("%sUnable to open picture file (%s):\n%s%s.\n", L_ERRORxSTR,
+ szFilename, L_BLANKxSTR, strerror(errno));
++ close(source);
+ return;
+ }
diff --git a/net-im/licq/licq-1.8.2.ebuild b/net-im/licq/licq-1.8.2.ebuild
new file mode 100644
index 000000000000..a75d8a32eba1
--- /dev/null
+++ b/net-im/licq/licq-1.8.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils eutils flag-o-matic
+
+DESCRIPTION="ICQ Client with v8 support"
+HOMEPAGE="http://www.licq.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+IUSE="debug doc linguas_he nls socks5 ssl xosd aosd xmpp qt4 msn"
+
+RDEPEND=">=app-crypt/gpgme-1
+ xmpp? ( net-libs/gloox )
+ qt4? ( dev-qt/qtgui:4 )
+ socks5? ( net-proxy/dante )
+ ssl? ( >=dev-libs/openssl-0.9.5a )
+ xosd? ( x11-libs/xosd )
+ aosd? ( x11-libs/libaosd )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ nls? ( sys-devel/gettext )
+ dev-libs/boost"
+
+src_prepare() {
+ local licq_plugins="auto-reply icq rms"
+ use msn && licq_plugins+=" msn"
+ use xosd && licq_plugins+=" osd"
+ use aosd && licq_plugins+=" aosd"
+ use xmpp && licq_plugins+=" jabber"
+ use qt4 && licq_plugins+=" qt4-gui"
+
+ local plugins="" x
+ for x in ${licq_plugins}; do
+ plugins+=" ${x}\/CMakeLists.txt"
+ done
+
+ sed -i -e "s/file(GLOB cmake_plugins.*$/set(cmake_plugins ${plugins})/" plugins/CMakeLists.txt
+}
+
+pkg_setup() {
+ # crutch
+ append-flags -pthread
+}
+
+src_configure() {
+ local myopts="-DCMAKE_BUILD_TYPE=$(use debug && echo 'Debug' || echo 'Release')"
+ mycmakeargs="$myopts
+ $(cmake-utils_use doc USE_DOXYGEN)
+ $(cmake-utils_use linguas_he USE_HEBREW)
+ $(cmake-utils_use nls ENABLE_NLS)
+ $(cmake-utils_use socks5 USE_SOCKS5)
+ $(cmake-utils_use ssl USE_OPENSSL)
+ -DUSE_FIFO=ON
+ -DBUILD_PLUGINS=ON"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README
+
+ docinto doc
+ dodoc doc/*
+
+ use ssl && dodoc README.OPENSSL
+
+ exeinto /usr/share/${PN}/upgrade
+ doexe upgrade/*.pl
+}
diff --git a/net-im/licq/metadata.xml b/net-im/licq/metadata.xml
new file mode 100644
index 000000000000..ffc90125c10d
--- /dev/null
+++ b/net-im/licq/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <longdescription>Licq is an ICQ clone with an extensive plugin system.</longdescription>
+ <use>
+ <flag name="aosd">Build the advanced on screen display plugin.</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">licq</remote-id>
+ </upstream>
+</pkgmetadata>