summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Shiryaev <sergey@shiryaev.pro>2017-02-11 22:19:05 +0300
committerPatrice Clement <monsieurp@gentoo.org>2017-02-13 17:13:45 +0100
commit6328aecccebee6739ec1d6fdd52e804fb58ff5de (patch)
tree50f2a7d78188f28e4ba179c0a5302f85bff93108 /net-im/mattermost-desktop-bin/mattermost-desktop-bin-3.5.0.ebuild
parentapp-text/paperwork: 1.1.1 bump (diff)
downloadgentoo-6328aecccebee6739ec1d6fdd52e804fb58ff5de.tar.gz
gentoo-6328aecccebee6739ec1d6fdd52e804fb58ff5de.tar.bz2
gentoo-6328aecccebee6739ec1d6fdd52e804fb58ff5de.zip
net-im/mattermost-desktop-bin: new package.
Gentoo-Bug: https://bugs.gentoo.org/608646 Mattermost is a Slack-like free software team communication service. It brings team messaging and file sharing into one place, accessible across PCs and phones, with archiving and search. Closes: https://github.com/gentoo/gentoo/pull/3919
Diffstat (limited to 'net-im/mattermost-desktop-bin/mattermost-desktop-bin-3.5.0.ebuild')
-rw-r--r--net-im/mattermost-desktop-bin/mattermost-desktop-bin-3.5.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-im/mattermost-desktop-bin/mattermost-desktop-bin-3.5.0.ebuild b/net-im/mattermost-desktop-bin/mattermost-desktop-bin-3.5.0.ebuild
new file mode 100644
index 000000000000..46a1cc78a8a5
--- /dev/null
+++ b/net-im/mattermost-desktop-bin/mattermost-desktop-bin-3.5.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils gnome2-utils
+
+DESCRIPTION="Mattermost Desktop application"
+HOMEPAGE="https://about.mattermost.com/"
+SRC_URI="https://github.com/mattermost/desktop/archive/v${PV}.tar.gz -> ${PV}.tar.gz
+ amd64? ( https://releases.mattermost.com/desktop/3.5.0/mattermost-desktop-${PV}-linux-x64.tar.gz )
+ x86? ( https://releases.mattermost.com/desktop/3.5.0/mattermost-desktop-${PV}-linux-ia32.tar.gz )
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/mattermost-desktop-${PV}"
+QA_PREBUILT="opt/mattermost-desktop/mattermost-desktop
+ opt/mattermost-desktop/libnode.so
+ opt/mattermost-desktop/libffmpeg.so
+"
+
+src_install() {
+ insinto /opt/mattermost-desktop/locales
+ doins locales/*.pak
+
+ insinto /opt/mattermost-desktop/resources
+ doins resources/*.asar
+
+ insinto /opt/mattermost-desktop
+ doins *.pak
+ doins *.bin
+ doins *.dat
+
+ exeinto /opt/mattermost-desktop
+
+ doexe *.so
+ doexe mattermost-desktop
+
+ dosym /opt/mattermost-desktop/mattermost-desktop /opt/bin/mattermost-desktop
+
+ newicon "${S}/icon.png" mattermost-desktop.png
+ make_desktop_entry mattermost-desktop Mattermost mattermost-desktop
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}