summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Shiryaev <sergey@shiryaev.pro>2018-02-20 03:14:03 +0300
committerPatrice Clement <monsieurp@gentoo.org>2018-02-20 21:26:27 +0100
commit8f8f665d521228b5429f199ee01466d03b8ef2fb (patch)
treee1278f37531a68aadd7aa5784f0015151e035607 /net-im/mattermost-desktop-bin/mattermost-desktop-bin-4.0.0.ebuild
parentapp-emulation/nemu: version bump to 1.4.0. (diff)
downloadgentoo-8f8f665d521228b5429f199ee01466d03b8ef2fb.tar.gz
gentoo-8f8f665d521228b5429f199ee01466d03b8ef2fb.tar.bz2
gentoo-8f8f665d521228b5429f199ee01466d03b8ef2fb.zip
net-im/mattermost-desktop-bin: version bump to 4.0.0.
Closes: https://github.com/gentoo/gentoo/pull/7233
Diffstat (limited to 'net-im/mattermost-desktop-bin/mattermost-desktop-bin-4.0.0.ebuild')
-rw-r--r--net-im/mattermost-desktop-bin/mattermost-desktop-bin-4.0.0.ebuild90
1 files changed, 90 insertions, 0 deletions
diff --git a/net-im/mattermost-desktop-bin/mattermost-desktop-bin-4.0.0.ebuild b/net-im/mattermost-desktop-bin/mattermost-desktop-bin-4.0.0.ebuild
new file mode 100644
index 000000000000..eb29944e4626
--- /dev/null
+++ b/net-im/mattermost-desktop-bin/mattermost-desktop-bin-4.0.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN%-*}"
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit eutils multilib-build
+
+DESCRIPTION="Mattermost Desktop application"
+HOMEPAGE="https://about.mattermost.com/"
+
+SRC_URI="
+ https://github.com/mattermost/desktop/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ amd64? ( https://releases.mattermost.com/desktop/${PV}/mattermost-desktop-${PV}-linux-x64.tar.gz )
+ x86? ( https://releases.mattermost.com/desktop/${PV}/mattermost-desktop-${PV}-linux-ia32.tar.gz )
+"
+
+LICENSE="Apache-2.0 GPL-2+ LGPL-2.1+ MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ gnome-base/gconf:2[${MULTILIB_USEDEP}]
+ dev-libs/atk:0[${MULTILIB_USEDEP}]
+ dev-libs/expat:0[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr:0[${MULTILIB_USEDEP}]
+ dev-libs/nss:0[${MULTILIB_USEDEP}]
+ gnome-base/gconf:2[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib:0[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ net-print/cups:0[${MULTILIB_USEDEP}]
+ sys-apps/dbus:0[${MULTILIB_USEDEP}]
+ sys-devel/gcc:6.4.0[${MULTILIB_USEDEP}]
+ sys-libs/glibc:2.2[${MULTILIB_USEDEP}]
+ x11-libs/cairo:0[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11:0[${MULTILIB_USEDEP}]
+ x11-libs/libxcb:0/1.12[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite:0[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor:0[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage:0[${MULTILIB_USEDEP}]
+ x11-libs/libXext:0[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes:0[${MULTILIB_USEDEP}]
+ x11-libs/libXi:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr:0[${MULTILIB_USEDEP}]
+ x11-libs/libXrender:0[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver:0[${MULTILIB_USEDEP}]
+ x11-libs/libXtst:0[${MULTILIB_USEDEP}]
+ x11-libs/pango:0[${MULTILIB_USEDEP}]"
+
+S="${WORKDIR}/mattermost-desktop-${PV}"
+
+QA_PREBUILT="
+ opt/mattermost-desktop/mattermost-desktop
+ opt/mattermost-desktop/libnode.so
+ opt/mattermost-desktop/libffmpeg.so
+"
+
+DOCS=(
+ NOTICE.txt
+ LICENSES.chromium.html
+ LICENSE.txt
+ LICENSE.electron.txt
+ README.md
+)
+
+src_install() {
+ insinto "/opt/${MY_PN}/locales"
+ doins locales/*.pak
+
+ insinto "/opt/${MY_PN}/resources"
+ doins resources/*.asar
+
+ insinto "/opt/${MY_PN}"
+ doins *.pak *.bin *.dat
+ exeinto "/opt/${MY_PN}"
+ doexe *.so "${MY_PN}"
+
+ dosym "/opt/${MY_PN}/${MY_PN}" "/usr/bin/${MY_PN}"
+
+ newicon "${S}/icon.png" "${MY_PN}.png"
+ make_desktop_entry "${MY_PN}" Mattermost "${MY_PN}"
+
+ einstalldocs
+}