summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarco Scardovi <mscardovi@icloud.com>2023-01-12 11:37:08 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-01-28 10:43:48 +0200
commit4da3d5b5576fec686a3685ce94251aa6d4c8fab8 (patch)
tree3df46007b210d6a2270305421747294efc16d0c3 /net-im/pidgin
parentsys-kernel/pf-sources: add 6.1-pf4 (diff)
downloadgentoo-4da3d5b5576fec686a3685ce94251aa6d4c8fab8.tar.gz
gentoo-4da3d5b5576fec686a3685ce94251aa6d4c8fab8.tar.bz2
gentoo-4da3d5b5576fec686a3685ce94251aa6d4c8fab8.zip
net-im/pidgin: add 2.14.12
Closes: https://bugs.gentoo.org/890283 Signed-off-by: Marco Scardovi <mscardovi@icloud.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im/pidgin')
-rw-r--r--net-im/pidgin/Manifest1
-rw-r--r--net-im/pidgin/files/pidgin-2.10.9-irc_join_sleep.patch11
-rw-r--r--net-im/pidgin/pidgin-2.14.12.ebuild292
3 files changed, 304 insertions, 0 deletions
diff --git a/net-im/pidgin/Manifest b/net-im/pidgin/Manifest
index 5b9e90d9d95f..9a047483906d 100644
--- a/net-im/pidgin/Manifest
+++ b/net-im/pidgin/Manifest
@@ -1,2 +1,3 @@
DIST pidgin-2.10.9-irc_join_sleep.patch 534 BLAKE2B 0215cebb93993e19e700e4d4974351ab5e9a00ea094775076d8f439569b34c0ec2faaed360965867df58bc42677516983ce11a2601dd322c1bdf2f288253a5b8 SHA512 8de0d6f05e48cd5a3e894576e06c7fb82e4bfc778cce8bb179fa22e2a05f5c2390a0e4c5b626ee4b910a18eab170d8f4be200f435ce408a86575af99e51e3bdf
DIST pidgin-2.14.10.tar.bz2 8229328 BLAKE2B 9f004abda0f00b315e763e8b17e4e938b44b8a971d5411d775b9428363ab2ae071462d6d16654fcc09270123c434ef2d1f639d7f6d85c08a83b05c0ba4342c21 SHA512 53241e9f62170fe7a8ea27ac03176d442f8aad4ed16da0033164b0949b00c3d476539b182e761950e7d6c385f22a891524c5f40a9cf8fe543b3003c37693314d
+DIST pidgin-2.14.12.tar.bz2 8226145 BLAKE2B 0f0bec301c196fb722b88998a2a420af4084aedb7563215bb44c2c74a670a20db030ac207f226cef7989477dba04a9655c71269564ccc3680b42946ee84fdb16 SHA512 ce016ab4c48448653ae22eead1ddc16f1d10f446c601f8abd2c85b4ea83a4e80092e1ce8182834d998b6587f42a92a9a91105b4db976e170ec7043bb6af3c54c
diff --git a/net-im/pidgin/files/pidgin-2.10.9-irc_join_sleep.patch b/net-im/pidgin/files/pidgin-2.10.9-irc_join_sleep.patch
new file mode 100644
index 000000000000..860a43a9551a
--- /dev/null
+++ b/net-im/pidgin/files/pidgin-2.10.9-irc_join_sleep.patch
@@ -0,0 +1,11 @@
+diff -ur ./pidgin-2.10.9.orig/libpurple/protocols/irc/irc.c pidgin-2.10.9/libpurple/protocols/irc/irc.c
+--- ./pidgin-2.10.9.orig/libpurple/protocols/irc/irc.c 2014-02-02 15:29:18.000000000 -0600
++++ pidgin-2.10.9/libpurple/protocols/irc/irc.c 2014-09-02 10:30:24.830599697 -0500
+@@ -742,6 +742,7 @@
+ struct irc_conn *irc = gc->proto_data;
+ const char *args[2];
+
++ g_usleep(500000);
+ args[0] = g_hash_table_lookup(data, "channel");
+ args[1] = g_hash_table_lookup(data, "password");
+ irc_cmd_join(irc, "join", NULL, args);
diff --git a/net-im/pidgin/pidgin-2.14.12.ebuild b/net-im/pidgin/pidgin-2.14.12.ebuild
new file mode 100644
index 000000000000..3f2e59459b9a
--- /dev/null
+++ b/net-im/pidgin/pidgin-2.14.12.ebuild
@@ -0,0 +1,292 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GENTOO_DEPEND_ON_PERL=no
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools gnome2-utils flag-o-matic perl-module python-single-r1 xdg
+
+DESCRIPTION="GTK Instant Messenger client"
+HOMEPAGE="https://pidgin.im/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/2" # libpurple version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="aqua dbus debug doc eds gadu gnutls groupwise +gstreamer +gtk idn
+meanwhile ncurses networkmanager nls perl pie prediction python sasl spell tcl
+test tk v4l +xscreensaver zephyr zeroconf"
+RESTRICT="!test? ( test )"
+
+# dbus requires python to generate C code for dbus bindings (thus DEPEND only).
+# finch uses libgnt that links with libpython - {R,}DEPEND. But still there is
+# no way to build dbus and avoid libgnt linkage with python. If you want this
+# send patch upstream.
+# purple-url-handler and purple-remote require dbus-python thus in reality we
+# rdepend on python if dbus enabled. But it is possible to separate this dep.
+RDEPEND="
+ >=dev-libs/glib-2.16
+ >=dev-libs/libxml2-2.6.18
+ dbus? (
+ >=dev-libs/dbus-glib-0.71
+ >=sys-apps/dbus-0.90
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+ gadu? ( >=net-libs/libgadu-1.11.0 )
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ dev-libs/nspr
+ dev-libs/nss
+ )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=net-libs/farstream-0.2.7:0.2
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.10:2[aqua=]
+ x11-libs/libSM
+ >=x11-libs/pango-1.4.0
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ spell? ( >=app-text/gtkspell-2.0.2:2 )
+ eds? ( >=gnome-extra/evolution-data-server-3.6:= )
+ prediction? ( >=dev-db/sqlite-3.3:3 )
+ )
+ idn? ( net-dns/libidn:= )
+ meanwhile? ( net-libs/meanwhile )
+ ncurses? (
+ >=dev-libs/libgnt-$(ver_cut 1-2)
+ sys-libs/ncurses:=[unicode(+)]
+ dbus? ( ${PYTHON_DEPS} )
+ python? ( ${PYTHON_DEPS} )
+ )
+ networkmanager? ( net-misc/networkmanager )
+ perl? ( >=dev-lang/perl-5.16:= )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ tcl? ( dev-lang/tcl:0= )
+ tk? ( dev-lang/tk:0= )
+ v4l? ( media-plugins/gst-plugins-v4l2 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+
+# We want nls in case gtk is enabled, bug #
+NLS_DEPEND="
+ >=dev-util/intltool-0.41.1
+ sys-devel/gettext
+"
+DEPEND="
+ ${RDEPEND}
+ gtk? (
+ x11-base/xorg-proto
+ ${NLS_DEPEND}
+ )
+ dbus? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ dev-lang/perl
+ dev-perl/XML-Parser
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ !gtk? ( nls? ( ${NLS_DEPEND} ) )
+ test? ( >=dev-libs/check-0.9.4 )
+"
+
+DOCS=( AUTHORS HACKING NEWS README ChangeLog )
+
+REQUIRED_USE="
+ dbus? ( ${PYTHON_REQUIRED_USE} )
+ networkmanager? ( dbus )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ v4l? ( gstreamer )
+"
+
+# Enable Default protocols
+DEFAULT_PRPLS="irc,jabber,simple"
+
+# List of plugins
+# app-accessibility/pidgin-festival
+# net-im/librvp
+# x11-plugins/guifications
+# x11-plugins/msn-pecan
+# x11-plugins/pidgin-encryption
+# x11-plugins/pidgin-extprefs
+# x11-plugins/pidgin-hotkeys
+# x11-plugins/pidgintex
+# x11-plugins/pidgin-libnotify
+# x11-plugins/pidgin-mbpurple
+# x11-plugins/pidgin-bot-sentry
+# x11-plugins/pidgin-otr
+# x11-plugins/pidgin-rhythmbox
+# x11-plugins/purple-plugin_pack
+# x11-themes/pidgin-smileys
+# x11-plugins/pidgin-knotify
+# Plugins in Sunrise:
+# x11-plugins/pidgin-audacious-remote
+# x11-plugins/pidgin-autoanswer
+# x11-plugins/pidgin-birthday-reminder
+# x11-plugins/pidgin-blinklight
+# x11-plugins/pidgin-convreverse
+# x11-plugins/pidgin-embeddedvideo
+# x11-plugins/pidgin-extended-blist-sort
+# x11-plugins/pidgin-gfire
+# x11-plugins/pidgin-lastfm
+# x11-plugins/pidgin-sendscreenshot
+# x11-plugins/pidgimpd
+
+pkg_pretend() {
+ if ! use gtk && ! use ncurses ; then
+ elog "You did not pick the ncurses or gtk use flags, only libpurple"
+ elog "will be built."
+ fi
+
+ # dbus is enabled, no way to disable linkage with python => python is enabled
+ #REQUIRED_USE="gtk? ( nls ) dbus? ( python )"
+ if use gtk && ! use nls ; then
+ ewarn "gtk build => nls is enabled!"
+ fi
+ if use dbus && ! use python ; then
+ elog "dbus is enabled, no way to disable linkage with python => python is enabled"
+ fi
+}
+
+pkg_setup() {
+ if use python || use dbus ; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ xdg_environment_reset
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Stabilize things, for your own good
+ strip-flags
+ replace-flags -O? -O2
+ use pie && append-cflags -fPIE -pie
+
+ use gadu && DEFAULT_PRPLS+=",gg"
+ use groupwise && DEFAULT_PRPLS+=",novell"
+ use meanwhile && DEFAULT_PRPLS+=",sametime"
+ use zephyr && DEFAULT_PRPLS+=",zephyr"
+ use zeroconf && DEFAULT_PRPLS+=",bonjour"
+
+ local myconf=(
+ --disable-mono
+ --disable-static
+ # Don't downgrade F_S, we already set it in toolchain, bug #890276
+ --disable-fortify
+ --with-dynamic-prpls="${DEFAULT_PRPLS}"
+ --with-system-ssl-certs="${EPREFIX}/etc/ssl/certs/"
+ --x-includes="${EPREFIX}"/usr/include/X11
+ $(use_enable dbus)
+ $(use_enable debug)
+ $(use_enable doc doxygen)
+ $(use_enable gstreamer)
+ $(use_enable gtk gtkui)
+ $(use_enable gtk sm)
+ $(use_enable idn)
+ $(use_enable meanwhile)
+ $(use_enable networkmanager nm)
+ $(use_enable ncurses consoleui)
+ $(use_enable perl)
+ $(use_enable sasl cyrus-sasl )
+ $(use_enable tk)
+ $(use_enable tcl)
+ $(use_enable v4l farstream)
+ $(use_enable v4l gstreamer-video)
+ $(use_enable v4l vv)
+ $(use_enable zeroconf avahi)
+ $(use_with gstreamer gstreamer 1.0)
+ $(usex gtk '--enable-nls' "$(use_enable nls)")
+ $(use gtk && use_enable eds gevolution)
+ $(use gtk && use_enable prediction cap)
+ $(use gtk && use_enable spell gtkspell)
+ $(use gtk && use_enable xscreensaver screensaver)
+ )
+
+ if use gnutls ; then
+ einfo "Disabling NSS, using GnuTLS"
+ myconf+=(
+ --enable-gnutls=yes
+ --enable-nss=no
+ --with-gnutls-includes="${EPREFIX}/usr/include/gnutls"
+ --with-gnutls-libs="${EPREFIX}/usr/$(get_libdir)"
+ )
+ else
+ einfo "Disabling GnuTLS, using NSS"
+ myconf+=(
+ --enable-gnutls=no
+ --enable-nss=yes
+ )
+ fi
+
+ if use dbus || { use ncurses && use python ; } ; then
+ myconf+=( --with-python3=${PYTHON} )
+ else
+ myconf+=( --without-python3 )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ # setting this here because we no longer use gnome2.eclass
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ default
+
+ if use gtk ; then
+ # Fix tray paths for e16 (x11-wm/enlightenment) and other
+ # implementations that are not compliant with new hicolor theme yet, #323355
+ local d f pixmapdir
+ for d in 16 22 32 48 ; do
+ pixmapdir="${ED}/usr/share/pixmaps/pidgin/tray/hicolor/${d}x${d}/actions"
+ mkdir "${pixmapdir}" || die
+ pushd "${pixmapdir}" >/dev/null || die
+ for f in ../status/*; do
+ ln -s ${f} || die
+ done
+ popd >/dev/null || die
+ done
+ fi
+ use perl && perl_delete_localpod
+
+ use dbus && python_fix_shebang "${ED}"
+ if use python || use dbus ; then
+ python_optimize
+ fi
+
+ dodoc ${DOCS[@]} finch/plugins/pietray.py
+ docompress -x /usr/share/doc/${PF}/pietray.py
+
+ find "${ED}" -type f -name "*.la" -delete || die
+}
+
+src_test() {
+ # make default build logs slightly more useful
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ emake check VERBOSE=1
+}
+
+pkg_preinst() {
+ gnome2_gconf_savelist
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_gconf_install
+ gnome2_schemas_update
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_gconf_uninstall
+ gnome2_schemas_update
+ xdg_pkg_postrm
+}