summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-04-06 08:39:12 +0200
committerLars Wendler <polynomial-c@gentoo.org>2016-04-06 08:45:14 +0200
commite6e3c91b2e092158c6fb066cc91da73cbe4fdcc7 (patch)
treea67ffbf280ac55cca7f2ecd65c90952ccae28167 /net-im/pidgin
parentdev-lang/parrot: Bump (diff)
downloadgentoo-e6e3c91b2e092158c6fb066cc91da73cbe4fdcc7.tar.gz
gentoo-e6e3c91b2e092158c6fb066cc91da73cbe4fdcc7.tar.bz2
gentoo-e6e3c91b2e092158c6fb066cc91da73cbe4fdcc7.zip
net-im/pidgin: networkmanager requires dbus (bug #579012).
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-im/pidgin')
-rw-r--r--net-im/pidgin/pidgin-2.10.12-r2.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/net-im/pidgin/pidgin-2.10.12-r2.ebuild b/net-im/pidgin/pidgin-2.10.12-r2.ebuild
index 86d8b5f58bbe..aa8dcdc4c6a0 100644
--- a/net-im/pidgin/pidgin-2.10.12-r2.ebuild
+++ b/net-im/pidgin/pidgin-2.10.12-r2.ebuild
@@ -84,8 +84,9 @@ DEPEND="$RDEPEND
DOCS="AUTHORS HACKING NEWS README ChangeLog"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
- dbus? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="dbus? ( ${PYTHON_REQUIRED_USE} )
+ networkmanager? ( dbus )
+ python? ( ${PYTHON_REQUIRED_USE} )"
# Enable Default protocols
DYNAMIC_PRPLS="irc,jabber,oscar,yahoo,simple,msn,myspace"
@@ -161,12 +162,10 @@ src_configure() {
replace-flags -O? -O2
use pie && CFLAGS="${CFLAGS} -fPIE -pie"
- local myconf
+ local myconf=()
if use gadu; then
DYNAMIC_PRPLS="${DYNAMIC_PRPLS},gg"
- myconf="${myconf} --with-gadu-includes=."
- myconf="${myconf} --with-gadu-libs=."
fi
use groupwise && DYNAMIC_PRPLS+=",novell"
@@ -178,18 +177,18 @@ src_configure() {
if use gnutls; then
einfo "Disabling NSS, using GnuTLS"
- myconf+=" --enable-nss=no --enable-gnutls=yes"
- myconf+=" --with-gnutls-includes=${EPREFIX}/usr/include/gnutls"
- myconf+=" --with-gnutls-libs=${EPREFIX}/usr/$(get_libdir)"
+ myconf+=( --enable-nss=no --enable-gnutls=yes )
+ myconf+=( --with-gnutls-includes=${EPREFIX}/usr/include/gnutls )
+ myconf+=( --with-gnutls-libs=${EPREFIX}/usr/$(get_libdir) )
else
einfo "Disabling GnuTLS, using NSS"
- myconf+=" --enable-gnutls=no --enable-nss=yes"
+ myconf+=( --enable-gnutls=no --enable-nss=yes )
fi
if use dbus || { use ncurses && use python; }; then
- myconf+=" --with-python=${PYTHON}"
+ myconf+=( --with-python=${PYTHON} )
else
- myconf+=" --without-python"
+ myconf+=( --without-python )
fi
econf \
@@ -221,7 +220,7 @@ src_configure() {
--with-dynamic-prpls="${DYNAMIC_PRPLS}" \
--disable-mono \
--x-includes="${EPREFIX}"/usr/include/X11 \
- ${myconf}
+ ${myconf[@]}
#$(use_enable mono) \
}