summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-05-06 20:01:43 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-05-06 20:17:48 +0100
commit264784f98311837d8a77e262d7bafe52ac759c1c (patch)
tree2a991580c5b8118f3917e712aa0e66e1e8ec81a9 /net-im/profanity
parentdev-libs/libstrophe: add new package (diff)
downloadgentoo-264784f98311837d8a77e262d7bafe52ac759c1c.tar.gz
gentoo-264784f98311837d8a77e262d7bafe52ac759c1c.tar.bz2
gentoo-264784f98311837d8a77e262d7bafe52ac759c1c.zip
net-im/profanity: add new package
Based on the ebuild contributed by Dennis Schridde <devurandom@gmx.net> - huge thanks! Bug: https://bugs.gentoo.org/558840 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'net-im/profanity')
-rw-r--r--net-im/profanity/Manifest1
-rw-r--r--net-im/profanity/metadata.xml16
-rw-r--r--net-im/profanity/profanity-0.6.0.ebuild39
3 files changed, 56 insertions, 0 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
new file mode 100644
index 000000000000..94dfe57fd10c
--- /dev/null
+++ b/net-im/profanity/Manifest
@@ -0,0 +1 @@
+DIST profanity-0.6.0.tar.gz 741812 BLAKE2B ba6cff070ee0e8a83b52677f6551c1d7397cd25993982d6b5390590a4924d902050504cb8803ee2741262b1409e4d75e9f223397f87f39d7dc86fcc56a0e5df6 SHA512 c7d8e74b764276f59fccfa029d45271032db315cdbf6e00deccbd611f202983a0930fed99021202333047acee9f3f0d7779cd9bb3628d2e5c4757e3de8c3629e
diff --git a/net-im/profanity/metadata.xml b/net-im/profanity/metadata.xml
new file mode 100644
index 000000000000..d2349017e1a3
--- /dev/null
+++ b/net-im/profanity/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrey_utkin@gentoo.org</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <longdescription>
+ Profanity is a console based XMPP client written in C using
+ ncurses and libstrophe, inspired by Irssi.
+ </longdescription>
+ <use>
+ <flag name="gpg">Enable OpenPGP encryption</flag>
+ <flag name="otr">Enable encrypted conversations using Off-The-Records messaging</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-im/profanity/profanity-0.6.0.ebuild b/net-im/profanity/profanity-0.6.0.ebuild
new file mode 100644
index 000000000000..402ca75c0859
--- /dev/null
+++ b/net-im/profanity/profanity-0.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A console based XMPP client inspired by Irssi"
+HOMEPAGE="http://www.profanity.im/"
+SRC_URI="http://www.profanity.im/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="libnotify otr gpg xscreensaver"
+
+DEPEND="
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/libstrophe:=
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/ncurses:=[unicode]
+ gpg? ( app-crypt/gpgme:= )
+ libnotify? ( x11-libs/libnotify )
+ otr? ( net-libs/libotr )
+ xscreensaver? (
+ x11-libs/libXScrnSaver
+ x11-libs/libX11 )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable otr) \
+ $(use_enable gpg pgp) \
+ $(use_with xscreensaver)
+}