summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2016-09-09 15:01:29 +0200
committerWolfram Schlich <wschlich@gentoo.org>2016-09-09 15:02:57 +0200
commit2b453e9de064709a7e3fa21d74b2cb5f2da05e4f (patch)
treebfff33ad33d7b789e625d9af84d98cbd400ef958 /net-im/skype
parentdev-python/parse-type: rev-bump for EAPI 6 bump and py-3.5 support (diff)
downloadgentoo-2b453e9de064709a7e3fa21d74b2cb5f2da05e4f.tar.gz
gentoo-2b453e9de064709a7e3fa21d74b2cb5f2da05e4f.tar.bz2
gentoo-2b453e9de064709a7e3fa21d74b2cb5f2da05e4f.zip
net-im/skype: initial import of new alpha version (with lower version number), see bug #588814
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-im/skype')
-rw-r--r--net-im/skype/Manifest1
-rw-r--r--net-im/skype/skype-1.7.0.1.ebuild106
2 files changed, 107 insertions, 0 deletions
diff --git a/net-im/skype/Manifest b/net-im/skype/Manifest
index 0a7499bffb0a..2784dc456611 100644
--- a/net-im/skype/Manifest
+++ b/net-im/skype/Manifest
@@ -1 +1,2 @@
DIST skype-4.3.0.37.tar.bz2 19310701 SHA256 8c99dc3978a588fb13303df7c8134379fb55b8dd460efefbc79ae594269b892d SHA512 935d0c06c031a90414f9b20c9a782c59deee36abff781c08f1dfd62194763dc9674bb85d478ae916b1bf440b123291d64380bc28295e9ecdd6522d17b434b7a5 WHIRLPOOL 1e5a84b04d7eb9bbf3bae9ae6e69bb41587a1cef7f5ff19af0363343fd7fc949d5202959efaf93b0ed9ccb939b8b2ad4d61fc9626fffbdc2a8d898f9fa29b300
+DIST skypeforlinux_1.7.0.1-1.x86_64.rpm 58391020 SHA256 db74489b0e96f5a590ab20567ec69178e9bed1c4d89963569f751814096da66b SHA512 7bbb9c13213aac000d39cc27856ddbae173a9bad373c2051a72872f7e33b938cc9d9f673e2f0f9e734b2e396b4717ea5b5d65d18afa2f080c21291d1585f6044 WHIRLPOOL f33bd8e016f0da37d6eea8d530b55b979677fbf794d331246a75385b27c6bdcf0769ed8beda0a22313bb55b6eac30948a480f0aa8b12d98d73567a9f4e9a94d2
diff --git a/net-im/skype/skype-1.7.0.1.ebuild b/net-im/skype/skype-1.7.0.1.ebuild
new file mode 100644
index 000000000000..a650d3c0f59e
--- /dev/null
+++ b/net-im/skype/skype-1.7.0.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+#inherit eutils rpm pax-utils
+inherit eutils rpm
+
+DESCRIPTION="P2P Internet Telephony (VoiceIP) client"
+HOMEPAGE="http://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/skypeforlinux_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS no-source-code"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+#IUSE="pax_kernel selinux"
+IUSE=""
+
+S="${WORKDIR}"
+QA_PREBUILT=opt/skypeforlinux/skypeforlinux
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ !${CATEGORY}/${PN}:0
+ virtual/ttf-fonts
+ gnome-base/libgnome-keyring
+ gnome-base/gnome-keyring
+ gnome-base/gconf"
+# selinux? ( sec-policy/selinux-skype )"
+
+src_unpack () {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EROOT}opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux
+ sed -e "s!^Exec=.*!Exec=${EROOT}opt/bin/skypeforlinux!" \
+ -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -i usr/share/applications/skypeforlinux.desktop
+}
+
+src_install() {
+
+ insinto /opt/skypeforlinux/locales
+ doins usr/share/skypeforlinux/locales/*.pak
+
+ insinto /opt/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release
+ doins usr/share/skypeforlinux/resources/app.asar.unpacked/node_modules/keytar/build/Release/keytar.node
+
+ insinto /opt/skypeforlinux/resources
+ doins usr/share/skypeforlinux/resources/*.asar
+
+ insinto /opt/skypeforlinux
+ doins usr/share/skypeforlinux/*.pak
+ doins usr/share/skypeforlinux/*.bin
+ doins usr/share/skypeforlinux/*.dat
+ doins usr/share/skypeforlinux/version
+ exeinto /opt/skypeforlinux
+ doexe usr/share/skypeforlinux/*.so
+ doexe usr/share/skypeforlinux/skypeforlinux
+
+ into /opt
+ dobin usr/bin/skypeforlinux
+ fowners root:audio /opt/bin/skypeforlinux /opt/skypeforlinux/skypeforlinux
+
+# insinto /etc/dbus-1/system.d
+# doins ${PN}.conf
+
+ dodoc usr/share/doc/skypeforlinux/* usr/share/skypeforlinux/*.html
+ dodoc usr/share/skypeforlinux/*.txt usr/share/skypeforlinux/LICENSE
+
+ # create compat symlink
+ dosym ${P} /usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+# if use pax_kernel; then
+# if use apulse; then
+# pax-mark Cm "${ED}"/opt/bin/${PN}-bin || die
+# else
+# pax-mark Cm "${ED}"/opt/bin/${PN} || die
+# fi
+# eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+# eqawarn "${PN} under a PaX enabled kernel. To do so, we must modify"
+# eqawarn "the ${PN} binary itself and this *may* lead to breakage! If"
+# eqawarn "you suspect that ${PN} is being broken by this modification,"
+# eqawarn "please open a bug."
+# fi
+
+# echo PRELINK_PATH_MASK=/opt/bin/${PN} > ${T}/99${PN}
+# doenvd "${T}"/99${PN} #430142
+}
+
+pkg_postinst() {
+ einfo "See https://support.skype.com/en/faq/FA34656"
+ einfo "for more information about Skype for Linux Alpha."
+}