summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-02-19 18:11:59 +0100
committerDavid Seifert <soap@gentoo.org>2021-02-19 18:11:59 +0100
commitfc8b4532b676801d8b3339847bce8239ef2e0710 (patch)
treee8c38f59e25e0f6e30339272233f5ce4acb62344 /net-im/skypeforlinux
parentsys-devel/clang-runtime: x86 stable (bug #768567) (diff)
downloadgentoo-fc8b4532b676801d8b3339847bce8239ef2e0710.tar.gz
gentoo-fc8b4532b676801d8b3339847bce8239ef2e0710.tar.bz2
gentoo-fc8b4532b676801d8b3339847bce8239ef2e0710.zip
net-im/skypeforlinux: Version bump to 8.69.0.77
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-im/skypeforlinux')
-rw-r--r--net-im/skypeforlinux/Manifest1
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.69.0.77.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 12451363030e..9afa2ac2e34d 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1,2 +1,3 @@
DIST skypeforlinux_8.67.0.96-1.x86_64.rpm 113616838 BLAKE2B aecf6d8f24836d2d6ef23b80b79796cbe5e309af862eac5e8caa0436e6cc8f10de5fd6337901c70a4b5b5c6cc3d7d15f6b0225b86187db800c8374762adf0313 SHA512 8d1c35026bbe90a2492f3ac88cc8fb2f098258050cf263121a06b9c9e048bda18774582d669d9a9177d8cfcaaa66a615b206587e74b371ef80b089dfecbb9a2e
DIST skypeforlinux_8.68.0.100-1.x86_64.rpm 113061038 BLAKE2B f8d04c1d1727e6e90527d3ca820f411f6358b152f15960f1673d07da9e20cd784c230084a539bc3cf6d96b025c6a34bedc814dc9af94826d51746f13e6a56a64 SHA512 457f2ff3a904776b3b03ea06004e81576d1394aa5adae80bd3fb6c46e319188c5733d7da820b5eead987e5530caba9c75090ce7ca8f108ad19786b76affd3cb8
+DIST skypeforlinux_8.69.0.77-1.x86_64.rpm 117875764 BLAKE2B 8f817c595b09f5e9c0e0ca10c2e34d76cc3d56da115950adebe6e43ca7d8715d2a20df862a76fd51fef639cc0664ba3b19976b93406e98da50b8ec07a7323c39 SHA512 a04a2e357192ee9390ebeb00aeeec3a230eb0b7b3cf00f32aab1323dfe61b8ebf980a459db779f1b14266c5b7ff9b1f749ce1bba56025ada06d137ff552db35c
diff --git a/net-im/skypeforlinux/skypeforlinux-8.69.0.77.ebuild b/net-im/skypeforlinux/skypeforlinux-8.69.0.77.ebuild
new file mode 100644
index 000000000000..01550d2ccb08
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.69.0.77.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}