summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-03-04 19:21:14 +0000
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-03-10 02:18:25 +0000
commitd1ffc1ff3349eabd0f7ee13a6fe77407cb284cc1 (patch)
tree7c9defa9043f5ac847f236a32c5b19d97eafc625 /net-im/spectrum2
parentdev-scheme/guile-cairo: drop EAPI2 ebuild (diff)
downloadgentoo-d1ffc1ff3349eabd0f7ee13a6fe77407cb284cc1.tar.gz
gentoo-d1ffc1ff3349eabd0f7ee13a6fe77407cb284cc1.tar.bz2
gentoo-d1ffc1ff3349eabd0f7ee13a6fe77407cb284cc1.zip
net-im/spectrum2: drop broken 'debug' USE flag
Switching to Debug CMake configuration leads to an odd effect. Users can just supply extra CFLAGS for better debugging info, which is exactly what Debug CMake configuration does. No revbump since this is a build failure issue. Successful installations don't need a rebuild. Bug: https://bugs.gentoo.org/674498 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
Diffstat (limited to 'net-im/spectrum2')
-rw-r--r--net-im/spectrum2/files/spectrum2-2.0.9-remove_debug_cflags.patch13
-rw-r--r--net-im/spectrum2/spectrum2-2.0.10.ebuild10
2 files changed, 1 insertions, 22 deletions
diff --git a/net-im/spectrum2/files/spectrum2-2.0.9-remove_debug_cflags.patch b/net-im/spectrum2/files/spectrum2-2.0.9-remove_debug_cflags.patch
deleted file mode 100644
index 19e3b83d2300..000000000000
--- a/net-im/spectrum2/files/spectrum2-2.0.9-remove_debug_cflags.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/CMakeLists.txt 2018-09-17 09:46:40.000000000 +0200
-+++ b/CMakeLists.txt 2018-09-20 21:04:29.000000000 +0200
-@@ -384,10 +384,6 @@
- endif()
-
- if(CMAKE_BUILD_TYPE MATCHES Debug)
-- if (CMAKE_COMPILER_IS_GNUCXX)
-- ADD_DEFINITIONS(-O0)
-- ADD_DEFINITIONS(-ggdb)
-- endif()
- ADD_DEFINITIONS(-DDEBUG)
- message("Debug : yes")
- else(CMAKE_BUILD_TYPE MATCHES Debug)
diff --git a/net-im/spectrum2/spectrum2-2.0.10.ebuild b/net-im/spectrum2/spectrum2-2.0.10.ebuild
index ddc335eca687..317a25b2ab55 100644
--- a/net-im/spectrum2/spectrum2-2.0.10.ebuild
+++ b/net-im/spectrum2/spectrum2-2.0.10.ebuild
@@ -14,7 +14,7 @@ SRC_URI="https://github.com/SpectrumIM/spectrum2/archive/${PV}.tar.gz -> ${P}.ta
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="debug doc frotz irc mysql postgres purple sms +sqlite test twitter whatsapp xmpp"
+IUSE="doc frotz irc mysql postgres purple sms +sqlite test twitter whatsapp xmpp"
REQUIRED_USE="|| ( mysql postgres sqlite )"
RDEPEND="
@@ -59,8 +59,6 @@ DEPEND="
)
"
-PATCHES=( "${FILESDIR}/${PN}-2.0.9-remove_debug_cflags.patch" )
-
# Tests are currently restricted, as they do completly fail
RESTRICT="test"
@@ -75,16 +73,10 @@ src_prepare() {
# Respect users LDFLAGS
sed -i -e "s/-Wl,-export-dynamic/& ${LDFLAGS}/" spectrum/src/CMakeLists.txt || die
- # Respect users CFLAGS, when compiling for debug mode
- # Since Spectrum2 searches for a qt4 compiled libcommuni,
- # it must be patched, to find the qt5 compiled libcommuni,
- # See: https://github.com/SpectrumIM/spectrum2/pull/253
cmake-utils_src_prepare
}
src_configure() {
- use debug && CMAKE_BUILD_TYPE="Debug"
-
local mycmakeargs=(
-DENABLE_DOCS="$(usex doc)"
-DENABLE_FROTZ="$(usex frotz)"