summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-05-27 23:04:09 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-05-27 23:06:38 -0700
commitb959c4bc9b8abc6778fc083ca5b22138eb3c8e8b (patch)
tree5c42a569e5223787bb903a9fa5da8c935dc0fdfd /net-im/telegram-desktop
parentnet-im/telegram-desktop: add qt-5.15 include patch (diff)
downloadgentoo-b959c4bc9b8abc6778fc083ca5b22138eb3c8e8b.tar.gz
gentoo-b959c4bc9b8abc6778fc083ca5b22138eb3c8e8b.tar.bz2
gentoo-b959c4bc9b8abc6778fc083ca5b22138eb3c8e8b.zip
net-im/telegram-desktop: drop 2.1.6
Closes: https://bugs.gentoo.org/709720 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-im/telegram-desktop')
-rw-r--r--net-im/telegram-desktop/Manifest1
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.1.6.ebuild145
2 files changed, 0 insertions, 146 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index 2b51fd9ad32a..b6370d71ca51 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1,3 +1,2 @@
DIST tdesktop-2.1.0-full.tar.gz 26133964 BLAKE2B c5eb476ea3ed02c2618e5b770bdce365bcf0d6124f75558570189e07e9dcd9f6f3282d53fec621be736cbd1269a9dd820629d4d9a36167d8f71109bfcd5a52e2 SHA512 46f5453c64d1dbd4cf8adde73fcc48e6b6f795972ab0f6516cb55112f47d5af990a049da356bedb81e6d3f7103c14a7be45369ff9a5a1812c07a1bfcda70646d
-DIST tdesktop-2.1.6-full.tar.gz 36478989 BLAKE2B 4c5364e560500efd445232c05556d1bdce63881b179906cef2602161944ac45d63af19c6f97b57dec9224c12a5b083c83fee4cbb56986c3edbbe3d76710f16c7 SHA512 a6a105676d8d24ec3414895cadc664829c5abc041d8614409e22d7964d7280e44df35ece5fca18a0cd127f65bd363abc1e5c36807b0031eabd6eb77c7effdfb8
DIST tdesktop-2.1.7-full.tar.gz 36509059 BLAKE2B 4a1bf5879e71e64f34024165f9db39f69d1d8e87b0387704bdb74415d60d6a1efd22ab1fec994116a72a6982a55f13cee0edb667060bbe9336cba4ce12e7472c SHA512 f942ce93d9671f3bb95a8fbba107fc851bfe3f28871c9651f6f2d97d711602f8a671f7b74750894b2175d33a67c25017562cd4ee455da7aa9b86755d1c3f1cfb
diff --git a/net-im/telegram-desktop/telegram-desktop-2.1.6.ebuild b/net-im/telegram-desktop/telegram-desktop-2.1.6.ebuild
deleted file mode 100644
index 3206772347bb..000000000000
--- a/net-im/telegram-desktop/telegram-desktop-2.1.6.ebuild
+++ /dev/null
@@ -1,145 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit cmake desktop flag-o-matic python-any-r1 xdg-utils
-
-MY_P="tdesktop-${PV}-full"
-
-DESCRIPTION="Official desktop client for Telegram"
-HOMEPAGE="https://desktop.telegram.org"
-SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3-with-openssl-exception"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64"
-IUSE="+alsa +dbus enchant +hunspell libressl pulseaudio +spell wayland +X"
-
-RDEPEND="
- !net-im/telegram-desktop-bin
- app-arch/lz4:=
- app-arch/xz-utils
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- dev-cpp/range-v3
- dev-libs/xxhash
- dev-qt/qtcore:5
- dev-qt/qtgui:5[jpeg,png,wayland?,X(-)?]
- dev-qt/qtimageformats:5
- dev-qt/qtnetwork:5
- dev-qt/qtsvg:5
- dev-qt/qtwidgets:5[png,X(-)?]
- media-fonts/open-sans
- media-libs/fontconfig:=
- >=media-libs/libtgvoip-2.4.4_p20200430[alsa?,pulseaudio?]
- media-libs/openal[alsa?,pulseaudio?]
- media-libs/opus:=
- media-video/ffmpeg:=[alsa?,opus,pulseaudio?]
- sys-libs/zlib[minizip]
- virtual/libiconv
- dbus? (
- dev-qt/qtdbus:5
- dev-libs/libdbusmenu-qt[qt5(+)]
- )
- enchant? ( app-text/enchant:= )
- hunspell? ( >=app-text/hunspell-1.7:= )
- pulseaudio? ( media-sound/pulseaudio )
-"
-
-DEPEND="
- ${PYTHON_DEPS}
- ${RDEPEND}
-"
-
-BDEPEND="
- >=dev-util/cmake-3.16
- virtual/pkgconfig
-"
-
-REQUIRED_USE="
- || ( alsa pulseaudio )
- || ( X wayland )
- spell? (
- ^^ ( enchant hunspell )
- )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_pretend() {
- if has ccache ${FEATURES}; then
- ewarn
- ewarn "ccache does not work with ${PN} out of the box"
- ewarn "due to usage of precompiled headers"
- ewarn "check bug https://bugs.gentoo.org/715114 for more info"
- ewarn
- fi
-}
-
-src_configure() {
- local mycxxflags=(
- -Wno-deprecated-declarations
- -Wno-error=deprecated-declarations
- -Wno-switch
- )
-
- append-cxxflags "${mycxxflags[@]}"
-
- # TODO: unbundle header-only libs, ofc telegram uses git versions...
- # it fals with tl-expected-1.0.0, so we use bundled for now to avoid git rev snapshots
- # EXPECTED VARIANT
- # TODO: unbundle GSL, version 3.0.1 required and has nasty googletest dep
- local mycmakeargs=(
- -DDESKTOP_APP_DISABLE_CRASH_REPORTS=ON
- -DDESKTOP_APP_USE_GLIBC_WRAPS=OFF
- -DDESKTOP_APP_USE_PACKAGED=ON
- -DDESKTOP_APP_USE_PACKAGED_EXPECTED=OFF
- -DDESKTOP_APP_USE_PACKAGED_GSL=OFF
- -DDESKTOP_APP_USE_PACKAGED_RLOTTIE=OFF
- -DDESKTOP_APP_USE_PACKAGED_VARIANT=OFF
- -DTDESKTOP_LAUNCHER_BASENAME="${PN}"
- -DDESKTOP_APP_DISABLE_DBUS_INTEGRATION="$(usex dbus OFF ON)"
- -DDESKTOP_APP_DISABLE_SPELLCHECK="$(usex spell OFF ON)" # enables hunspell (recommended)
- -DDESKTOP_APP_USE_ENCHANT="$(usex enchant ON OFF)" # enables enchant and disables hunspell
- )
-
- if [[ -n ${MY_TDESKTOP_API_ID} && -n ${MY_TDESKTOP_API_HASH} ]]; then
- einfo "Found custom API credentials"
- mycmakeargs+=(
- -DTDESKTOP_API_ID="${MY_TDESKTOP_API_ID}"
- -DTDESKTOP_API_HASH="${MY_TDESKTOP_API_HASH}"
- )
- else
- # https://github.com/telegramdesktop/tdesktop/blob/dev/snap/snapcraft.yaml
- # Building with snapcraft API credentials by default
- # Custom API credentials can be obtained here:
- # https://github.com/telegramdesktop/tdesktop/blob/dev/docs/api_credentials.md
- # After getting credentials you can export variables:
- # export MY_TDESKTOP_API_ID="17349""
- # export MY_TDESKTOP_API_HASH="344583e45741c457fe1862106095a5eb"
- # and restart the build"
- # you can set above variables (without export) in /etc/portage/env/net-im/telegram-desktop
- # portage will use custom variable every build automatically
- mycmakeargs+=(
- -DTDESKTOP_API_ID="611335"
- -DTDESKTOP_API_HASH="d524b414d21f4d37f08684c1df41ac9c"
- )
- fi
-
- cmake_src_configure
-}
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
- xdg_mimeinfo_database_update
-}