summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-07-17 11:10:40 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-07-17 11:10:57 -0700
commite631981144117cad28fc202d007f5f06154521de (patch)
treec838d6f673ea6ff0e252411a1d16de5fdc19cd2f /net-im/telegram-desktop
parentmedia-libs/libtgvoip: drop old (diff)
downloadgentoo-e631981144117cad28fc202d007f5f06154521de.tar.gz
gentoo-e631981144117cad28fc202d007f5f06154521de.tar.bz2
gentoo-e631981144117cad28fc202d007f5f06154521de.zip
net-im/telegram-desktop: bump to 2.1.20
wayland is not optional anymore. Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'net-im/telegram-desktop')
-rw-r--r--net-im/telegram-desktop/Manifest2
-rw-r--r--net-im/telegram-desktop/files/2.1.20-qt-includes.patch72
-rw-r--r--net-im/telegram-desktop/telegram-desktop-2.1.20.ebuild (renamed from net-im/telegram-desktop/telegram-desktop-2.1.18.ebuild)11
3 files changed, 80 insertions, 5 deletions
diff --git a/net-im/telegram-desktop/Manifest b/net-im/telegram-desktop/Manifest
index baec09df3b84..eb85fb1360ae 100644
--- a/net-im/telegram-desktop/Manifest
+++ b/net-im/telegram-desktop/Manifest
@@ -1,2 +1,2 @@
DIST tdesktop-2.1.13-full.tar.gz 36549505 BLAKE2B 48514be8add4ad4491c8e81a868f140228787ee489de7cd90faf31dbee959b0fb87cf2c844bf98c5b62fd6de8e32f504a6d19b071c56e6a4c0cd489d7b283818 SHA512 f28ae7c8c9a9eb8094fc52784742b470235234a3df7487902152858bc7c297b2dcfe5c8b939cdb9653a356b3835609e7289f53cdf7d5fb3f009823d3dbeb1bd8
-DIST tdesktop-2.1.18-full.tar.gz 36579968 BLAKE2B 49b0d8e6fd1233588601fdd39ba22f1686ad2d9900e71ebdadc3f0c8870bb2c752e60f437795ab484d87899aad7edcc7e530ae3c640d9a875f889d004c83e525 SHA512 e7c1df200ac5ca8f0d3cb244e9a5daf49996046176488046d8d503ecfbf67d91bec9504fb712cfd649ae5cc0bed1cbbfc78e3a9fd6bed95c558cf51cb014dd66
+DIST tdesktop-2.1.20-full.tar.gz 36585360 BLAKE2B 217a90ca07513f8c2e1f1fcd4f543cafabc4d85fd5ef29417a18c55fc6f64c0070c02d34bfcae86c434153ba015713139f0f61733a9b31e53dd011ac4943de6c SHA512 6e5c2ddec7fc447cf0900665153772b82ddc5d9d1f4dc6061b60dc003f0c295acb01795fa7201e3cde27705f866a30a7d2d3740556b1e8d1de49a12ae276ef9c
diff --git a/net-im/telegram-desktop/files/2.1.20-qt-includes.patch b/net-im/telegram-desktop/files/2.1.20-qt-includes.patch
new file mode 100644
index 000000000000..a2f02aea3b05
--- /dev/null
+++ b/net-im/telegram-desktop/files/2.1.20-qt-includes.patch
@@ -0,0 +1,72 @@
+From 9eb24ca5c194482faf86e68d93527707fa01a78e Mon Sep 17 00:00:00 2001
+From: Ilya Fedin <fedin-ilja2010@ya.ru>
+Date: Thu, 16 Jul 2020 18:54:29 +0400
+Subject: [PATCH] QtWaylandClient contains QtXkbCommonSupport includes
+
+---
+ external/qt/CMakeLists.txt | 25 +++++++++++++++++++++++++
+ external/qt/package.cmake | 1 +
+ 2 files changed, 26 insertions(+)
+
+diff --git a/external/qt/CMakeLists.txt b/external/qt/CMakeLists.txt
+index 25b662a..490d13b 100644
+--- a/cmake/external/qt/CMakeLists.txt
++++ b/cmake/external/qt/CMakeLists.txt
+@@ -57,6 +57,15 @@ if (DESKTOP_APP_USE_PACKAGED)
+ )
+ endif()
+
++ if (Qt5XkbCommonSupport_FOUND)
++ target_link_libraries(external_qt INTERFACE Qt5::XkbCommonSupport)
++
++ target_include_directories(external_qt
++ INTERFACE
++ ${Qt5XkbCommonSupport_PRIVATE_INCLUDE_DIRS}
++ )
++ endif()
++
+ if (Qt5WaylandClient_FOUND)
+ target_link_libraries(external_qt INTERFACE Qt5::WaylandClient)
+
+@@ -97,6 +106,15 @@ else()
+ )
+ endif()
+
++ if (Qt5XkbCommonSupport_FOUND)
++ target_include_directories(external_qt SYSTEM
++ INTERFACE
++ ${qt_loc}/include/QtXkbCommonSupport
++ ${qt_loc}/include/QtXkbCommonSupport/${qt_version}
++ ${qt_loc}/include/QtXkbCommonSupport/${qt_version}/QtXkbCommonSupport
++ )
++ endif()
++
+ if (LINUX)
+ target_include_directories(external_qt SYSTEM
+ INTERFACE
+@@ -129,6 +147,13 @@ else()
+ )
+ endif()
+
++ if (Qt5XkbCommonSupport_FOUND)
++ target_compile_definitions(external_qt
++ INTERFACE
++ QT_XKBCOMMON_SUPPORT_LIB
++ )
++ endif()
++
+ if (LINUX)
+ target_compile_definitions(external_qt
+ INTERFACE
+diff --git a/external/qt/package.cmake b/external/qt/package.cmake
+index 4e97717..ac40f05 100644
+--- a/cmake/external/qt/package.cmake
++++ b/cmake/external/qt/package.cmake
+@@ -25,6 +25,7 @@ find_package(Qt5Gui COMPONENTS QWebpPlugin REQUIRED)
+
+ if (LINUX)
+ find_package(Qt5 COMPONENTS WaylandClient REQUIRED)
++ find_package(Qt5 COMPONENTS XkbCommonSupport)
+
+ if (NOT DESKTOP_APP_USE_PACKAGED)
+ find_package(Qt5 COMPONENTS Svg X11Extras REQUIRED)
diff --git a/net-im/telegram-desktop/telegram-desktop-2.1.18.ebuild b/net-im/telegram-desktop/telegram-desktop-2.1.20.ebuild
index 0ef79f82b7cc..8d40c4048a74 100644
--- a/net-im/telegram-desktop/telegram-desktop-2.1.18.ebuild
+++ b/net-im/telegram-desktop/telegram-desktop-2.1.20.ebuild
@@ -16,7 +16,7 @@ SRC_URI="https://github.com/telegramdesktop/tdesktop/releases/download/v${PV}/${
LICENSE="GPL-3-with-openssl-exception"
SLOT="0"
KEYWORDS="~amd64 ~ppc64"
-IUSE="+alsa +dbus enchant +gtk +hunspell libressl pulseaudio +spell wayland +X"
+IUSE="+alsa +dbus enchant +gtk +hunspell libressl pulseaudio +spell +X"
RDEPEND="
!net-im/telegram-desktop-bin
@@ -24,13 +24,15 @@ RDEPEND="
app-arch/xz-utils
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
+ dev-libs/wayland
dev-libs/xxhash
dev-qt/qtcore:5
- dev-qt/qtgui:5[dbus?,jpeg,png,wayland?,X(-)?]
+ dev-qt/qtgui:5[dbus?,jpeg,png,wayland,X(-)?]
dev-qt/qtimageformats:5
dev-qt/qtnetwork:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5[png,X(-)?]
+ dev-qt/qtx11extras:5
media-fonts/open-sans
media-libs/fontconfig:=
~media-libs/libtgvoip-2.4.4_p20200704[alsa?,pulseaudio?]
@@ -47,7 +49,7 @@ RDEPEND="
gtk? (
dev-libs/glib:2
x11-libs/gdk-pixbuf:2[jpeg,X?]
- x11-libs/gtk+:3[X?,wayland?]
+ x11-libs/gtk+:3[X?,wayland]
x11-libs/libX11
)
hunspell? ( >=app-text/hunspell-1.7:= )
@@ -68,7 +70,6 @@ BDEPEND="
REQUIRED_USE="
|| ( alsa pulseaudio )
- || ( X wayland )
spell? (
^^ ( enchant hunspell )
)
@@ -76,6 +77,8 @@ REQUIRED_USE="
S="${WORKDIR}/${MY_P}"
+PATCHES=( "${FILESDIR}/${PV}-qt-includes.patch" )
+
pkg_pretend() {
if has ccache ${FEATURES}; then
ewarn