summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Campbell <zlg@gentoo.org>2017-02-22 01:18:41 -0800
committerDaniel Campbell <zlg@gentoo.org>2017-02-22 01:18:41 -0800
commitb48b82c80ccca5df204102a8dab0abf0283cd11d (patch)
tree5d6173b4448ea71f29b154d6fdef069058ef0dfa /net-im/toxic/toxic-0.7.2.ebuild
parentapp-emulation/xen-tools: fix XSA-209 (diff)
downloadgentoo-b48b82c80ccca5df204102a8dab0abf0283cd11d.tar.gz
gentoo-b48b82c80ccca5df204102a8dab0abf0283cd11d.tar.bz2
gentoo-b48b82c80ccca5df204102a8dab0abf0283cd11d.zip
net-im/toxic: version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-im/toxic/toxic-0.7.2.ebuild')
-rw-r--r--net-im/toxic/toxic-0.7.2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-im/toxic/toxic-0.7.2.ebuild b/net-im/toxic/toxic-0.7.2.ebuild
new file mode 100644
index 000000000000..3f2723fe2829
--- /dev/null
+++ b/net-im/toxic/toxic-0.7.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="A curses-based client for Tox."
+HOMEPAGE="https://github.com/JFreegman/toxic"
+SRC_URI="https://github.com/JFreegman/toxic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+X +av notifications"
+
+RDEPEND="
+ net-libs/tox:0/0.0[av?]
+ dev-libs/libconfig
+ media-gfx/qrencode
+ net-misc/curl
+ sys-libs/ncurses:0=
+ av? ( media-libs/openal media-libs/freealut )
+ notifications? ( x11-libs/libnotify )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ if ! use av; then
+ export DISABLE_AV=1
+ export DISABLE_SOUND_NOTIFY=1
+ fi
+ if ! use X; then
+ export DISABLE_X11=1
+ fi
+ if ! use notifications; then
+ export DISABLE_DESKTOP_NOTIFY=1
+ fi
+ sed -i \
+ -e "s,/usr/local,${EPREFIX}/usr,g" \
+ cfg/global_vars.mk || die "PREFIX sed failed"
+}
+
+src_install() {
+ default
+ if ! use av; then
+ rm -r "${ED%/}"/usr/share/${PN}/sounds || die "Could not remove sound dir"
+ fi
+}