summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-25 11:17:08 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-25 11:17:08 +0100
commit66ebb183ab232a2ed71def6447aeafa6aaa97551 (patch)
treecffc39f33f5d4a5de518fc96cf349713ed04da8c /net-im/ysm
parentsys-power/cpudyn: Install html files into html/ dir (diff)
downloadgentoo-66ebb183ab232a2ed71def6447aeafa6aaa97551.tar.gz
gentoo-66ebb183ab232a2ed71def6447aeafa6aaa97551.tar.bz2
gentoo-66ebb183ab232a2ed71def6447aeafa6aaa97551.zip
net-im/ysm: add -std=gnu89 to CFLAGS to restore pre-GCC5 semantics
Gentoo-Bug: 570408 * EAPI=6 Package-Manager: portage-2.2.27
Diffstat (limited to 'net-im/ysm')
-rw-r--r--net-im/ysm/ysm-2.9.9.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-im/ysm/ysm-2.9.9.1-r1.ebuild b/net-im/ysm/ysm-2.9.9.1-r1.ebuild
new file mode 100644
index 000000000000..fcd49a68e668
--- /dev/null
+++ b/net-im/ysm/ysm-2.9.9.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit flag-o-matic versionator
+
+MY_PV="$(replace_all_version_separators _)"
+
+DESCRIPTION="A console ICQ client supporting versions 7/8"
+HOMEPAGE="http://ysmv7.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ysmv7/${PN}v7_${MY_PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+S=${WORKDIR}/${PN}v7_${MY_PV}
+
+src_prepare() {
+ # fix bug 570408 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ default
+}