summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2020-05-01 11:46:19 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-05-05 11:46:35 +0300
commit05ff2b3241b7facf365ecf15b9d0db1ed7d020c2 (patch)
tree6c7ad9d418fb04a56cfd6c2f73cd486e83324296 /net-im
parentnet-im/bitlbee: fix libcheck and libevent bugs (diff)
downloadgentoo-05ff2b3241b7facf365ecf15b9d0db1ed7d020c2.tar.gz
gentoo-05ff2b3241b7facf365ecf15b9d0db1ed7d020c2.tar.bz2
gentoo-05ff2b3241b7facf365ecf15b9d0db1ed7d020c2.zip
net-im/bitlbee: fix dependencies in live ebuild
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/bitlbee/bitlbee-9999.ebuild24
1 files changed, 15 insertions, 9 deletions
diff --git a/net-im/bitlbee/bitlbee-9999.ebuild b/net-im/bitlbee/bitlbee-9999.ebuild
index 6643e1c5920c..37efbe6e16b4 100644
--- a/net-im/bitlbee/bitlbee-9999.ebuild
+++ b/net-im/bitlbee/bitlbee-9999.ebuild
@@ -3,7 +3,9 @@
EAPI=7
-inherit systemd toolchain-funcs
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit python-any-r1 systemd toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
@@ -32,7 +34,7 @@ REQUIRED_USE="
COMMON_DEPEND="
acct-group/bitlbee
acct-user/bitlbee
- >=dev-libs/glib-2.16
+ dev-libs/glib:2
purple? ( net-im/pidgin )
libevent? ( dev-libs/libevent:= )
otr? ( >=net-libs/libotr-4 )
@@ -46,17 +48,21 @@ COMMON_DEPEND="
)
"
DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
selinux? ( sec-policy/selinux-bitlbee )
- test? ( dev-libs/check )"
+ test? ( dev-libs/check )
+"
RDEPEND="${COMMON_DEPEND}
- xinetd? ( sys-apps/xinetd )"
+ xinetd? ( sys-apps/xinetd )
+"
-src_prepare() {
- [[ ${PV} != "9999" ]] && eapply "${FILESDIR}"/${PN}-3.5-systemd-user.patch
- eapply_user
-}
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-systemd-user.patch
+)
src_configure() {
local myconf