summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2019-12-18 19:15:50 +0100
committerConrad Kostecki <conikost@gentoo.org>2019-12-18 19:18:09 +0100
commit3d911ea31b317dfd9a6d9c475a173b93c9bcf835 (patch)
tree563e0d6543dcbcfd877d5ad04b787f0b153cfdd3 /net-im
parentdev-python/pyspectrum2: New package (diff)
downloadgentoo-3d911ea31b317dfd9a6d9c475a173b93c9bcf835.tar.gz
gentoo-3d911ea31b317dfd9a6d9c475a173b93c9bcf835.tar.bz2
gentoo-3d911ea31b317dfd9a6d9c475a173b93c9bcf835.zip
net-im/transwhat: bump to version 0.2.2_p20190426
This is the python3 branch, which also dropps python2 support. Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/transwhat/Manifest1
-rw-r--r--net-im/transwhat/transwhat-0.2.2_p20190426.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-im/transwhat/Manifest b/net-im/transwhat/Manifest
index b70861dc49eb..78585f8ec94a 100644
--- a/net-im/transwhat/Manifest
+++ b/net-im/transwhat/Manifest
@@ -1 +1,2 @@
DIST transwhat-0.2.2.tar.gz 49494 BLAKE2B 2d34a697df74d010aa030cd0162d6b1523d3e6eb1935251efb3c76a6259c8111f8644f244141c9724018f6617fef67bbd503be22d29a42bee3ffd619932cc3fb SHA512 4a292ba7dd064214e1f7e90f3a0da4f9fbd42e1227fe648ab2269b35c345eb7feda4d47d90b3ab95a31c356e6c0ad19aa6ffbea6641947810835ab06fbda4b75
+DIST transwhat-0.2.2_p20190426.tar.gz 38373 BLAKE2B 3addf2ae66d042eaf4a5f6b54015b9592fea68b69f4c542c5ec0d97040c0eb473d15b893af35f6d6cf83671417ed718c9c91b6268242e667fa34397fc230d2d5 SHA512 7079d1015bf5dfcd97e729219306320055ef86ac3203bb727bebb1e96abb60a26787882a12f9a8f4cce2ef45652bebfbd824a98d37d97ed72ebe0269004c1a71
diff --git a/net-im/transwhat/transwhat-0.2.2_p20190426.ebuild b/net-im/transwhat/transwhat-0.2.2_p20190426.ebuild
new file mode 100644
index 000000000000..2de533f52d56
--- /dev/null
+++ b/net-im/transwhat/transwhat-0.2.2_p20190426.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+EGIT_COMMIT="d022243f6c7b23674d3c87a09819f00b10df1165"
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WhatsApp XMPP Gateway based on Spectrum 2 and Yowsup 3"
+HOMEPAGE="https://github.com/stv0g/transwhat"
+SRC_URI="https://github.com/stv0g/transwhat/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+ dev-python/pyspectrum2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ net-im/yowsup[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+DOCS=( "INSTALL.rst" "README.rst" "USAGE.rst" )
+
+src_prepare() {
+ default
+
+ # Spectrum2 must be lower case
+ sed -e 's/Spectrum2/spectrum2/g' -i transWhat/{buddy,group,registersession,session,transwhat,whatsappbackend}.py || die
+}