summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorrobert <gentoo.bugzilla.2012@r123.de>2017-11-22 22:08:05 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-11-23 00:14:03 +0100
commit82d47b751ada5977475567b79d72fa7053732ccc (patch)
treec24dad21d914759304c9b52213a2fb3ad9f9a38a /net-im
parentmedia-video/syncplay: version bump to 1.5.0. (diff)
downloadgentoo-82d47b751ada5977475567b79d72fa7053732ccc.tar.gz
gentoo-82d47b751ada5977475567b79d72fa7053732ccc.tar.bz2
gentoo-82d47b751ada5977475567b79d72fa7053732ccc.zip
net-im/signal-desktop-bin: version bump to 1.0.39.
Closes: https://github.com/gentoo/gentoo/pull/6263
Diffstat (limited to 'net-im')
-rw-r--r--net-im/signal-desktop-bin/Manifest1
-rw-r--r--net-im/signal-desktop-bin/signal-desktop-bin-1.0.39.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-im/signal-desktop-bin/Manifest b/net-im/signal-desktop-bin/Manifest
index ce2f92fc9ca5..e025edfbd181 100644
--- a/net-im/signal-desktop-bin/Manifest
+++ b/net-im/signal-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST signal-desktop_1.0.38_amd64.deb 94694718 SHA256 ea2e215876357e027fbbcb82a57512185cf6fc7f8781819d1e8a8680078389c0 SHA512 a9b01dd4b991e2208613e5b0a70d615a06e9aa95202a15958cb6765612218022b807a8907e49bef6c2c9b7b865250f2682cbc675520364f251a9ed32cd937fb5 WHIRLPOOL 00bb2db589af68d3e706b01ebe5577bb77e20bd425731f6e8a532bc5acb0f7187cebd81bdeb278472685fba4e18c63b011f9f50f353fd518ebde5f81bac5f47d
+DIST signal-desktop_1.0.39_amd64.deb 94702074 BLAKE2B b9f727a70e6e27dafd193699769870e4abf30916f0826a10a2337a3dac1dcbf75a00c0396b144864c534905ab2a85ee04ae039e150823830860a8251508155c8 SHA512 24e7a40c11117f4fe67c84ebe2f361f7513831cdffdb84c508318db823e8a41a9a51a4449a60ecc276a8f31581c036166c76df2e4b395fe65c09607d82bb766a
diff --git a/net-im/signal-desktop-bin/signal-desktop-bin-1.0.39.ebuild b/net-im/signal-desktop-bin/signal-desktop-bin-1.0.39.ebuild
new file mode 100644
index 000000000000..8a6f4926cd85
--- /dev/null
+++ b/net-im/signal-desktop-bin/signal-desktop-bin-1.0.39.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/-bin/}"
+
+inherit gnome2-utils unpacker xdg-utils
+
+DESCRIPTION="Signal Desktop"
+HOMEPAGE="https://signal.org/ https://github.com/WhisperSystems/Signal-Desktop"
+SRC_URI="https://updates.signal.org/desktop/apt/pool/main/s/${MY_PN}/${MY_PN}_${PV}_amd64.deb"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ gnome-base/gconf:2
+ dev-libs/libappindicator:3
+ dev-libs/nss
+ x11-libs/libXtst
+ "
+
+QA_PREBUILT="opt/Signal/signal-desktop
+ opt/Signal/libnode.so
+ opt/Signal/libffmpeg.so"
+
+S="${WORKDIR}"
+
+src_install() {
+ doins -r .
+ fperms +x /opt/Signal/signal-desktop
+
+ dosym ../../opt/Signal/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}