summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-03-02 13:52:34 +0100
committerPacho Ramos <pacho@gentoo.org>2023-03-02 13:52:34 +0100
commite49de584ce1bc139ef5fe7c28b1fa65a06ea3c9e (patch)
tree3bca28f99647262a90d53bc3c66cab9ad55bdf59 /net-im
parentsys-libs/kpmcore: drop 22.12.2 (diff)
downloadgentoo-e49de584ce1bc139ef5fe7c28b1fa65a06ea3c9e.tar.gz
gentoo-e49de584ce1bc139ef5fe7c28b1fa65a06ea3c9e.tar.bz2
gentoo-e49de584ce1bc139ef5fe7c28b1fa65a06ea3c9e.zip
net-im/rocketchat-desktop-bin: add 3.8.16
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/rocketchat-desktop-bin/Manifest1
-rw-r--r--net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.16.ebuild105
2 files changed, 106 insertions, 0 deletions
diff --git a/net-im/rocketchat-desktop-bin/Manifest b/net-im/rocketchat-desktop-bin/Manifest
index 3a4dc95c92ef..f4ea3856cb5f 100644
--- a/net-im/rocketchat-desktop-bin/Manifest
+++ b/net-im/rocketchat-desktop-bin/Manifest
@@ -1 +1,2 @@
DIST rocketchat-3.8.14-linux-x86_64.rpm 62927388 BLAKE2B a42322efdbe4022a95c62143b0308d8fcf8e9b8fdf60b730badc04eb0bacc2cd0ab620b99f11b197f24f40b48f5adf5133224e0f30614562cafb03aecf185e94 SHA512 844580d3fd5a64bd81b6becee6c8365b866f698b8c2eea3034dcf1db923ae20132749f3e5e84555977568b24477f0109332ac3311d047c22f49aacb8d41158cb
+DIST rocketchat-3.8.16-linux-x86_64.rpm 68712989 BLAKE2B b572047c535b6bcbca9e2a7b37060674aca9a4b356955e8ddf2b3e396b9f60e169d65fe5ffae292e43962b2045eb27c440f497fe950c6d66764b903e7e1700e1 SHA512 3a891396c3f92b5a47f2436047a6724089072bc3f4bd8a56830dfcb3347550dd71e7a2c3ce7c56b5c2c3de99384cdd470ea1005c705649a40a642404dc9e689f
diff --git a/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.16.ebuild b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.16.ebuild
new file mode 100644
index 000000000000..661f85c108d0
--- /dev/null
+++ b/net-im/rocketchat-desktop-bin/rocketchat-desktop-bin-3.8.16.ebuild
@@ -0,0 +1,105 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CHROMIUM_LANGS="
+ af am ar bg bn ca cs da de el en-GB en-US es es-419 et fa fi fil fr gu he
+ hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr
+ sv sw ta te th tr uk ur vi zh-CN zh-TW
+"
+
+inherit chromium-2 desktop rpm xdg
+
+DESCRIPTION="The Ultimate Open Source Web Chat Platform"
+HOMEPAGE="https://rocket.chat"
+SRC_URI="https://github.com/RocketChat/Rocket.Chat.Electron/releases/download/${PV}/rocketchat-${PV}-linux-x86_64.rpm"
+S="${WORKDIR}"
+
+KEYWORDS="-* ~amd64"
+# Electron bundles a bunch of things
+LICENSE="
+ MIT BSD BSD-2 BSD-4 AFL-2.1 Apache-2.0 Ms-PL GPL-2 LGPL-2.1 APSL-2
+ unRAR OFL CC-BY-SA-3.0 MPL-2.0 android public-domain all-rights-reserved
+"
+SLOT="0"
+RESTRICT="bindist mirror"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0:2
+ dev-libs/expat
+ dev-libs/libayatana-appindicator
+ dev-libs/nspr
+ dev-libs/nss
+ media-fonts/noto-emoji
+ media-libs/alsa-lib
+ net-print/cups
+ sys-libs/glibc
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+ x11-libs/libxcb
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libxkbcommon
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXScrnSaver
+ x11-libs/pango
+"
+
+QA_PREBUILT="opt/Rocket.Chat/*"
+
+pkg_pretend() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_prepare() {
+ default
+ # cleanup languages
+ pushd "opt/Rocket.Chat/locales" || die
+ chromium_remove_language_paks
+ popd || die
+}
+
+src_configure() {
+ chromium_suid_sandbox_check_kernel_config
+ default
+}
+
+src_install() {
+ for size in {16,32,48,64,128,256,512,1024}; do
+ doicon -s ${size} "usr/share/icons/hicolor/${size}x${size}/apps/rocketchat-desktop.png"
+ done
+
+ domenu usr/share/applications/rocketchat-desktop.desktop
+
+ local DESTDIR="/opt/Rocket.Chat"
+
+ # https://github.com/RocketChat/Rocket.Chat.Electron/issues/2536
+ dosym ../../usr/lib64/libayatana-appindicator3.so "${DESTDIR}"/libappindicator3.so || die
+
+ pushd "opt/Rocket.Chat" || die
+
+ exeinto "${DESTDIR}"
+ doexe chrome-sandbox rocketchat-desktop *.so*
+
+ insinto "${DESTDIR}"
+ doins *.pak *.bin *.json *.dat
+ insopts -m0755
+ doins -r locales resources
+
+ # Chrome-sandbox requires the setuid bit to be specifically set.
+ # see https://github.com/electron/electron/issues/17972
+ fperms 4755 "${DESTDIR}"/chrome-sandbox
+
+ dosym "${DESTDIR}"/rocketchat-desktop /opt/bin/rocketchat-desktop
+ popd || die
+}