summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-03-04 20:01:01 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-03-04 20:02:59 +0000
commite651546dc4872e416734014463215f663cb9308b (patch)
treeb07abb1fccf248b857d184b5d818acf79fd57b34 /net-im
parentnet-misc/openssh: Re-order maintainers (diff)
downloadgentoo-e651546dc4872e416734014463215f663cb9308b.tar.gz
gentoo-e651546dc4872e416734014463215f663cb9308b.tar.bz2
gentoo-e651546dc4872e416734014463215f663cb9308b.zip
net-im/skypetab-ng: pushed new snapshot, 0.5.2_p20150201
Reported-by: Gleb Bug: https://bugs.gentoo.org/576310 Package-Manager: portage-2.2.27
Diffstat (limited to 'net-im')
-rw-r--r--net-im/skypetab-ng/Manifest1
-rw-r--r--net-im/skypetab-ng/files/skypetab-ng-0.5.2_p20150201-isdigit.patch14
-rw-r--r--net-im/skypetab-ng/skypetab-ng-0.5.2_p20150201.ebuild42
-rw-r--r--net-im/skypetab-ng/skypetab-ng-9999.ebuild6
4 files changed, 62 insertions, 1 deletions
diff --git a/net-im/skypetab-ng/Manifest b/net-im/skypetab-ng/Manifest
index 3be0c28de8af..599e679d891d 100644
--- a/net-im/skypetab-ng/Manifest
+++ b/net-im/skypetab-ng/Manifest
@@ -1 +1,2 @@
DIST skypetab-ng-0.5.2.tar.gz 54244 SHA256 cb47961ddb9d5754141c10c862d991704ae065abf2cba1e4763a78a5dcbf0805 SHA512 28a19ea983a81c069bb6ad24c337561293f7ec53ca9a315fb872c9341dccecf4eb30e1652b1f012f7be34060fb955a8c085327ae03017264ccc4510976d3f6ea WHIRLPOOL 48b1a86a588dd60c3ee7b9185625027bbaef69b0a6dce237c1e38d3c7dc5b762675d7d21efb88bef7e3840ac1464cdfa3ca4a531756ab3f3f155c2a681aec0e7
+DIST skypetab-ng-0.5.2_p20150201.tar.bz2 53527 SHA256 c2ec5b1b206b9dd6c285daea58fc68966237a1a29fdc67c3feec2030a78d8487 SHA512 cb423d83a1ea6979bf8732b2f546860778f0a5b4dddf3e7704c5fc71d15c25b191dcf510ede2315350aa26cf8c0580cd7fae5cd79ff035e5053857849bd0427c WHIRLPOOL c5bcaf70547305eb6c5f3fb74d516b3d7083eb3ccc569c8d7c08ee33b41c5196e2688d4ec9a5cab7bc8dad3491b3b17ac7d5cd7dbda37757619ae98b532eeb32
diff --git a/net-im/skypetab-ng/files/skypetab-ng-0.5.2_p20150201-isdigit.patch b/net-im/skypetab-ng/files/skypetab-ng-0.5.2_p20150201-isdigit.patch
new file mode 100644
index 000000000000..9b199e5361c8
--- /dev/null
+++ b/net-im/skypetab-ng/files/skypetab-ng-0.5.2_p20150201-isdigit.patch
@@ -0,0 +1,14 @@
+Missing header noticed by gcc:
+ * skype-poll-fix.c:38:9: warning: implicit declaration of function ‘isdigit’ [-Wimplicit-function-declaration]
+diff --git a/skype-poll-fix.c b/skype-poll-fix.c
+index ccc88a1..fd21ba8 100644
+--- a/skype-poll-fix.c
++++ b/skype-poll-fix.c
+@@ -2,2 +2,3 @@
+ #define _GNU_SOURCE
++#include <ctype.h>
+ #include <stdio.h>
+@@ -13,3 +14,2 @@
+ #include <sys/time.h>
+-#include <ctype.h>
+ #endif
diff --git a/net-im/skypetab-ng/skypetab-ng-0.5.2_p20150201.ebuild b/net-im/skypetab-ng/skypetab-ng-0.5.2_p20150201.ebuild
new file mode 100644
index 000000000000..86b11c4b2c0c
--- /dev/null
+++ b/net-im/skypetab-ng/skypetab-ng-0.5.2_p20150201.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://github.com/kekekeks/skypetab-ng.git"
+ UNPACKER_ECLASS="git-2"
+ LIVE_EBUILD=yes
+else
+ UNPACKER_ECLASS="vcs-snapshot"
+fi
+
+inherit eutils qt4-r2 multilib ${UNPACKER_ECLASS}
+
+if [[ -z ${LIVE_EBUILD} ]]; then
+ KEYWORDS="-* ~x86 ~amd64"
+ SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.bz2"
+fi
+
+DESCRIPTION="An LD_PRELOAD wrapper that adds tabs to Skype for Linux"
+HOMEPAGE="https://github.com/kekekeks/skypetab-ng"
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4[abi_x86_32(-)]
+ dev-qt/qtgui:4[abi_x86_32(-)]
+"
+RDEPEND="${DEPEND}
+ || ( >=net-im/skype-4.1 <net-im/skype-4.1[-qt-static] )
+"
+
+pkg_setup() {
+ use amd64 && multilib_toolchain_setup x86
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-isdigit.patch
+}
diff --git a/net-im/skypetab-ng/skypetab-ng-9999.ebuild b/net-im/skypetab-ng/skypetab-ng-9999.ebuild
index 5e2a1f9155fa..20b0be834554 100644
--- a/net-im/skypetab-ng/skypetab-ng-9999.ebuild
+++ b/net-im/skypetab-ng/skypetab-ng-9999.ebuild
@@ -12,7 +12,7 @@ else
UNPACKER_ECLASS="vcs-snapshot"
fi
-inherit qt4-r2 multilib ${UNPACKER_ECLASS}
+inherit eutils qt4-r2 multilib ${UNPACKER_ECLASS}
if [[ -z ${LIVE_EBUILD} ]]; then
KEYWORDS="-* ~x86 ~amd64"
@@ -36,3 +36,7 @@ RDEPEND="${DEPEND}
pkg_setup() {
use amd64 && multilib_toolchain_setup x86
}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-isdigit.patch
+}