summaryrefslogtreecommitdiff
path: root/net-im
diff options
context:
space:
mode:
authorVladimir Pavljuchenko (SpiderX) <spiderx@spiderx.dp.ua>2016-09-16 16:02:04 +0300
committerPatrice Clement <monsieurp@gentoo.org>2016-09-27 22:23:30 +0200
commite780cced313278807c053656e1baa3f721c5e006 (patch)
tree5a9f01ff4ea07b74ff088ef7121d18dea8c41054 /net-im
parentapp-admin/yadm: version bump to 1.05. (diff)
downloadgentoo-e780cced313278807c053656e1baa3f721c5e006.tar.gz
gentoo-e780cced313278807c053656e1baa3f721c5e006.tar.bz2
gentoo-e780cced313278807c053656e1baa3f721c5e006.zip
net-im/slack-bin: new package.
Slack is a cloud-based team collaboration tool. It offers persistent chat rooms (channels) organized by topic, as well as private groups and direct messaging. All content (files, conversations, people) inside Slack is searchable. Slack integrates with a large number of third-party services and supports community-built integrations. Base for ebuild from https://github.com/SpiderX/portage-overlay/tree/master/net-im/slack-bin. Gentoo-Bug: https://bugs.gentoo.org/575786 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2342 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/slack-bin/Manifest2
-rw-r--r--net-im/slack-bin/metadata.xml22
-rw-r--r--net-im/slack-bin/slack-bin-2.1.2.ebuild78
3 files changed, 102 insertions, 0 deletions
diff --git a/net-im/slack-bin/Manifest b/net-im/slack-bin/Manifest
new file mode 100644
index 000000000000..b774bc33ab83
--- /dev/null
+++ b/net-im/slack-bin/Manifest
@@ -0,0 +1,2 @@
+DIST slack-desktop-2.1.2-amd64.deb 46460486 SHA256 46576dbe929d4d60d0311056c0268d22dfaa58edc6774ce8a7e61873414bbf2e SHA512 b23ccee498c2c6d043bdb4632b1b2755b3f0a96a1d78338020fb4221c49b7feeb437cc358abcf285e0f0a0f7b57f4db6792b2baa8b339596a287f1272ed12284 WHIRLPOOL 7b9dbf46c988dce1837318c4568ef7357481058593d80d0d00f0b8924a1ead28d8aaf3548d7e1f095d62042a05d721ba047658fcbb1758aad1ea006e69c74dcf
+DIST slack-desktop-2.1.2-i386.deb 42997902 SHA256 cc9660d95f5ce765c18b35191e2475d6bd272affc6d47f176759cc202910ddb4 SHA512 6b68123d3c85687043e886974449fe424af267c326ffc869d03d911ae5d0f30f5081b611e136bc4f832da8d555b2851a4c093df9c8be2de98235ebcd03528d8c WHIRLPOOL 80514dc501a94652bb54dad205224ee73cc4abd12f356aaf2b454aff67f99b4a16ec88bde0f9c541dbbddfcb8739df040656ca6c91b42b2947d6862743be41a8
diff --git a/net-im/slack-bin/metadata.xml b/net-im/slack-bin/metadata.xml
new file mode 100644
index 000000000000..87e0265eca89
--- /dev/null
+++ b/net-im/slack-bin/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>spiderx@spiderx.dp.ua</email>
+ <name>Vladimir Pavljuchenkov</name>
+ <description>Proxy maintainer</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+Slack offers persistent chat rooms organized by topic,
+as well as private groups and direct messaging.
+All content inside Slack is searchable, including files, conversations,
+and people.
+ </longdescription>
+ <upstream>
+ <doc>https://get.slack.help/hc/en-us</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/slack-bin/slack-bin-2.1.2.ebuild b/net-im/slack-bin/slack-bin-2.1.2.ebuild
new file mode 100644
index 000000000000..3f3e8eb110bf
--- /dev/null
+++ b/net-im/slack-bin/slack-bin-2.1.2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit unpacker gnome2-utils
+
+QA_PREBUILT="
+ opt/slack/slack
+ opt/slack/resources/app.asar.unpacked/node_modules/*
+ opt/slack/libnode.so
+ opt/slack/libgcrypt.so.11
+ opt/slack/libffmpeg.so
+ opt/slack/libCallsCore.so
+"
+
+DESCRIPTION="Team collaboration tool"
+HOMEPAGE="http://www.slack.com/"
+
+MY_PN="${PN/-bin/}"
+BASE_URI="https://downloads.slack-edge.com/linux_releases/${MY_PN}-desktop-${PV}-_arch_.deb"
+
+SRC_URI="
+ x86? ( ${BASE_URI/_arch_/i386} )
+ amd64? ( ${BASE_URI/_arch_/amd64} )
+"
+
+LICENSE="MIT Apache-2.0 BSD ISC LGPL-2 AFL-2.1 public-domain WTFPL-2 Artistic-2 no-source-code"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="mirror"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libnotify
+ x11-libs/libXtst
+ x11-libs/pango
+ x11-libs/cairo[xcb]
+ media-libs/alsa-lib
+ media-libs/harfbuzz[graphite]
+ media-libs/libcanberra[gtk]
+ dev-libs/nss
+ dev-libs/glib:2
+ dev-libs/atk
+ gnome-base/libgnome-keyring
+ gnome-base/gconf:2
+ sys-apps/dbus
+ net-print/cups[ssl]
+ net-misc/curl
+ virtual/udev
+ virtual/libc
+ virtual/libffi
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+src_install() {
+ insinto /usr/share/pixmaps
+ doins usr/share/pixmaps/${MY_PN}.png
+
+ newicon -s 512 usr/share/pixmaps/${MY_PN}.png ${MY_PN}.png
+ domenu usr/share/applications/${MY_PN}.desktop
+
+ insinto /opt/${MY_PN}
+ doins -r usr/lib/${MY_PN}/*
+ fperms +x /opt/${MY_PN}/${MY_PN}
+ dosym /opt/${MY_PN}/${MY_PN} /usr/bin/${MY_PN}
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}