summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/atheme-services
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/atheme-services')
-rw-r--r--net-irc/atheme-services/Manifest2
-rw-r--r--net-irc/atheme-services/atheme-services-6.0.11-r1.ebuild105
-rw-r--r--net-irc/atheme-services/atheme-services-7.0.6-r1.ebuild109
-rw-r--r--net-irc/atheme-services/atheme-services-9999.ebuild120
-rw-r--r--net-irc/atheme-services/files/atheme-services-6.0.8-configure-disable.patch116
-rw-r--r--net-irc/atheme-services/files/atheme-services.initd37
-rw-r--r--net-irc/atheme-services/metadata.xml20
7 files changed, 509 insertions, 0 deletions
diff --git a/net-irc/atheme-services/Manifest b/net-irc/atheme-services/Manifest
new file mode 100644
index 000000000000..a4924c9c3099
--- /dev/null
+++ b/net-irc/atheme-services/Manifest
@@ -0,0 +1,2 @@
+DIST atheme-services-6.0.11.tar.bz2 859123 SHA256 762bc717d4710d135f8654025c34c4fc431a6a8cf7345e994fbe800fa78a9f74 SHA512 81b85744aba5ab5708a21c006d09f870be34a9ff15a791c0ed234de984d44e2b1a6021af1f1e21ad94010d7a42246f6ac3fa9daf3d7c379a1c19b7661a947c97 WHIRLPOOL 3664ef405ace32973d823dd37003c7f5c107a429228c46a72420ab829bde6af0a2bdfb7d2d69b4a6d1fbc537d7a1a1a20ce69f57568ad47016675b85158154f4
+DIST atheme-services-7.0.6.tar.bz2 1086070 SHA256 314fd708dc63145e9db10c5a2ed5afebf16b398d617a633c5e80d003039afdeb SHA512 448dd532c1ece9f3d5f36891464a4fdf6b16e021fb24c9d3850c0bbe473cbd472bb7d5442a331bcf96fbdf8d09a261a6baeaeb96f41e1766d556b01bc8d0f8e3 WHIRLPOOL c8d6d6d4ca5a816f5e9b74ff0272cf797396722f0e0cfece29cc738e9396f9cf3ce070232aee9bcf99849be96cbdfa92c73a468d611caf1935cc7bb6443ede6e
diff --git a/net-irc/atheme-services/atheme-services-6.0.11-r1.ebuild b/net-irc/atheme-services/atheme-services-6.0.11-r1.ebuild
new file mode 100644
index 000000000000..435bee27967c
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-6.0.11-r1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic perl-module prefix user
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="http://atheme.net/"
+SRC_URI="http://atheme.net/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd ~amd64-linux"
+IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
+
+RDEPEND="dev-libs/libmowgli:0
+ cracklib? ( sys-libs/cracklib )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # the dependency calculation puts all of the .c files together and
+ # overwhelms cc1 with this flag :-(
+ filter-flags -combine
+
+ if use profile; then
+ # bug #371119
+ ewarn "USE=\"profile\" is incompatible with the hardened profile's -pie flag."
+ ewarn "Disabling PIE. Please ignore any warning messages about -nopie being invalid."
+ append-flags -nopie
+ fi
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/atheme ${PN}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-6.0.8-configure-disable.patch
+ eautoconf
+
+ # fix docdir
+ sed -i -e 's/\(^DOCDIR.*=.\)@DOCDIR@/\1@docdir@/' extra.mk.in || die
+
+ # basic logging config directive fix
+ sed -i -e '/^logfile/s;var/\(.*\.log\);'"${EPREFIX}"'/var/log/atheme/\1;g' dist/* || die
+
+ # QA against bundled libs
+ rm -rf libmowgli || die
+
+ # Get useful information into build.log
+ sed -i -e '/^\.SILENT:$/d' buildsys.mk.in || die
+}
+
+src_configure() {
+ econf \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with cracklib) \
+ $(use_with ldap) \
+ $(use_with nls) \
+ $(use_enable profile) \
+ $(use_with pcre) \
+ $(use_enable ssl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ newins ${conf} $(basename ${conf} .example)
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log,run}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log,run}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ # contributed scripts and such:
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{c,pl,php,py,rb}
+
+ if use perl; then
+ perl_set_version
+ insinto "${VENDOR_LIB#${EPREFIX}}"
+ doins -r contrib/Atheme{,.pm}
+ fi
+}
diff --git a/net-irc/atheme-services/atheme-services-7.0.6-r1.ebuild b/net-irc/atheme-services/atheme-services-7.0.6-r1.ebuild
new file mode 100644
index 000000000000..8cef6b425420
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-7.0.6-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic perl-module user
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="http://atheme.net/"
+SRC_URI="http://atheme.net/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux"
+IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
+
+RDEPEND=">=dev-libs/libmowgli-2.0.0:2
+ cracklib? ( sys-libs/cracklib )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ perl? ( dev-lang/perl )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # the dependency calculation puts all of the .c files together and
+ # overwhelms cc1 with this flag :-(
+ filter-flags -combine
+
+ if use profile; then
+ # bug #371119
+ ewarn "USE=\"profile\" is incompatible with the hardened profile's -pie flag."
+ ewarn "Disabling PIE. Please ignore any warning messages about -nopie being invalid."
+ append-flags -nopie
+ fi
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/atheme ${PN}
+}
+
+src_prepare() {
+ # fix docdir
+ sed -i -e 's/\(^DOCDIR.*=.\)@DOCDIR@/\1@docdir@/' extra.mk.in || die
+
+ # basic logging config directive fix
+ sed -i -e '/^logfile/s;var/\(.*\.log\);'"${EPREFIX}"'/var/log/atheme/\1;g' dist/* || die
+
+ # QA against bundled libs
+ rm -rf libmowgli-2 || die
+}
+
+src_configure() {
+ # perl scriping module support is also broken in 7.0.0. Yay for QA failures.
+ econf \
+ atheme_cv_c_gcc_w_error_implicit_function_declaration=no \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --disable-warnings \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with cracklib) \
+ $(use_with ldap) \
+ $(use_with nls) \
+ $(use_enable profile) \
+ $(use_with pcre) \
+ $(use_with perl) \
+ $(use_enable ssl)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ newins ${conf} $(basename ${conf} .example)
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log,run}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log,run}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ mv "${ED}"/usr/bin/{,atheme-}dbverify || die
+
+ # contributed scripts and such:
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{c,pl,php,py,rb}
+
+ if use perl; then
+ perl_set_version
+ insinto "${VENDOR_LIB#${EPREFIX}}"
+ doins -r contrib/Atheme{,.pm}
+ fi
+}
diff --git a/net-irc/atheme-services/atheme-services-9999.ebuild b/net-irc/atheme-services/atheme-services-9999.ebuild
new file mode 100644
index 000000000000..46643ace3492
--- /dev/null
+++ b/net-irc/atheme-services/atheme-services-9999.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-2 user eutils flag-o-matic perl-module
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A portable and secure set of open-source and modular IRC services"
+HOMEPAGE="http://atheme.net/"
+EGIT_REPO_URI="git://github.com/atheme/atheme.git"
+EGIT_HAS_SUBMODULES="true"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="cracklib largenet ldap nls +pcre perl profile ssl"
+
+RDEPEND="=dev-libs/libmowgli-9999:2
+ cracklib? ( sys-libs/cracklib )
+ ldap? ( net-nds/openldap )
+ nls? ( sys-devel/gettext )
+ perl? ( dev-lang/perl )
+ pcre? ( dev-libs/libpcre )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # the dependency calculation puts all of the .c files together and
+ # overwhelms cc1 with this flag :-(
+ filter-flags -combine
+
+ if use profile; then
+ # bug #371119
+ ewarn "USE=\"profile\" is incompatible with the hardened profile's -pie flag."
+ ewarn "Disabling PIE. Please ignore any warning messages about -nopie being invalid."
+ append-flags -nopie
+ fi
+
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/atheme ${PN}
+}
+
+# To stop perl-module overriding this function
+src_unpack() {
+ git-2_src_unpack
+}
+
+src_prepare() {
+ # fix docdir
+ sed -i -e 's/\(^DOCDIR.*=.\)@DOCDIR@/\1@docdir@/' extra.mk.in || die
+
+ # basic logging config directive fix
+ sed -i -e '/^logfile/s;var/\(.*\.log\);'"${EPREFIX}"'/var/log/atheme/\1;g' dist/* || die
+
+ # QA against bundled libs.
+ # But comment it out in the live ebuild
+ # because it only contains a git submodule
+ # and removing it MAY break everything.
+ #rm -rf libmowgli-2 || die
+}
+
+src_configure() {
+ econf \
+ atheme_cv_c_gcc_w_error_implicit_function_declaration=no \
+ --sysconfdir="${EPREFIX}"/etc/${PN} \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-fhs-paths \
+ --disable-warnings \
+ --enable-contrib \
+ $(use_enable largenet large-net) \
+ $(use_with cracklib) \
+ $(use_with ldap) \
+ $(use_with nls) \
+ $(use_enable profile) \
+ $(use_with perl) \
+ $(use_with pcre) \
+ $(use_enable ssl)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/${PN}
+ for conf in dist/*.example; do
+ # The .cron file isn't meant to live in /etc/${PN}, so only
+ # install a .example version.
+ [[ ${conf} == *cron* ]] && continue
+
+ newins ${conf} $(basename ${conf} .example)
+ done
+
+ fowners -R 0:${PN} /etc/${PN}
+ keepdir /var/{lib,log}/atheme
+ fowners ${PN}:${PN} /var/{lib,log,run}/atheme
+ fperms -R go-w,o-rx /etc/${PN}
+ fperms 750 /etc/${PN} /var/{lib,log,run}/atheme
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+
+ mv "${ED}"/usr/bin/{,atheme-}dbverify || die
+
+ # contributed scripts and such:
+ insinto /usr/share/doc/${PF}/contrib
+ doins contrib/*.{c,pl,php,py,rb}
+
+ if use perl; then
+ perl_set_version
+ insinto "${VENDOR_LIB#${EPREFIX}}"
+ doins -r contrib/Atheme{,.pm}
+ fi
+}
diff --git a/net-irc/atheme-services/files/atheme-services-6.0.8-configure-disable.patch b/net-irc/atheme-services/files/atheme-services-6.0.8-configure-disable.patch
new file mode 100644
index 000000000000..ac671956ee48
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services-6.0.8-configure-disable.patch
@@ -0,0 +1,116 @@
+From be144253c54b41d9b2f3929f12025457f66ce288 Mon Sep 17 00:00:00 2001
+From: Nathan Phillip Brink <ohnobinki@ohnopublishing.net>
+Date: Mon, 13 Jun 2011 22:25:47 -0400
+Subject: [PATCH] Fix remaining AC_ARG_ENABLEs so that --disable-<feature> does not produce the same effect as --enable-<feature>.
+
+Fixes --disable-warnings, --disable-propolice, and --disable-profile. (Problems with --disable-profile resulted in https://bugs.gentoo.org/371119).
+---
+ configure | 21 +++++++++++++++++----
+ configure.ac | 18 ++++++++++++------
+ 2 files changed, 29 insertions(+), 10 deletions(-)
+
+diff --git a/configure b/configure
+index a3337e0..9bd0428 100755
+--- a/configure
++++ b/configure
+@@ -8360,7 +8360,11 @@ $as_echo "no" >&6; }
+
+ # Check whether --enable-warnings was given.
+ if test "${enable_warnings+set}" = set; then :
+- enableval=$enable_warnings;
++ enableval=$enable_warnings; enable_warnings=no
++fi
++
++if test "x$enable_warnings" = "xyes"; then :
++
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking GCC flag(s) -Wall" >&5
+ $as_echo_n "checking GCC flag(s) -Wall... " >&6; }
+@@ -9335,10 +9339,15 @@ $as_echo "no" >&6; }
+
+ fi
+
+-
+ # Check whether --enable-propolice was given.
+ if test "${enable_propolice+set}" = set; then :
+ enableval=$enable_propolice;
++else
++ enable_propolice=no
++fi
++
++if test "x$enable_propolice" = "xyes"; then :
++
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking GCC flag(s) -fno-stack-protector-all" >&5
+ $as_echo_n "checking GCC flag(s) -fno-stack-protector-all... " >&6; }
+@@ -9546,10 +9555,15 @@ $as_echo "no" >&6; }
+
+ fi
+
+-
+ # Check whether --enable-profile was given.
+ if test "${enable_profile+set}" = set; then :
+ enableval=$enable_profile;
++else
++ enable_profile=no
++fi
++
++if test "x$enable_profile" = "xyes"; then :
++
+
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking GCC flag(s) -pg" >&5
+ $as_echo_n "checking GCC flag(s) -pg... " >&6; }
+@@ -9606,7 +9620,6 @@ LDFLAGS=${ac_save_LDFLAGS}
+
+ fi
+
+-
+ ac_save_CPPFLAGS="${CFLAGS} ${orig_CFLAGS} ${CWARNS} -DPREFIX=\\\"\${prefix}\\\" -DLOCALEDIR=\\\"\${LOCALEDIR}\\\" -DMODDIR=\\\"\${MODDIR}\\\" -DSHAREDIR=\\\"${SHAREDIR}\\\" -DSYSCONFDIR=\\\"${sysconfdir}\\\" -DLOGDIR=\\\"${LOGDIR}\\\" -DRUNDIR=\\\"${RUNDIR}\\\" -DDATADIR=\\\"${DATADIR}\\\""
+ CPPFLAGS=${ac_save_CPPFLAGS}
+
+diff --git a/configure.ac b/configure.ac
+index a8baa2e..36195ce 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -484,8 +484,10 @@ AC_SUBST(PICFLAGS)
+ ATHEME_C_GCC_TRY_FLAGS([-std=gnu99], atheme_cv_c_gcc_std_gnu99)
+ ATHEME_C_GCC_TRY_FLAGS([-Werror-implicit-function-declaration], atheme_cv_c_gcc_w_error_implicit_function_declaration)
+
+-AC_ARG_ENABLE(warnings,
+-AC_HELP_STRING([--enable-warnings],[ Enable compiler warnings]),
++AC_ARG_ENABLE([warnings],
++ [AS_HELP_STRING([--enable-warnings],[ Enable compiler warnings])],
++ [enable_warnings=no])
++AS_IF([test "x$enable_warnings" = "xyes"],
+ [
+ dnl See what warnings we can get away with
+ ATHEME_C_GCC_TRY_FLAGS([-Wall], atheme_cv_c_gcc_w_all)
+@@ -519,8 +521,10 @@ dnl ATHEME_C_GCC_TRY_FLAGS([-Wwrite-strings], atheme_cv_c_gcc_w_strings)
+ dnl ATHEME_C_GCC_TRY_FLAGS([-Werror], atheme_cv_c_gcc_w_error)
+ ])
+
+-AC_ARG_ENABLE(propolice,
+-AC_HELP_STRING([--disable-propolice],[ Disable propolice protections (for debugging.)]),
++AC_ARG_ENABLE([propolice],
++ [AS_HELP_STRING([--disable-propolice],[ Disable propolice protections (for debugging.)])],
++ [], [enable_propolice=no])
++AS_IF([test "x$enable_propolice" = "xyes"],
+ [
+ ATHEME_C_GCC_TRY_FLAGS([-fno-stack-protector-all], atheme_cv_nspa)
+ ATHEME_C_GCC_TRY_FLAGS([-fno-pie], atheme_cv_npie)
+@@ -528,8 +532,10 @@ ATHEME_C_GCC_TRY_FLAGS([-nonow], atheme_cv_nonow)
+ ATHEME_C_GCC_TRY_FLAGS([-norelro], atheme_cv_no_relro)
+ ])
+
+-AC_ARG_ENABLE(profile,
+-AC_HELP_STRING([--enable-profile],[ Enable profiling extensions]),
++AC_ARG_ENABLE([profile],
++ [AS_HELP_STRING([--enable-profile],[ Enable profiling extensions])],
++ [], [enable_profile=no])
++AS_IF([test "x$enable_profile" = "xyes"],
+ [
+ ATHEME_C_GCC_TRY_FLAGS([-pg], atheme_cv_pg)
+ ac_save_LDFLAGS="${LDFLAGS} -pg"
+--
+1.7.3.4
+
diff --git a/net-irc/atheme-services/files/atheme-services.initd b/net-irc/atheme-services/files/atheme-services.initd
new file mode 100644
index 000000000000..53996f386385
--- /dev/null
+++ b/net-irc/atheme-services/files/atheme-services.initd
@@ -0,0 +1,37 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+extra_started_commands="reload"
+
+depend() {
+ need net
+ use ircd
+ provide irc-services
+}
+
+start() {
+ ATHEME_SERVICES_RUNDIR=/var/run/atheme
+ if ! [ -d "${ATHEME_SERVICES_RUNDIR}" ]; then
+ ebegin "Creating \`${ATHEME_SERVICES_RUNDIR}'"
+ install -o atheme-services -d "${ATHEME_SERVICES_RUNDIR}"
+ eend $?
+ fi
+
+ ebegin "Starting ${SVCNAME}"
+ start-stop-daemon --start --pidfile=/var/run/atheme/atheme.pid --user atheme-services --exec /usr/bin/atheme-services
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP --pidfile /var/run/atheme/atheme.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${SVCNAME}"
+ start-stop-daemon --stop --quiet --pidfile /var/run/atheme/atheme.pid
+ eend $?
+}
diff --git a/net-irc/atheme-services/metadata.xml b/net-irc/atheme-services/metadata.xml
new file mode 100644
index 000000000000..204e95820a10
--- /dev/null
+++ b/net-irc/atheme-services/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="utf-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-irc</herd>
+ <maintainer>
+ <email>binki@gentoo.org</email>
+ <name>Nathan Phillip Brink</name>
+ </maintainer>
+ <maintainer>
+ <email>jdhore@gentoo.org</email>
+ <name>Jeff Horelick</name>
+ <description>Co-maintainer</description>
+ </maintainer>
+ <use>
+ <flag name='cracklib'>Enable nickserv/cracklib module for enforcing strong account passwords</flag>
+ <flag name='largenet'>Enable support/tweaks for large networks</flag>
+ <flag name='ldap'>Enable ldap-backed authentication module</flag>
+ <flag name='perl'>Install a perl module which wraps around the services' XML-RPC interface</flag>
+ </use>
+</pkgmetadata>