summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-12-26 05:22:34 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-12-26 05:22:50 +1100
commit7277d55009938e328281b61b502722ea59d1f342 (patch)
treeef15a1260230568e7260226aa4fc46391385b2a5 /net-irc/bip/files
parentwww-misc/shellinabox: x86 stable wrt bug #567316 (diff)
downloadgentoo-7277d55009938e328281b61b502722ea59d1f342.tar.gz
gentoo-7277d55009938e328281b61b502722ea59d1f342.tar.bz2
gentoo-7277d55009938e328281b61b502722ea59d1f342.zip
net-irc/bip: remove old
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-irc/bip/files')
-rw-r--r--net-irc/bip/files/bip-0.8.8-configure.patch50
-rw-r--r--net-irc/bip/files/bip-CVE-2012-0806.patch121
2 files changed, 0 insertions, 171 deletions
diff --git a/net-irc/bip/files/bip-0.8.8-configure.patch b/net-irc/bip/files/bip-0.8.8-configure.patch
deleted file mode 100644
index 592bdc664561..000000000000
--- a/net-irc/bip/files/bip-0.8.8-configure.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-commit 559fa7ed44238e811ac0c11321ed021c35cba2be
-Author: Pierre-Louis Bonicoli <pierre-louis.bonicoli@gmx.fr>
-Date: Wed Sep 14 06:30:09 2011 +0200
-
- don't override user var. Thanks to Alex Legler
-
- Based on gentoo-x86/net-irc/bip/files/bip-configure.patch
- See http://www.gnu.org/software/autoconf/manual/automake.html#User-Variables
- If user doesn't specify CFLAGS, default value is "-Wall -Wextra -g -O2".
-
-diff --git a/Makefile.am b/Makefile.am
-index c2dae4d..f17c314 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -13,13 +13,8 @@ src_bip_SOURCES = src/conf.y src/lex.l \
- src_bipmkpw_SOURCES = src/bipmkpw.c src/md5.c src/util.c
- AM_YFLAGS= -d
- BUILT_SOURCES = src/conf.c src/conf.h src/lex.c
--if DEBUG
-- AM_CFLAGS+=-Wall -g
-- AM_LDFLAGS+=-g
--else
-- AM_CFLAGS+=-Wall
--endif
-
-+AM_CFLAGS=-Wall -Wextra
-
- dist_man_MANS = bip.1 bip.conf.5 bipmkpw.1
-
-diff --git a/configure.ac b/configure.ac
-index 005e697..5740a39 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -44,16 +44,12 @@ AC_ARG_ENABLE([pie], AS_HELP_STRING([--disable-pie], [Do not build a position in
-
- AM_CONDITIONAL(DEBUG, test x$enable_debug = xyes)
- AS_IF([test "x$enable_debug" = "xyes"], [
-- CFLAGS="-O0 -g -W -Wall"
-- LDFLAGS="-g"
- AC_CHECK_FUNC(backtrace_symbols_fd, [
- AC_DEFINE(HAVE_BACKTRACE, [], [Use glibc backtrace on fatal()])
- LDFLAGS="-rdynamic $LDFLAGS"
- backtrace="(with backtrace)"
- ])
- ], [
-- CFLAGS="-O2 -g -W -Wall"
-- LDFLAGS="-g"
- enable_debug=no
- ])
-
diff --git a/net-irc/bip/files/bip-CVE-2012-0806.patch b/net-irc/bip/files/bip-CVE-2012-0806.patch
deleted file mode 100644
index 6ea26aead2bb..000000000000
--- a/net-irc/bip/files/bip-CVE-2012-0806.patch
+++ /dev/null
@@ -1,121 +0,0 @@
-commit 222a33cb84a2e52ad55a88900b7895bf9dd0262c
-Author: Pierre-Louis Bonicoli <pierre-louis.bonicoli@gmx.fr>
-Date: Sat Jan 7 11:41:02 2012 +0100
-
- Buffer Overflow: check against the implicit size of select() arrays
-
- Reported by Julien Tinnes (Fix #269)
- exit is called when the listening socket can not be created
-
-diff --git a/src/bip.c b/src/bip.c
-index d46ee2b..b4ac706 100644
---- a/src/bip.c
-+++ b/src/bip.c
-@@ -1311,7 +1311,7 @@ int main(int argc, char **argv)
- close(fd);
-
- bip.listener = listen_new(conf_ip, conf_port, conf_css);
-- if (!bip.listener)
-+ if (!bip.listener || bip.listener->connected == CONN_ERROR)
- fatal("Could not create listening socket");
-
- for (;;) {
-diff --git a/src/connection.c b/src/connection.c
-index 07ab431..5c4c24a 100644
---- a/src/connection.c
-+++ b/src/connection.c
-@@ -124,6 +124,18 @@ static void connect_trynext(connection_t *cn)
- continue;
- }
-
-+ if (cn->handle >= FD_SETSIZE) {
-+ mylog(LOG_WARN, "too many fd used, close socket %d",
-+ cn->handle);
-+
-+ if (close(cn->handle) == -1)
-+ mylog(LOG_WARN, "Error on socket close: %s",
-+ strerror(errno));
-+
-+ cn->handle = -1;
-+ break;
-+ }
-+
- socket_set_nonblock(cn->handle);
-
- if (cn->connecting_data->src) {
-@@ -789,13 +801,8 @@ list_t *wait_event(list_t *cn_list, int *msec, int *nc)
- /*
- * This shouldn't happen ! just in case...
- */
-- if (cn->handle < 0) {
-- mylog(LOG_WARN, "wait_event invalid socket %d",
-- cn->handle);
-- if (cn_is_connected(cn))
-- cn->connected = CONN_ERROR;
-- continue;
-- }
-+ if (cn->handle < 0 || cn->handle >= FD_SETSIZE)
-+ fatal("wait_event invalid socket %d", cn->handle);
-
- /* exceptions are OOB and disconnections */
- FD_SET(cn->handle, &fds_except);
-@@ -966,6 +973,18 @@ static void create_listening_socket(char *hostname, char *port,
- continue;
- }
-
-+ if (cn->handle >= FD_SETSIZE) {
-+ mylog(LOG_WARN, "too many fd used, close listening socket %d",
-+ cn->handle);
-+
-+ if (close(cn->handle) == -1)
-+ mylog(LOG_WARN, "Error on socket close: %s",
-+ strerror(errno));
-+
-+ cn->handle = -1;
-+ break;
-+ }
-+
- if (setsockopt(cn->handle, SOL_SOCKET, SO_REUSEADDR,
- (char *)&multi_client,
- sizeof(multi_client)) < 0) {
-@@ -1113,10 +1132,21 @@ connection_t *accept_new(connection_t *cn)
-
- mylog(LOG_DEBUG, "Trying to accept new client on %d", cn->handle);
- err = accept(cn->handle, &sa, &sa_len);
-+
- if (err < 0) {
-- mylog(LOG_ERROR, "accept failed: %s", strerror(errno));
-+ fatal("accept failed: %s", strerror(errno));
-+ }
-+
-+ if (err >= FD_SETSIZE) {
-+ mylog(LOG_WARN, "too many client connected, close %d", err);
-+
-+ if (close(err) == -1)
-+ mylog(LOG_WARN, "Error on socket close: %s",
-+ strerror(errno));
-+
- return NULL;
- }
-+
- socket_set_nonblock(err);
-
- conn = connection_init(cn->anti_flood, cn->ssl, cn->timeout, 0);
-diff --git a/src/irc.c b/src/irc.c
-index ebc1b34..147a315 100644
---- a/src/irc.c
-+++ b/src/irc.c
-@@ -2439,9 +2439,10 @@ void bip_on_event(bip_t *bip, connection_t *conn)
-
- if (conn == bip->listener) {
- struct link_client *n = irc_accept_new(conn);
-- assert(n);
-- list_add_last(&bip->conn_list, CONN(n));
-- list_add_last(&bip->connecting_client_list, n);
-+ if (n) {
-+ list_add_last(&bip->conn_list, CONN(n));
-+ list_add_last(&bip->connecting_client_list, n);
-+ }
- return;
- }
-