summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/bobotpp/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/bobotpp/files')
-rw-r--r--net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch15
-rw-r--r--net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch13
2 files changed, 28 insertions, 0 deletions
diff --git a/net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch b/net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch
new file mode 100644
index 000000000000..e960e008f187
--- /dev/null
+++ b/net-irc/bobotpp/files/bobotpp-2.2.2-asneeded.patch
@@ -0,0 +1,15 @@
+--- bobotpp-2.2.2.orig/configure.ac 2006-06-29 02:02:46.000000000 +0200
++++ bobotpp-2.2.2/configure.ac 2009-10-15 19:31:42.058285332 +0200
+@@ -58,9 +58,9 @@
+ AC_CPP_STL_IOSBASE
+
+ dnl Checks for libraries.
+-AC_CHECK_LIB(crypt, crypt, [LDFLAGS="-lcrypt $LDFLAGS]")
+-AC_CHECK_LIB(socket, socket, [LDFLAGS="-lsocket $LDFLAGS]")
+-AC_CHECK_LIB(nsl, connect, [LDFLAGS="-lnsl $LDFLAGS]")
++AC_CHECK_LIB(crypt, crypt)
++AC_CHECK_LIB(socket, socket)
++AC_CHECK_LIB(nsl, connect)
+
+ dnl CC++ is special (no function to check_lib on
+ dnl AC_CHECK_PROG(CCGNU_FOUND, [ccgnu2-config],
diff --git a/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch b/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch
new file mode 100644
index 000000000000..8bbb78be966c
--- /dev/null
+++ b/net-irc/bobotpp/files/bobotpp-2.2.3-stdout.patch
@@ -0,0 +1,13 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Reduce amount of noise printed to stdout.
+
+--- a/source/Utils.C
++++ b/source/Utils.C
+@@ -97,7 +97,6 @@
+ if (host == "") host = "*";
+ }
+
+- std::cout << nick + "!" + user + "@" + host << std::endl;
+
+ return nick + "!" + user + "@" + host;
+ }