summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-06-30 03:09:13 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-06-30 04:01:30 +0200
commit06152d7886e77ff70a6cade640dfcc62937b763a (patch)
treea62a82b9e0787c2e123046e9e24f6a014e7fa5e7 /net-irc/eggdrop
parentapp-editors/qxmledit: version bump 0.9.10 (diff)
downloadgentoo-06152d7886e77ff70a6cade640dfcc62937b763a.tar.gz
gentoo-06152d7886e77ff70a6cade640dfcc62937b763a.tar.bz2
gentoo-06152d7886e77ff70a6cade640dfcc62937b763a.zip
net-irc/eggdrop: bump to 1.8.3, drop custom patches+related USEs
Also: * Make LICENSE GPL-2+. * Add a slot operator to tcl. * Do not try to install all docs to /usr/share/doc. * Show postinst only for new installs. * Introduce an ipv6 USE flag. * install HTML docs only when the doc USE flag is set. Closes: https://bugs.gentoo.org/617748 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'net-irc/eggdrop')
-rw-r--r--net-irc/eggdrop/Manifest1
-rw-r--r--net-irc/eggdrop/eggdrop-1.8.3.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-irc/eggdrop/Manifest b/net-irc/eggdrop/Manifest
index d05018b90fb8..329ddc5a7f2d 100644
--- a/net-irc/eggdrop/Manifest
+++ b/net-irc/eggdrop/Manifest
@@ -1,2 +1,3 @@
DIST eggdrop-1.6.21-patches-1.0.tar.bz2 322608 BLAKE2B 5589b4c826b6144b2c5b68df485dfc361edf699d4cd6cf2760f410716664d34cc3dd7f22f2b5af67264ec5f4071e9a17907fa9796bd2712a9a86cbd6122a9c27 SHA512 d7d5d740c68997101f360096612700919c890c4254708102e962427de5929ce98f0f2eb5ad8dc8a56de60e8b610d502edeae7de2ac762fe0981134da379b6e64
+DIST eggdrop-1.8.3.tar.gz 1756536 BLAKE2B c2693bc383e1d857fe784d54f34479e73902064196021788ddf21f0bb2910977c643d820d2f6b640bb459b2acbfad8158fc0b29b4d76c588dfd76fee09a6fa25 SHA512 ad3b93d18aaa05d0eb00f1089b68d1f077f316042e64fff511ad1bbac06d35105adcb503490faaac4c9fe720dd45a9f350115b6c5d0f41fe198f228213a7a3a3
DIST eggdrop1.6.21.tar.bz2 999211 BLAKE2B f804ebe4f06176a6de7331d409f97ed1c3159cc32a8a06cb8c5c6e6a83bf181c7b9624a2a4aaee4d36361903a21b7ee1c052466faeebda357bb0675052e3a5da SHA512 9fd9a86c1c4b59a47a5eed4e2306e829a01bac2ad29e990ca9c0ec630d5814fd649a9216dae9ce49f734e3ac1728beb4f479ca10af583bd513f43bbbea23a653
diff --git a/net-irc/eggdrop/eggdrop-1.8.3.ebuild b/net-irc/eggdrop/eggdrop-1.8.3.ebuild
new file mode 100644
index 000000000000..86d8765154b1
--- /dev/null
+++ b/net-irc/eggdrop/eggdrop-1.8.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1
+
+DESCRIPTION="An IRC bot extensible with C or TCL"
+HOMEPAGE="https://www.eggheads.org/"
+SRC_URI="https://ftp.eggheads.org/pub/eggdrop/source/${PV:0:3}/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="debug doc ipv6 ssl static"
+
+DEPEND="
+ dev-lang/tcl:0=
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="
+ sys-apps/gentoo-functions
+ ${DEPEND}
+"
+
+DOCS=( AUTHORS FEATURES INSTALL NEWS README THANKS UPGRADING )
+
+src_prepare() {
+ # https://bugs.gentoo.org/335230
+ # https://github.com/eggheads/eggdrop/issues/526
+ sed -i \
+ -e '/\$(LD)/s/-o/$(CFLAGS) $(LDFLAGS) &/' \
+ src/mod/*.mod/Makefile* src/Makefile.in || die
+ default
+}
+
+src_configure() {
+ econf $(use_enable ssl tls) \
+ $(use_enable ipv6 ipv6)
+
+ # https://github.com/eggheads/eggdrop/issues/527
+ emake -j1 config
+}
+
+src_compile() {
+ local target
+
+ if use static && use debug; then
+ target="sdebug"
+ elif use static; then
+ target="static"
+ elif use debug; then
+ target="debug"
+ fi
+
+ emake ${target}
+}
+
+src_install() {
+ # https://github.com/eggheads/eggdrop/issues/527
+ emake -j1 DEST="${D}"/opt/eggdrop install
+
+ use doc && HTML_DOCS=( doc/html/. )
+ rm -r "${D}"/opt/eggdrop/doc/html || die
+ DOC_CONTENTS="
+ Additional documentation can be found
+ in ${EPREFIX}/opt/eggdrop/doc
+ "
+ readme.gentoo_create_doc
+ einstalldocs
+
+ dobin "${FILESDIR}"/eggdrop-installer
+ doman doc/man1/eggdrop.1
+}
+
+pkg_postinst() {
+ # Only display this for new installs
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please run ${EPREFIX}/usr/bin/eggdrop-installer to install your eggdrop bot."
+ fi
+}