summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-10-04 09:24:32 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-10-04 09:24:42 +0200
commit98f400e631edaf5ec46aadd0aaccb84cc863c7db (patch)
tree74f59f27ce968d497928968068d946f4f56cd536 /net-irc/hexchat/hexchat-9999.ebuild
parentnet-irc/hexchat: Bump to version 2.16.0 (diff)
downloadgentoo-98f400e631edaf5ec46aadd0aaccb84cc863c7db.tar.gz
gentoo-98f400e631edaf5ec46aadd0aaccb84cc863c7db.tar.bz2
gentoo-98f400e631edaf5ec46aadd0aaccb84cc863c7db.zip
net-irc/hexchat: Synced live ebuild
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-irc/hexchat/hexchat-9999.ebuild')
-rw-r--r--net-irc/hexchat/hexchat-9999.ebuild38
1 files changed, 19 insertions, 19 deletions
diff --git a/net-irc/hexchat/hexchat-9999.ebuild b/net-irc/hexchat/hexchat-9999.ebuild
index 5de62a8f2e7f..5964fd0c827e 100644
--- a/net-irc/hexchat/hexchat-9999.ebuild
+++ b/net-irc/hexchat/hexchat-9999.ebuild
@@ -22,7 +22,7 @@ fi
LICENSE="GPL-2 plugin-fishlim? ( MIT )"
SLOT="0"
-IUSE="dbus debug +gtk libcanberra libnotify libproxy lua perl plugin-checksum plugin-fishlim plugin-sysinfo python ssl theme-manager"
+IUSE="dbus debug +gtk libcanberra lua perl plugin-checksum plugin-fishlim plugin-sysinfo python ssl theme-manager"
REQUIRED_USE="lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )"
@@ -36,12 +36,13 @@ RDEPEND="
x11-libs/pango
)
libcanberra? ( media-libs/libcanberra )
- libproxy? ( net-libs/libproxy )
- libnotify? ( x11-libs/libnotify )
lua? ( ${LUA_DEPS} )
perl? ( dev-lang/perl:= )
plugin-sysinfo? ( sys-apps/pciutils )
- python? ( ${PYTHON_DEPS} )
+ python? (
+ ${PYTHON_DEPS}
+ virtual/python-cffi
+ )
ssl? ( dev-libs/openssl:0= )
theme-manager? (
|| (
@@ -70,23 +71,22 @@ pkg_setup() {
src_configure() {
local emesonargs=(
- -Dwith-gtk="$(usex gtk true false)"
- -Dwith-text="$(usex gtk false true)"
- -Dwith-ssl="$(usex ssl true false)"
- -Dwith-plugin=true
- -Dwith-dbus="$(usex dbus true false)"
- -Dwith-libproxy="$(usex libproxy true false)"
- -Dwith-libnotify="$(usex libnotify true false)"
- -Dwith-libcanberra="$(usex libcanberra true false)"
- -Dwith-theme-manager="$(usex theme-manager true false)"
-Ddbus-service-use-appid=false
- -Dwith-checksum="$(usex plugin-checksum true false)"
- -Dwith-fishlim="$(usex plugin-fishlim true false)"
- -Dwith-lua="$(usex lua ${ELUA} false)"
+ -Dinstall-appdata=false
+ -Dplugin=true
+ $(meson_feature dbus)
+ $(meson_feature libcanberra)
+ $(meson_feature ssl tls)
+ $(meson_use gtk gtk-frontend)
+ $(meson_use !gtk text-frontend)
+ $(meson_use theme-manager)
+
+ $(meson_use plugin-checksum with-checksum)
+ $(meson_use plugin-fishlim with-fishlim)
+ -Dwith-lua="$(usex lua "${ELUA}" false)"
-Dwith-perl="$(usex perl "${EPREFIX}"/usr/bin/perl false)"
-Dwith-python="$(usex python "${EPYTHON/.*}" false)"
- -Dwith-sysinfo="$(usex plugin-sysinfo true false)"
- -Dwith-appdata=false
+ $(meson_use plugin-sysinfo with-sysinfo)
)
meson_src_configure
}
@@ -94,7 +94,7 @@ src_configure() {
src_install() {
meson_src_install
dodoc readme.md
- find "${D}" -name '*.la' -delete || die
+ find "${ED}" -type f -name '*.la' -delete || die
}
pkg_preinst() {