summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-04-23 07:29:54 -0500
committerBen Kohler <bkohler@gentoo.org>2023-04-23 07:30:22 -0500
commita86757f8582b6919feefc7f18900fb4ca75d5a4b (patch)
tree470ef0015159ad98f14317dcc15168ec5073b472 /net-irc/ircii
parentnet-misc/dropbox: add 172.4.7555 (diff)
downloadgentoo-a86757f8582b6919feefc7f18900fb4ca75d5a4b.tar.gz
gentoo-a86757f8582b6919feefc7f18900fb4ca75d5a4b.tar.bz2
gentoo-a86757f8582b6919feefc7f18900fb4ca75d5a4b.zip
net-irc/ircii: add 20221016
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'net-irc/ircii')
-rw-r--r--net-irc/ircii/Manifest1
-rw-r--r--net-irc/ircii/ircii-20221016.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-irc/ircii/Manifest b/net-irc/ircii/Manifest
index ea4e7488913f..21df62f33597 100644
--- a/net-irc/ircii/Manifest
+++ b/net-irc/ircii/Manifest
@@ -1 +1,2 @@
DIST ircii-20210314.tar.bz2 590626 BLAKE2B d9b785fd043f277ab7824b2161e9f8635f106802c502a905755fd7cfa1d34f8d7533e9bed7158f3ce0639787894c5f8f4ba4c96d628d3a50a34339f5a3d8466e SHA512 3dc3a4ddb000133907edb9b867ae7cb0b36488c875f5d4f56e70d7263cf042da6c429f60a8ed6cced89bca077aec42c9d992ea6b56b2ed8b4e91f125eeced310
+DIST ircii-20221016.tar.bz2 578521 BLAKE2B 718ec9e4b5baf572a422d80932469c8c9fc24d24d2de3cebb062c30888084075b53bf386fe4b03db95631ee2c9b8e4f72a80d4bde2fb774132095dd65841a09f SHA512 36d6971810982515866fd510d5f70c4308424e66e395e3aeeb3270920daed5148b4b0f770eb5b9f15748d51f3392f48ddfd81f53edce8798076e90ffd4adc493
diff --git a/net-irc/ircii/ircii-20221016.ebuild b/net-irc/ircii/ircii-20221016.ebuild
new file mode 100644
index 000000000000..1616f0f974f2
--- /dev/null
+++ b/net-irc/ircii/ircii-20221016.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+SRC_URI="https://ircii.warped.com/${P}.tar.bz2
+ https://ircii.warped.com/old/${P}.tar.bz2
+ https://dev.gentoo.org/~bkohler/dist/${P}.tar.bz2"
+HOMEPAGE="http://eterna.com.au/ircii/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="lto"
+
+DEPEND="dev-libs/openssl:0=
+ sys-libs/ncurses:0=
+ virtual/libcrypt:=
+ virtual/libiconv"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-manpage-path.patch" )
+DOCS=( ChangeLog INSTALL NEWS README doc/Copyright doc/crypto doc/VERSIONS
+ doc/ctcp )
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ tc-export CC
+ econf $(use_with lto)
+}