summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-06-20 17:09:19 +0000
committerThomas Deutschmann <whissi@gentoo.org>2020-06-20 22:30:46 +0200
commitcc50694803ba87c82ae611e5cedeba67df063bfd (patch)
tree10d3f25783fd779b98cd61f07a0095aa9621c695 /net-irc/ngircd/ngircd-24.ebuild
parentnet-irc/ngircd: bump to 26 (diff)
downloadgentoo-cc50694803ba87c82ae611e5cedeba67df063bfd.tar.gz
gentoo-cc50694803ba87c82ae611e5cedeba67df063bfd.tar.bz2
gentoo-cc50694803ba87c82ae611e5cedeba67df063bfd.zip
net-irc/ngircd: cleanup old
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/16349 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-irc/ngircd/ngircd-24.ebuild')
-rw-r--r--net-irc/ngircd/ngircd-24.ebuild92
1 files changed, 0 insertions, 92 deletions
diff --git a/net-irc/ngircd/ngircd-24.ebuild b/net-irc/ngircd/ngircd-24.ebuild
deleted file mode 100644
index 104e09904175..000000000000
--- a/net-irc/ngircd/ngircd-24.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit user
-
-DESCRIPTION="An IRC server written from scratch"
-HOMEPAGE="https://ngircd.barton.de/"
-SRC_URI="https://arthur.barton.de/pub/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x64-macos"
-IUSE="debug gnutls iconv ident ipv6 libressl pam ssl tcpd test zlib"
-
-RDEPEND="
- iconv? ( virtual/libiconv )
- ident? ( net-libs/libident )
- pam? ( sys-libs/pam )
- ssl? (
- gnutls? ( net-libs/gnutls:= )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )
- )
- tcpd? ( sys-apps/tcp-wrappers )
- zlib? ( sys-libs/zlib )
-"
-
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- test? (
- dev-tcltk/expect
- net-misc/netkit-telnetd
- )
-"
-
-# Testsuite fails server-login-test
-RESTRICT="test"
-
-src_prepare() {
- default
-
- if ! use prefix; then
- sed -i \
- -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
- -e "s:;ServerGID = 65534:ServerGID = nogroup:" \
- doc/sample-ngircd.conf.tmpl || die
- fi
-}
-
-src_configure() {
- local myconf=(
- --sysconfdir="${EPREFIX}"/etc/"${PN}"
- $(use_enable debug sniffer)
- $(use_enable debug)
- $(use_enable ipv6)
- $(use_with iconv)
- $(use_with ident)
- $(use_with pam)
- $(use_with tcpd tcp-wrappers)
- $(use_with zlib)
- )
-
- if use ssl; then
- myconf+=(
- $(use_with !gnutls openssl)
- $(use_with gnutls)
- )
- else
- myconf+=(
- --without-gnutls
- --without-openssl
- )
- fi
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
- newinitd "${FILESDIR}"/ngircd.init-r1.d ngircd
-}
-
-pkg_postinst() {
- if ! use prefix; then
- enewuser ngircd
- chown ngircd "${EROOT%/}"/etc/ngircd/ngircd.conf || die
- fi
-}