summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorScott Martin <om@organizedmagnetism.com>2019-08-07 19:02:49 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-08-07 19:06:02 +0300
commited40d3c4d27621fdca2bec1b36fd86f476b764cb (patch)
tree849350ee0885f78db644ba6f67fe48141f1f49f8 /net-irc/quasselgrep/quasselgrep-0_p20190211.ebuild
parentdev-python/lxml: Bump to 4.4.0 (diff)
downloadgentoo-ed40d3c4d27621fdca2bec1b36fd86f476b764cb.tar.gz
gentoo-ed40d3c4d27621fdca2bec1b36fd86f476b764cb.tar.bz2
gentoo-ed40d3c4d27621fdca2bec1b36fd86f476b764cb.zip
net-irc/quasselgrep: bump to 0_p20190211
Signed-off-by: Scott Martin <om@organizedmagnetism.com> Closes: https://bugs.gentoo.org/659634 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-irc/quasselgrep/quasselgrep-0_p20190211.ebuild')
-rw-r--r--net-irc/quasselgrep/quasselgrep-0_p20190211.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-irc/quasselgrep/quasselgrep-0_p20190211.ebuild b/net-irc/quasselgrep/quasselgrep-0_p20190211.ebuild
new file mode 100644
index 000000000000..83e67c38a6bc
--- /dev/null
+++ b/net-irc/quasselgrep/quasselgrep-0_p20190211.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_REQ_USE=( sqlite )
+
+inherit distutils-r1 eutils python-r1
+
+DESCRIPTION="Tool for searching quassel logs from the commandline"
+HOMEPAGE="https://github.com/fish-face/quasselgrep"
+
+if [[ "${PV}" == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/65278/quasselgrep.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ MY_COMMIT=9b6b0bc1252daa6e574363d87d04eebd981215a5
+ SRC_URI="https://github.com/fish-face/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+ S="${WORKDIR}/fish-face-${PN}-${MY_COMMIT:0:7}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-lang/python[${PYTHON_REQ_USE}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]"
+
+pkg_postinst() {
+ optfeature "access postgres db" dev-python/psycopg:2
+}