summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2017-07-03 22:44:18 +1000
committerSam Jorna <wraeth@gentoo.org>2017-07-03 22:44:36 +1000
commit4dcf3260e40b29e2cb44010685706234feeb7ee7 (patch)
treebb3536d14604940744ae34b11597207cbcfa74fc /net-irc/quasselgrep
parentprofiles: unmask media-fonts/ttf-bitstream-vera (diff)
downloadgentoo-4dcf3260e40b29e2cb44010685706234feeb7ee7.tar.gz
gentoo-4dcf3260e40b29e2cb44010685706234feeb7ee7.tar.bz2
gentoo-4dcf3260e40b29e2cb44010685706234feeb7ee7.zip
net-irc/quasselgrep: new package
New package submitted by ephemer0l for searching Quassel logs. Gentoo-bug: 620408 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-irc/quasselgrep')
-rw-r--r--net-irc/quasselgrep/Manifest1
-rw-r--r--net-irc/quasselgrep/metadata.xml11
-rw-r--r--net-irc/quasselgrep/quasselgrep-0_p20170411.ebuild34
-rw-r--r--net-irc/quasselgrep/quasselgrep-9999.ebuild34
4 files changed, 80 insertions, 0 deletions
diff --git a/net-irc/quasselgrep/Manifest b/net-irc/quasselgrep/Manifest
new file mode 100644
index 000000000000..4d0e6c44567b
--- /dev/null
+++ b/net-irc/quasselgrep/Manifest
@@ -0,0 +1 @@
+DIST quasselgrep-0_p20170411.tar.gz 29117 SHA256 06f7729c3f51a728b93a82979ca0adb4135ce8345bb55deaeb42aa9a985ab229 SHA512 b216c49e340cddfeb4fe28046c698a5517a873602a4303c7c6976d6d7f0bfffbb78f170a33126a16089e239a67e1624410f8e727b5ed6ab977f78745362db0e2 WHIRLPOOL 97ad005be19910c2ce503b12c3d4ff4e7c8be74054802847a8b2be444823511bcc508d075f2073a89c671bfae2d7e1fd2f22dc225c68d74056c179d78cf9601c
diff --git a/net-irc/quasselgrep/metadata.xml b/net-irc/quasselgrep/metadata.xml
new file mode 100644
index 000000000000..09746d072a90
--- /dev/null
+++ b/net-irc/quasselgrep/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>om@organizedmagnetism.com</email>
+ <name>Scott Martin</name>
+ </maintainer>
+ <upstream>
+ <doc>https://github.com/fish-face/quasselgrep/blob/master/README.md</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/net-irc/quasselgrep/quasselgrep-0_p20170411.ebuild b/net-irc/quasselgrep/quasselgrep-0_p20170411.ebuild
new file mode 100644
index 000000000000..efe0f9483d65
--- /dev/null
+++ b/net-irc/quasselgrep/quasselgrep-0_p20170411.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_COMMIT=502c88bdc7613abb68e868eb520e39ec8a5cf6dd
+
+DESCRIPTION="Tool for searching quassel logs from the commandline"
+HOMEPAGE="https://github.com/fish-face/quasselgrep"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/fish-face/quasselgrep"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fish-face/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+ S="${WORKDIR}/fish-face-${PN}-${MY_COMMIT:0:7}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.5.3[${PYTHON_USEDEP}]"
+
+src_configure() {
+ sed -i 's/pycrypto/pycryptodome/g' "${S}"/setup.py || die "sed failed"
+}
diff --git a/net-irc/quasselgrep/quasselgrep-9999.ebuild b/net-irc/quasselgrep/quasselgrep-9999.ebuild
new file mode 100644
index 000000000000..efe0f9483d65
--- /dev/null
+++ b/net-irc/quasselgrep/quasselgrep-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+MY_COMMIT=502c88bdc7613abb68e868eb520e39ec8a5cf6dd
+
+DESCRIPTION="Tool for searching quassel logs from the commandline"
+HOMEPAGE="https://github.com/fish-face/quasselgrep"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/fish-face/quasselgrep"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/fish-face/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
+ S="${WORKDIR}/fish-face-${PN}-${MY_COMMIT:0:7}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/psycopg-2.5.3[${PYTHON_USEDEP}]"
+
+src_configure() {
+ sed -i 's/pycrypto/pycryptodome/g' "${S}"/setup.py || die "sed failed"
+}