summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-irc/ultimate/files/ultimate-3.0.2-system-zlib-r1.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-irc/ultimate/files/ultimate-3.0.2-system-zlib-r1.patch')
-rw-r--r--net-irc/ultimate/files/ultimate-3.0.2-system-zlib-r1.patch53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-irc/ultimate/files/ultimate-3.0.2-system-zlib-r1.patch b/net-irc/ultimate/files/ultimate-3.0.2-system-zlib-r1.patch
new file mode 100644
index 000000000000..acbb71c73d42
--- /dev/null
+++ b/net-irc/ultimate/files/ultimate-3.0.2-system-zlib-r1.patch
@@ -0,0 +1,53 @@
+From: Nathan Phillip Brink <ohnobinki@ohnopublishing.net>
+Subject: Don't compile against internal zlib. Missing ./configure.ac
+ changes because ./configure.ac wasn't shipped with the dist
+ tarball.
+Date: 2011/04/27
+Subject: Use @ZLIB_LIBS@ and @ZLIB_CFLAGS@ instead of $(ZLIB_LIBS) and
+ friends because we don't get AC_SUBST() declared as Makefile
+ variables for free. https://bugs.gentoo.org/371889
+Date: 2011/06/16
+
+--- a/autoconf/configure.in
++++ b/autoconf/configure.in
+@@ -702,6 +702,8 @@
+ wi_ARG_DISABLE_CCDV
+ wi_PROG_CCDV
+
++PKG_CHECK_MODULES([ZLIB], [zlib])
++
+ AC_SUBST(SSL_INCLUDES)
+ AC_SUBST(SSL_LIBS)
+ AC_SUBST(ENCRYPT_SRC)
+@@ -716,7 +718,7 @@
+ AC_SUBST(SEDOBJ)
+ AC_SUBST(CCDV)
+
+-AC_OUTPUT(Makefile data/Makefile data/networks/Makefile src/Makefile tools/Makefile tools/ircdcron/Makefile tools/ssl-cert/Makefile zlib/Makefile)
++AC_OUTPUT(Makefile data/Makefile data/networks/Makefile src/Makefile tools/Makefile tools/ircdcron/Makefile tools/ssl-cert/Makefile)
+
+ echo
+ echo =================================================================
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -28,3 +28,3 @@
+ SHELL=/bin/sh
+-SUBDIRS=zlib src tools data @SUBDIR_MESSAGES@
++SUBDIRS = src tools data @SUBDIR_MESSAGES@
+ SUBDIRS2=data/networks tools/ircdcron tools/ssl-cert
+
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -53,9 +53,9 @@
+ SSL_LIBS = @SSL_LIBS@
+ SSL_INCLUDES = @SSL_INCLUDES@
+
+-IRCDLIBS = ../zlib/libz.a @LIBS@ $(SSL_LIBS)
++IRCDLIBS = @ZLIB_LIBS@ @LIBS@ $(SSL_LIBS)
+
+-INCLUDES = -I../include -I../zlib $(SSL_INCLUDES)
++INCLUDES = -I../include @ZLIB_CFLAGS@ $(SSL_INCLUDES)
+ CPPFLAGS = ${INCLUDES} @CPPFLAGS@
+
+ default: all
+