summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-07 13:09:27 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-07 13:09:56 +0100
commitfcbbc6c644bc2103a486195a62fcad917d8f386a (patch)
tree6a5a761392b4defd6d881618f059800c225ffeee /net-irc/weechat/weechat-9999.ebuild
parentx11-misc/xvkbd: Version 3.8. (diff)
downloadgentoo-fcbbc6c644bc2103a486195a62fcad917d8f386a.tar.gz
gentoo-fcbbc6c644bc2103a486195a62fcad917d8f386a.tar.bz2
gentoo-fcbbc6c644bc2103a486195a62fcad917d8f386a.zip
net-irc/weechat: Test LINGUAS rather than linguas_* USE flags.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-irc/weechat/weechat-9999.ebuild')
-rw-r--r--net-irc/weechat/weechat-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/net-irc/weechat/weechat-9999.ebuild b/net-irc/weechat/weechat-9999.ebuild
index 59575ed9f9d6..dd1313a0c730 100644
--- a/net-irc/weechat/weechat-9999.ebuild
+++ b/net-irc/weechat/weechat-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,7 +25,7 @@ PLUGINS="+alias +buflist +charset +exec +fset +fifo +logger +relay +scripts +spe
# dev-lang/v8 was dropped from Gentoo so we can't enable javascript support
SCRIPT_LANGS="guile lua +perl php +python ruby tcl"
LANGS=" cs de es fr hu it ja pl pt pt_BR ru tr"
-IUSE="doc nls +ssl test ${LANGS// / linguas_} ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
+IUSE="doc nls +ssl test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
@@ -77,7 +77,7 @@ src_prepare() {
# install only required translations
local i
for i in ${LANGS} ; do
- if ! use linguas_${i} ; then
+ if ! has ${i} ${LINGUAS-${i}} ; then
sed -i \
-e "/${i}.po/d" \
po/CMakeLists.txt || die
@@ -87,7 +87,7 @@ src_prepare() {
# install only required documentation ; en always
for i in $(grep add_subdirectory doc/CMakeLists.txt \
| sed -e 's/.*add_subdirectory(\(..\)).*/\1/' -e '/en/d'); do
- if ! use linguas_${i} ; then
+ if ! has ${i} ${LINGUAS-${i}} ; then
sed -i \
-e '/add_subdirectory('${i}')/d' \
doc/CMakeLists.txt || die