summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Qian <i@bitbili.net>2023-02-26 17:05:23 +0800
committerMatthew Smith <matthew@gentoo.org>2023-03-08 15:22:49 +0000
commit7a5ec9aba929de9e3058779243913969ac6b6ac9 (patch)
tree3bacdad67965194d3d6e8431ed5a21fbc8dc3916 /net-irc/weechat
parentprofiles: mask x11-plugins/purple-hangouts for removal (diff)
downloadgentoo-7a5ec9aba929de9e3058779243913969ac6b6ac9.tar.gz
gentoo-7a5ec9aba929de9e3058779243913969ac6b6ac9.tar.bz2
gentoo-7a5ec9aba929de9e3058779243913969ac6b6ac9.zip
net-irc/weechat: add new USE flag 'enchant' for spell checker plugin
Version 3.8 already has compile support for enchant-2, both enchant and enchant-2 now work well for Spell checker plugin. Signed-off-by: Ryan Qian <i@bitbili.net> Closes: https://github.com/gentoo/gentoo/pull/29802 Acked-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'net-irc/weechat')
-rw-r--r--net-irc/weechat/metadata.xml1
-rw-r--r--net-irc/weechat/weechat-3.8.ebuild9
2 files changed, 8 insertions, 2 deletions
diff --git a/net-irc/weechat/metadata.xml b/net-irc/weechat/metadata.xml
index d2ef9242b266..f8a6ae8d9289 100644
--- a/net-irc/weechat/metadata.xml
+++ b/net-irc/weechat/metadata.xml
@@ -13,6 +13,7 @@
<flag name="alias">Enable plugin for alias control</flag>
<flag name="buflist">Enable buflist plugin</flag>
<flag name="charset">Enable encoding conversions</flag>
+ <flag name="enchant">Enable spell checker plugin via Enchant instead of GNU Aspell</flag>
<flag name="exec">Enable exec plugin</flag>
<flag name="fset">Enable fast set plugin</flag>
<flag name="fifo">Enable FIFO support (sh pipes)</flag>
diff --git a/net-irc/weechat/weechat-3.8.ebuild b/net-irc/weechat/weechat-3.8.ebuild
index 12b8e8a9bda7..a10572d3f909 100644
--- a/net-irc/weechat/weechat-3.8.ebuild
+++ b/net-irc/weechat/weechat-3.8.ebuild
@@ -32,9 +32,10 @@ PLUGINS="+alias +buflist +charset +exec +fifo +fset +logger +relay +scripts +spe
# dev-lang/php eclass support is lacking, php plugins don't work. bug #705702
SCRIPT_LANGS="guile lua +perl +python ruby tcl"
LANGS=" cs de es fr it ja pl ru"
-IUSE="doc man nls selinux test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
+IUSE="doc enchant man nls selinux test ${SCRIPT_LANGS} ${PLUGINS} ${INTERFACES} ${NETWORKS}"
REQUIRED_USE="
+ enchant? ( spell )
lua? ( ${LUA_REQUIRED_USE} )
python? ( ${PYTHON_REQUIRED_USE} )
test? ( nls )
@@ -61,7 +62,10 @@ RDEPEND="
)
)
selinux? ( sec-policy/selinux-irc )
- spell? ( app-text/aspell )
+ spell? (
+ enchant? ( app-text/enchant:* )
+ !enchant? ( app-text/aspell )
+ )
tcl? ( >=dev-lang/tcl-8.4.15:0= )
"
@@ -136,6 +140,7 @@ src_configure() {
-DENABLE_BUFLIST=$(usex buflist)
-DENABLE_CHARSET=$(usex charset)
-DENABLE_DOC=$(usex doc)
+ -DENABLE_ENCHANT=$(usex enchant)
-DENABLE_EXEC=$(usex exec)
-DENABLE_FIFO=$(usex fifo)
-DENABLE_FSET=$(usex fset)